cancel
Showing results for 
Search instead for 
Did you mean: 

RAMCFG_MxCR ECCE bit not set even after SRAMxECC is enabled(0) in FLASH_OPTR

harisuvarna
Associate II

Hi,

I have enabled option bit SRAMxECC is in FLASH_OPTR by following sequence mentioned in datasheet to enable SRAM ECC, However RAMCFG_MxCR ECCE still shows as 0(disabled). Please do the needuful.

harisuvarna_0-1718831916888.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
harisuvarna
Associate II

ECCE bit in register RAMCFG is setting to 1 after I enable clock for RAMCFG module in RCC register 

harisuvarna_0-1719245070771.png

Thanks,

Hareesha

View solution in original post

3 REPLIES 3
Imen.D
ST Employee

Hello @harisuvarna 

Check the STM32U5 Errata, you may have the same condition described in section: SRAM ECC error flags and addresses are updated only if interrupt is enabled.

ImenD_0-1719000893783.png

When your question is answered, please close this topic by clicking "Accept as Solution".
Thanks
Imen

Hi Iman,

Thank you for the response. I do enable RAM ECC interrupts in register RAMCFG_MxIER.  

Section 6.3.2 of ST User Manual (RM0456) says following

harisuvarna_0-1719004750896.png

But ECCE bit is not automatically set even though SRAM ECC is enabled in FLASH_OPTR. 

Regards,

Hareesha

 

harisuvarna
Associate II

ECCE bit in register RAMCFG is setting to 1 after I enable clock for RAMCFG module in RCC register 

harisuvarna_0-1719245070771.png

Thanks,

Hareesha