Showing results for 
Search instead for 
Did you mean: 

"validate on target" Error on STM32H747I-DISCO:E 801(HwIOError): Invalid firmware - COM5:115200

Associate II

Hi, I need help. I checked all the answers to this question in the community, and tried many methods, but still did not solve.

when I use the M4 core and validating an ONNX model on target (STM32F747I-DISCO), I got the following error:

E200(ValidationError): stm32: Unable to bind the STM AI runtime with "network" c-model: []

connection to "serial:115200"/"115200" run-time fails

E801(HwIOError): Invalid firmware - COM5:115200

0693W00000FD0LjQAL.jpgHere are some methods I tried:

(1)I use the stm32h747i M7 core successfully "validation on target".


(2) when i use the M4 core,I re-selected the of the M4 version and reconfigured the usart .It was successful "validation on target" when debugging.But after I run and download successfully,I "validate on target" and got the top error .

note:When I reset the development board, the model in the board is not the model just downloaded (downloaded before). Therefore, I think when I using the M4 core to develop, the model is not downloaded into the board(even if it shows that the download was successful), but I don't know how to solve this problem.

Thank you very much for your time.

Associate II

I upload the complete code here, hoping to get your help.

Associate II

I successfully solved the problem. There are many reasons. If you understand Chinese, please see here.

Associate II

How do you solve this problem finally? 请问您是怎么解决的这个validate的问题,是知乎里�?�的他说的第几�?�?

Could you explain how you solved the problem ? I guess there are a few here who dont read chinese.

I tried on H747I-DISCO followed his instruction. If you are using a board with double cores, you can try to switch to Cortex-M7 only for X-CUBE-AI.

0693W00000NrgJrQAJ.pngBut it doesn't help to fix the same problem on my H735-DK board.

Associate II

im also facing this problem trying to run a simple NN on my STM32F769-DK, it says it is a single core processor, and i have done other steps in zhizu article, still getting the error, how to resolve it?