Showing results for 
Search instead for 
Did you mean: 

[AI:network] Error: IDE EWARM V8 not found & invalid firmware or the board should be re-started


I am using cube ai 5.0.0 , and the version of my IAR is v8.32.

My board is NUCLEO-LM476RG.

I followed the tutorial exactly step by step, but it raised this error.

What can I do?

The further question is: is validation on target necessary?

I can validate my network on colab.

Can I develop my own applications without this step?




I solved the IDE not found problem by installing IAR at disk C,

​but I found another problem.

LOAD ERROR: STM32 - no connected board(s), invalid firmware or the board should be re-started



I solved it on my own.

You must connect your USART port to the PC.

You have to implement the hardware connection.

Therefore you will have to use 2 port to "control" the board.


Note that this port is different from the port connecting the board.

So when validating on target, you have to select the right COM port which

CONNECTS TO YOUR USART, not the board.

Or you will not surprisingly get the error: no connected board(s),

(In my case COM3 connects my L476RG board and COM6 connects my USART3.)


ST Employee


About the question "is validation on target necessary?"

In theory,  validation on target or on desktop step is not necessary to develop our own STM32 application. This step is just a facilty ("on-click" environment) to check that the generated code will be correct, in particular computation point of view. By default this validation step (target or desktop) uses the random sample (fix seed with uniform distibution between [-1,1]) to provide a first level of result, however the right pratice is to provide a representative sub-set of a validation data-set to have a coherent distributon of the input values.

As mentionned by you, this step is not here to valid a model, should be done in the origninal training DL framework environment, colab... This is just a step to valid the generated code.



Associate II


The solution - to use an additional USART to connect to a new COM port for validation on Target worked perfectly!

Thank you for your answer.

Details: Board Nucleo64 L476RG

STM32CubeMx 5.5.0 , STM32CubeIDE Version: 1.2.0, X-CUBEAI 5.0.0

Best Regards,

Yuvaraj Govindarajulu