Showing results for 
Search instead for 
Did you mean: 

STM32F0 USB CDC not working with Windows 7

Associate II

Hi all,

I have a custom board made with STM32F070C6T6. I tried to implement USB CDC, and everything works fine on Windows 10 but in Windows 7 I cannot open the serial port although the Device Manager recognize it and the device status says "This device is working properly". I have tried Realterm, Putty as well as my own PC test application. The interesting thing is this custom board is one of 12 boards in the same production lot, and all other boards work okay with Windows 7 so I doubt the problem is in the firmware, but again anything is possible. Does anyone have this problem before or know the answer to this?

Thanks in advance,



Just to clarify, you have 12 boards and 12/12 work in windows 10 but only 11/12 work in windows 7?

you could use usb pcap to look at the usb packets. Seems strange though if you’re not getting device manager errors.

If you feel a post has answered your question, please click "Accept as Solution".