Showing results for 
Search instead for 
Did you mean: 

stm32f103c8t6 debug error

Associate II


I get the following error when I debug with blue pill. see the attached picture error.PNGerror1.PNG


How can i fix that? thank you in advance


Perhaps wired up wrong, not much to work with here...

Check you've got SWDIO, SWCLK, VCC and GND wired up minimally.

Perhaps check with STM32 Cube Programmer.

Has this worked before, or on other boards? Real STM32 on the board?

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..
ST Employee

Firstly, as has often been discussed here in the community (e.g. here or there), the Blue Pills have not been built with original STM32F103s for years, but with cheap counterfeits that are not (or cannot be) supported - which is what @Tesla DeLorean means with his last question.

Secondly, are you using an original ST-LINK from an authorised dealer (i.e. not from Ebay or other ‘trustworthy’ sources), or one in a tin can? With the latter, the connection may not work either, as these are also cheap counterfeits that are not (or cannot be) supported.


In order to give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.