Showing results for 
Search instead for 
Did you mean: 

STM32 NUCLEO-F767ZI 3.3V power source from X-NUCLEO-LPM01A



I am trying to power up my F767ZI board from the 3.3V power given by X-NUCLEO-LPM01A. Strangely, when I measure the voltage from X-NUCLEO-LPM01A with a multimeter (on the 3.3V input pins on the F767ZI board), I see the output voltage is only 1.6V to 1.7V (or about1.2V if I pull a wire from 3.3V input to SWD's RST signal to prevent STLINK from resetting my board[*]), despite that I had set it to 3.3V. The board does not start up as well. 

More observations:

1) This only happens when I use X-NUCLEO-LPM01A as power source. When I used another DC power source, I could measure 3.3V on the board's 3.3V input pins just as I set it. The program on board also run normally.

2) This only happens when I set X-NUCLEO-LPM01A's output voltage to 3V or 3.3V. When I tried setting it to 2.4V, I measured 2.4V on the board's input pins, and the program on board could run.

3) This only happens when I use F767ZI. I have tried G0B1RE, L4R5ZI and U575ZI and all of those could work normally.

Additional information:

I have removed SB3 from the board to prevent the 3.3V input from going into the on-board 3.3V voltage regulator. This however had happened even before I remove it, so I don't think the regulator plays a part.


I have not found an answer from the board's manual, and I appreciate it very much for any help.


[1] I do this because boards like F767ZI does not have a jumper to disconnect STLINK's reset signal, and thus I found the board is always in reset if STLINK is not powered. For this board, I have not removed SB111 to disconnect STLINK reset, so I would just connect 3.3V to the NRST pin of SWD to prevent getting the RST signal from STLINK.

ST Employee

Hello @ShmL

I couldn't reproduce your issue on my side, using a NUCLEO-F767ZI and X-NUCLEO-LPM01A, I can measure 3.12V with the multimeter which is acceptable.

Thinking about if the ST-LINK drawing some current, it won't be as aggressive as 1.6V 

This leaves me with 2 hypotheses, one being hardware-related, did you do any previous manipulation on the board, soldering or removing jumpers apart from SB3? 

the other hypothesis is related to your application, could you give more context on your manipulation, maybe your application requires more current than the power shield can provide! 

Waiting for your updates! 



To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.