Showing results for 
Search instead for 
Did you mean: 

Technical Support Needed for NeuroLeap's STEVAL-MKI193V1 Setup



I run into some technical challenges during the integration process of STEVAL-MKI193V1 with the nrf52-dk development kit. 

Brief Overview of the Setup:

· STEVAL-MKI193V1 is powered with a 3.3V supply for VDD, VDDIO, and CS pins.

· CS pin is connected to a 3.3V supply

· SDx and SCx pins are grounded.

· SDA and SCL pins use a 5k ohm pull-up resistor to 3.3V.

· All other pins are currently unconnected.

Issues Faced:

1. After connecting the sensor to the nrf52-dk development kit and subsequently to a computer via USB, we are unable to detect the sensor or receive any data from it.

2. At times, the program crashes and stops immediately, which means the terminal stops outputting any information, after or during the TWI initialization function.

The nrf52-dk works with other sensors which means the problem should be on STEVAL-MKI193V1.

Concerning the software, I am using Segger Embedded Studio. Interestingly, when I disconnect the pull-ups for SDA and SCL, the program initiates and the terminal starts outputting but promptly hits an error code of 33281. This error indicates that the slave did not respond to the serial address, which is reasonable because there are no pull-ups.

Federica Bossi
ST Employee

Hi @marshall373 ,


I have some questions to better understand your problem:

- How did you polarize the SDO?

- Which I2C address did you use?

In addition, can you share some signal acquisitions with the oscilloscope?

In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.