Showing results for 
Search instead for 
Did you mean: 


Associate II

Hello, im using STM32f410CBT3 on custom board. I was able to debug before, but now Im getting errors trying to conect to STM32 using stlink v3 set with isolation. Sometimes i can read data, but it is corrupted (all 0, but i didnt flashed it yet). Tried replacing CPU, but it didnt work. The nRST is conected with capasitor to gnd and i tried adding pull up with 10k (this cpu has pull up inside).

 Im desperate for help.

Thank you all in advance.


When measuring voltage on Nrst, it shows 0,6 V. I gues it is floating, but why...


Show the salient parts of the schematic for this custom board.

Do you have Analogue VDD/VSS connected? VDDA / VSSA needed regardless of ADC/DAC usage

Check chip orientation

Check 1.25V at VCAP pins, 2u2 F on each, or 4u7 F on connected?


Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..


Everything is conected. What is most interesting for me, is that i was able to program it few weeks ago, but then my programmer shorted, so i bought new one and this started to happen

If NRST is low it suggest something is wrong internally or the supplies.

Try replacing the chip, or a second board..

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

wasted 3 chips now trying. I gues ill try with second board

maybe it is stlink, thats causes problems? It conects to pc, but maybe it somehow breaks nRST? Dont know how much sense this scenario has

Nothing is jumping out on the design.

The NRST should have an internal pull-up

If you can pull BOOT0 HIGH you could perhaps skip the ST-LINK and program via the serial port, see AN2606 / AN3155

The ST-LINK only need be used from programming.

Otherwise look at your code, doing anything to put the chip in a low power mode?

The STM32 can driver the NRST low, check data sheet, things like low power, watchdogs, etc.

Did those chips fail immediately, you programmed a dozen times? Any life story there which might shed some broader light on the issue? Hard to know without hearing more information about symptoms, etc.

Check board for shorts, check net-list for missing or unanticipated connectivity of nets.

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

Okey, Im going to write all that has happened before.

I was programing it sucsesfully using STlink V3 Minie few weeks ago, but it somehow shorted (Minie) and damaged mcu, so i bought STlink v3 set with iso set and using it now.

When using STlink v3 set yesterday i was able to flash code into MCU, but when i tried conecting second time, the nRST line was floating at 0,4-0,6 V, so today i swiched the MCU to new one and i wasnt able to flash even once. The target_under_reset error got displayed and using hot plug mode i read all 0 (it should be all F's, because i didnt flash program). When measuring voltage with multimeter on nRST line, it is 0,4-0,6 V again. Its a shame i didint check nRST line voltage before connecting stlink

Few days ago i shorted the board on accident, but changed all components that was shorted before using again. This was before yesterday.

The current consumption yesterday before flashing was 1 mA. After flashing it was 1-2 mA, but when nRST line became floating it jumped from 1 to 8 mA sometimes and sometimes got back to 1-2 mA. 

Before STlink v3 minie got shorted i used to program MCU for a week, so more than dozen times i was able to program it. When STlink v3 minie shorted i got all kinds of errors trying to conect to MCU.