Showing results for 
Search instead for 
Did you mean: 

Invalid Network Error in loading model and unable to check AI Application.


I tried Cube AI like youtube But I got some difficulties.

I use Cube MX 5.0.1,Cube AI 3.3.0.

1.   Invalid Network Error

In mcu selection, I selected Github Model file and pushed analyze button in the funtion item. Then I got Invalid network error and difficult to analyze the model.

In the youtube, here :

2.   Unable check AI in the Pinout & Configuration Setting

I selected F7 MCU. But the item of Artificial intelligence doesn’t appear in the Application software. I tried to display the item by checking AI in the additional software. But the item doesn’t appear in the Application.

In the youtube, here :

Anyone has solutions?

Thank you.

Associate III


Could you provide us the complete output log and the CubeMX log while reproducing the error ?

(CubeMX log is located at: C:\Users\[username]\.stm32cubemx\STM32CubeMX.log)

Thank you

Jonathan Roberts
Associate II

I get the same error when I try and analyse the HAR-CNN-Keras Model from Github: This is the relevant snippet from the STM32CubeMX.Log file:

2019-01-07 16:23:57,845 [INFO] McuExtendedFiltersManager:82 - Reset MCU extended filter: Artificial Intelligence
2019-01-07 16:24:12,555 [ERROR] AIPython:88 - Error: no directory found: C:/Users/another/STM32Cube/Repository//Packs/STMicroelectronics/X-CUBE-AI/3.3.0/Utilities/windows
2019-01-07 16:24:12,555 [INFO] AIPython:100 - Command: C:/Users/another/STM32Cube/Repository//Packs/STMicroelectronics/X-CUBE-AI/3.3.0/Utilities/windows/generatecode --auto -c C:/Users/another/AppData/Local/Temp/mxAI11374476597176510148740718862498/
2019-01-07 16:24:12,565 [INFO] AIPython:153 - Exception in python generation: Cannot run program "C:/Users/another/STM32Cube/Repository//Packs/STMicroelectronics/X-CUBE-AI/3.3.0/Utilities/windows/generatecode" (in directory "C:\Users\another\STM32Cube\Repository\Packs\STMicroelectronics\X-CUBE-AI\3.3.0\Utilities\windows"): CreateProcess error=2, The system cannot find the file specified

The console in STM32CubeMX shows:

Command: Command: C:/Users/another/STM32Cube/Repository//Packs/STMicroelectronics/X-CUBE-AI/3.3.0/Utilities/windows/generatecode --auto -c C:/Users/another/AppData/Local/Temp/mxAI11374476597176510148740718862498/
 Invalid network

The following path has no files or directories present:


The parent directory includes the 3.3.0 folder and what looks like an extraction of the the install pack in a TMPUPD folder.

Hope this figures out what the problem is..


Copying the contents of :




Seems to resolve the problem running analyse. It looks like the installer hasn't worked correctly.

I also don't see the "Additional Software" option on the LHS after enabling the AI Application and AI Core settings. From these messages in the log I guess other parts of the install also failed:

2019-01-07 17:13:51,330 [INFO] UITreeTableRework:854 - In
2019-01-07 17:13:51,337 [ERROR] Mcu:515 - ThirdParty IPModes/IPconfigs doesn't exist for :C:/Users/another/.stm32cubemx/plugins/thirdparty/db//STMicroelectronics/X-CUBE-AI/3.3.0/STMicroelectronics.X-CUBE-AI.3.3.0_Modes.xml
2019-01-07 17:14:50,608 [INFO] UITreeTableRework:854 - In
2019-01-07 17:14:50,608 [ERROR] Mcu:515 - ThirdParty IPModes/IPconfigs doesn't exist for :C:/Users/another/.stm32cubemx/plugins/thirdparty/db//STMicroelectronics/X-CUBE-AI/3.3.0/STMicroelectronics.X-CUBE-AI.3.3.0_Modes.xml

Associate III

There are effectively problems during the installation, try deleting X-Cube-AI from CubeMX, then go to "C:\Users\[username]\STM32Cube\Repository\Packs\STMicroelectronics" and check that X-Cube-AI is no more present (delete it if present). Be sure that no process is using the directory and try re-installing the X-Cube-AI from CubeMX

Additionally what you can try is a manual installation by downloading the plugin here (bottom of the page) :

Then go to Help > Embedded Software Packages Manager and click on "From Local" to browse the file you just get

Hope this can help

Thank you.

​CubeMX log is here.

2019-01-07 22:29:32,388 [ERROR] AIPython:88 - Error: no directory found: C:/Users/***/STM32Cube/Repository/Packs/STMicroelectronics/X-CUBE-AI/3.3.0/Utilities/windows
2019-01-07 22:29:32,407 [INFO] AIPython:100 - Command: C:/Users/***/STM32Cube/Repository/Packs/STMicroelectronics/X-CUBE-AI/3.3.0/Utilities/windows/generatecode --auto -c C:/Users/***/AppData/Local/Temp/mxAI21338039797414705533947946921371644/
2019-01-07 22:29:32,431 [INFO] AIPython:153 - Exception in python generation: Cannot run program "C:/Users/***/STM32Cube/Repository/Packs/STMicroelectronics/X-CUBE-AI/3.3.0/Utilities/windows/generatecode" (in directory "C:\Users\***\STM32Cube\Repository\Packs\STMicroelectronics\X-CUBE-AI\3.3.0\Utilities\windows"): CreateProcess error=2, cannot find files.
2019-01-07 22:29:32,663 [INFO] New_gui_TipPanel:170 - scale :0.21235194585448391
2019-01-07 22:29:36,157 [INFO] ApiDb:186 - Save user favorites file C:\Users\***/.stm32cubemx/favorites.mcus.txt: 0 item(s)
2019-01-07 22:29:36,159 [INFO] ApiDb:191 - User favorites MCUs=[]
2019-01-07 22:29:36,165 [INFO] ApiDb:186 - Save user favorites file C:\Users\***/.stm32cubemx/favorites.boards.txt: 0 item(s)
2019-01-07 22:29:36,166 [INFO] ApiDb:191 - User favorites Boards=[]

From the log, the probrem may be the instalation fail of the ai pack.

The dedicated folder doesn't exit and I reinstalled it again.

But​ I got the error again.

Finally, I succeeded the execution.

The solution is deleting X-Cube-AI folder completely and reinstalling it again.

Thank you.

Also seeing the same error shown in the CubeMX dialog, but have a different log remark:

[INFO] AIPython:108 - INVALID MODEL: Model saved with Keras 2.2.4-tf but <= 2.2.4 is supported

It appears the latest Keras version appends "tf" unfortunately, and the code may not handle that properly?

You are right for this problem, in the next version of the pack this problem will be fixed


Hi everyone, i am having a similar issue , i get a invalid network error window once i start to analyze. Please find below the log:

2019-10-17 17:35:39,958 [INFO] AIPython:126 - Command used: C:/Users/Preeti/STM32Cube/Repository//Packs/STMicroelectronics/X-CUBE-AI/3.4.0/Utilities/windows/generatecode --auto -c C:/Users/Preeti/AppData/Local/Temp/mxAI117732111163906505095478914033096/

2019-10-17 17:35:39,974 [INFO] AIPython:196 - Exception in python generation: Cannot run program "C:/Users/Preeti/STM32Cube/Repository//Packs/STMicroelectronics/X-CUBE-AI/3.4.0/Utilities/windows/generatecode" (in directory "C:\Users\Preeti\STM32Cube\Repository\Packs\STMicroelectronics\X-CUBE-AI\3.4.0\Utilities\windows"): CreateProcess error=216, This version of %1 is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need a x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher