Showing results for 
Search instead for 
Did you mean: 

Blue_NRG-2 examples load but dont run

Associate II

I am trying to develop some custom code using the BlueNRG-2 chip. I have my own custom board but first I am trying to get things to work on the STEVAL-BCN002V1 blue tile. That board comes preloaded with the Sensor Demo which worked fine. I am using the latest KEIl IDE for the BlueNRG series. I also dowloaded all of the recent DK files for the Tile board and the BlueNRG. 

I opened the Sensor Demo in Kiel. It compiled correctly. It seemed to download ok and the board ran as normal. Then I tried a few other examples such as the remote control. This also compiled and downloaded ok. This also worked as normal. When I went back to reload the Sensor Demo, Keil couldn't find the board. I ended up using the BlueNRG utility and that allowed me to connect and erase the chip. Then Keil downloaded the SensorDemo again with no problem. However, the code doesnt work. All I get is a green LED lit. I cant even run the debugger, it never starts anywhere. If I go back to the remote control firmware, that loads ok again and runs.

I even tried directly loading the bin and hex files from the DK files which were compiled from ST and I get the same issue, just a green LED. I have two of these development boards and the exact same thing happened to both. The starting address for both Keil and the BlueNRG Utility seem to start at 0x10040000.

I tried a few other examples such as the throughput server example and that worked to. It seems to be related to the Sensor examples. I even tried an old hex file from last year that has worked with no problem and that also just gives me a green LED and no operation.

Any help would be greatly appreciated.