Showing results for 
Search instead for 
Did you mean: 

Login to ST website is broken for some global locations



I tried to report this problem to OLS but they seem to be not listening to my issue. I hope to explain the problem further here so that (like the OLS) you don't just tell me that the problem is with my computer.

I have a number of people (including myself) that cannot log in to the ST website or register an account here in Australia. I personally have tried three different operating systems, two different internet connections, three different browsers, and even one fresh install of linux in a virtual machine and all three show the same problem. I have also had multiple colleagues try on their computers on different internet connections and they too are not able to log in properly. The login is also broken in CubeIDE.

The problem with the registration form is that you cannot submit it. The problem with the login page is that you submit it and it just redirects back to the same login page without logging in.

If I try to submit on the login page with an incorrect password, I get the error "null", so I know that it is at least processing the password in some way.


Whereas if I enter my correct password, I get no error and I just get sent back to the login page.

On the registration page, if you open the javascript console in the browser, you get this error message (it's also present on the login page):


This "Uncaught ReferenceError: MktoForms2 is not defined" means that whatever forms library your website is using is not loading correctly. Looking at the HTML of the page, you can see that this is loaded via a javascript file called "forms2.min.js":


However, if I go to I do not get a javascript file, in fact I get the contents of a different file which is more commonly known as a robots.txt file:


Given that this is not javascript. The website breaks. This website is presumably part of a Content Distribution Network (CDN) that is used to distribute common files for websites, and it is very likely that you get allocated to a different server depending on where you are on the planet.

I then tried an online HTTP access website: which I believe is based in the USA to access this same URL:


From this location, the javascript file appears to be served correctly. So it seems that currently your CDN is serving incorrect files to some locations of the planet (or whatever heuristic your CDN uses to select a server). What you need to do is to contact your web team and ask them to please make sure all CDN servers are up to date and not serving stale files.

So if the login is broken, how did I get in to post this? I used a VPN service to connect to random countries in the hope that I would get a different CDN server. I was finally able to do this via Japan.

You should really have a way to report login problems without having to log in.

Please fix this CDN problem on your website. I am trying to teach people how to program STM32 microcontrollers using CubeIDE, but a large number of them cannot install the software support packages because they cannot log in to the website and cannot register an account.

Community manager
Community manager

Hello @jh4 , 

Thanks for sharing this issue. I will check internally about this case and get back to you. 


In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.

Hi Lina,


Thank you! Overnight it seems someone updated the CDN, the javascript file has its copyright date changed from 2023-11-24 to 2024-01-29 and the registration page now works (the javascript errors are gone)! I really appreciate your help on this.

/*! forms2 2024-01-29  See forms2.js for license info */


Login is also working for my new account (this one)! However, the problem still appears for my personal account, perhaps because I have tried and failed to log in a large number of times. Is there some way that you can check on your end if my account has been disabled? I will send you a PM with my email for that account.





I am a user from Brisbane, Australia and I got stuck with this issue since last 5 months. Today I could register a new user and was just able to log into this forum. It is so sad that ST ecosystem is so important to us, but how poor are the application developers that ST hires, my gut feeling is this is outsourced to some cheap labor who can't keep up with the quality of service.

ST doesn't seem to realize enough that it's community forum is critical to its success. If they removed the forum today I would seriously consider switching to a different vendor. There a quite a few bugs on the forum. It keeps logging me out for instance. And I cannot change my email address so I cannot access my original account anymore.

Kudo posts if you have the same problem and kudo replies if the solution works.
Click "Accept as Solution" if a reply solved your problem. If no solution was posted please answer with your own.