Showing results for 
Search instead for 
Did you mean: 

Failing to build QT for stm32mp157f-dk2


I'm new to the stm32 community.

I am trying to build distribution package with qt following this guide

During the build with the command “bitbake -k st-example-image-qt” I encounter the following error

Full error logs attached


ERROR: All buildable tasks have been run but the build is incomplete (--continue mode). Errors for the tasks that failed will have been printed above.

ERROR: Command execution failed: 1


Summary: There were 2 WARNING messages shown.

Summary: There were 9 ERROR messages shown, returning a non-zero exit code.


When I try to build qtwebkit separately using the “bitbake qtwebkit” command I encounter the following error

Full error logs attached

| WARNING: exit code 1 from a shell command.

| ERROR: Function failed: do_compile (log file is located at /home/werent4/linux_source/Distribution-package/openstlinux-4.19-thud-mp1-19-02-20/build-openstlinuxeglfs-stm32mp1/tmp-glibc/work/x86_64-linux/m4-native/1.4.18-r0/temp/log.do_compile.509181)

ERROR: Task (/home/werent4/linux_source/Distribution-package/openstlinux-4.19-thud-mp1-19-02-20/layers/openembedded-core/meta/recipes-devtools/m4/ failed with exit code '1'

NOTE: Tasks Summary: Attempted 195 tasks of which 0 didn't need to be rerun and 1 failed.

NOTE: Writing buildhistory


Summary: 1 task failed:


Summary: There were 2 WARNING messages shown.


I'm using Ubuntu 22.04.4 LTS

free -m

               total        used        free      shared  buff/cache   available

Mem:           32073        1805         693          56       29574       29757

Swap:           9215           0        9215


I tried in the local.conf file



I tried to patch it with this patch:


Tried changing ROOTFS_PARTITION_SIZE to “1400000”

Solutions that I found on the Internet and tried

Any suggestions are welcome!
Looking forward to hearing from you!



Jean-Marc B
ST Employee

Hello @weren4 

From what I see from your logs, your image is really old as based on ecosystem 1.2! I would recommend to upgrade to the last ecosystem release 5.0.2

Best regards,