Showing results for 
Search instead for 
Did you mean: 

Flash Loader Demonstrator no longer responds to reply from STM32L151C

Associate III
Posted on August 10, 2017 at 23:21

I have been using the bootloader in the STM32L151C with STMFlashLoaderDemo for some years to update firmware.

Now, with nothing changed, the Flash Loader no longer connects to the chip

I have spied on the serial connection between the PC (hardware serial port) and the device, and the exchange for the first two commands is normal:

>7F (Flashloader sent)

79 (chip response)

>00 FF

79 0B 30 00 01 02 11 21 31 44 63 73 82 92 79

This response is byte for byte identical to that shown as the expected response in AN3155 page 9.

After receiving the last response, the Flash loader times out with the message'Cannot get available commands, Please try to change Echo selection etc'

I have also simulated the chip responses using a terminal program that can send strings of hex characters. Same result.

The second byte of the response, 0x0B is decimal 11, and is the correct value for the number of succeeding characters -1, not counting the final 0x79 ACK.

HOWEVER... if I change this to 0x0A in my simulated response, the Flash loader will issue a subsequent command,

02 FD.

I have reduced the baud rate to 9600 in case there were timing problems, no difference. I have checked the signals with an oscilloscope, all well-formed characters.

I have tried two different versions of Flash Loader (2.5.0 and 2.8.0), three computers, and three different PCBs with the same chip on board.

I am at my wits end. Can anyone shine light on this one?