cancel
Showing results for 
Search instead for 
Did you mean: 

LIS2DTW12 temperature sensor accuracy

vard
Associate II

Hello everyone,

We manufactured about 100 boards for a pre-production run using the LIS2DTW12, and at room temperature, the boards are all over the map with +/-3°C accuracy, nowhere near the "typical" +/-0.8°C as stated in the datasheet.

I've already seen the other post regarding temperature accuracy issues for the LIS2DTW12, but I did not see a resolution or an accepted solution in that post, so to me at least the problem was not solved.

Our production volume is 10k+ a year, and we've selected this part because of the temperature accuracy features. I know the data sheet does not show min/max for temperature accuracy, but on a sample of 100 boards, the sensor is nowhere near the "typical" values.

Also, I noticed a large temperature variation with the supply voltage: on the EV board, if you change the VDD from 1.8V to 3.6V (using the Advanced Features) the temperature readings (in Data panel) are jumping up by 2°C!

There is nowhere in the data sheet any information regarding the temperature dependency with supply voltage (a graph or a note stating the VDD at which the +/0.8°C typical values were measured would have been very helpful).

Could anyone shed some light on how we can get close to the "typical" +/- 0.8°C? We can't afford calibrating every single board in production.

If there is such a graph for temperature vs VDD, can anyone provide it? To me at least, it looks like the 0.8°C was measured at 1.8V, but our boards are working at 3V and at 3.6V, so if we need to add an offset, I would like to know the temperature measurement change with VDD.

Thank you!

Vlad

6 REPLIES 6
Federica Bossi
ST Employee

Hi @vard ,

At what temperature do you see this difference? 25 °C?

In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.

Thank you for your reply, Federica!

I see the temperature difference in the range of 19°C to 23°C.

On the boards we already built, some boards will only go up by 2.2°C higher than expected, and some boards will go all the way up to 4.9°C higher than expected. 

I know the datasheet specified that the +/-0.8°C was measured at VDC =1.8V, but my supply voltage is 3.3V. There are no heat sources on our boards, and the temperature measurements are done at 1.6Hz/12 bits, once every 30 seconds. The microcontroller is in sleep mode, and the power consumption of the board (LIS2DTW12, microcontroller and peripherals) is 0.9uA in sleep mode. The measurement takes a few ms and the current is as high as 75uA, every 30 seconds. That's not enough to heat the board and impact the measurements. 

I used both low power 1.6Hz with 12bit and high performance 800Hz with 14bits, but other then the refresh rate and the LSB, there's no significant change in temperature measurements. 

However, changing the VDD and sometimes the VDDIO as well from say 1.6V to 3.6V on the EV board with an MKI190V1 adapter on it will show changes in temperature measurements by as much as 3.5°C, always going higher with VDD. That's why I'm thinking there must be a correlation between VDD and the temperature value, and if that is true, a graph or a formula available, that would help a lot.

 

Also, one more thing: when testing temperature on the EV board, the longer I run the test, the bigger the error. It looks like there is a self-heating effect as well, so I ran the tests at low power 1.6Hz and 12 bits.

I also extended the MKI190V1 adapter with extra sockets. I used a set of intermediary pins to move the adapter away from the EV board, just in case the EV board is generating any heat.

Here are some tests done with the EV boards.

Please note that my ambient temperature is 19.0°C, and I have no other heat sources or fans around the EV board.

 

At VDD = 1.8V

vard_0-1714132955347.png

At VDD = 3.6V

vard_1-1714133118273.png

 

The tests done on the 100 boards we already built are in line with the measurements you see from the EV board: always a few degrees higher than the actual temperature.

Thank you for all the help!

 

Vlad

vard
Associate II

Hi @Federica Bossi​ ,

I was just wondering if you may have any updates on the temperature accuracy issues I am seeing.

Thank you!

Uwe Bonnes
Principal II

Did you plot a distribution of the error? Does it center around the expected value? Are half of the sample in a range of +/- 0.8 degree as the datasheet claims? Or how large is the window?


Otherwise if I need to have specifications for a final product, I can not use a part that has no min/max accuracy specification  and where typical values have the remark "Typical specifications are not guaranteed"

Hello @Uwe Bonnes,

I did not plot a temperature distribution error graph. I wasn't trying to check and validate the temperature specs and then have a distribution chart on this part to prove to ST that the range of values I am getting is off specs. I usually trust the datasheet during the initial component selection for a project, and the temperature range specification was the main reason I selected this part.

Measuring the temperature on the eval board was a bit of a warning flag, but with a sample of one that did not mean much. Also, at the time of doing the evaluation, I did not realize that there is a temperature dependency on VDD.

However, the majority of our pre-production samples measure within +1.5°C and +2.5°C higher then  the expected temperature values, and that on it's own is higher than the "typical" +0.8°C. 

Our measurements are NOT done at VDD=1.8V as per the data sheet specifications, but at VDD=3.3V, and I have already established that there is a direct dependency between the typical temperature values and VDD: the higher the VDD, the larger the shift in the upward direction.

All I am asking for is a graph showing the typical temperature numbers vs. VDD. My devices will operate at any voltages from 1.8V to 3.6V, so I need to make the temperature error correction in software based on VDD, but without a graph showing typical temperature values at  VDD=1.8V to 3.6V, I can't do any blind adjustments.

 

 

 

MiahPrince
Associate

Replying for the updates.