cancel
Showing results for 
Search instead for 
Did you mean: 

stm32h747 discovery blank

yakabmarci
Senior

i just received my brand new stm32h747 discovery board, on power-up it does nothing just two LEDs light up, according to the user manual it should be preloaded with a demo.

I checked in cube prog and it reports as blank.

Is it possible that my device got damaged somehow or it is just not flashed?

aren't units tested before shipping out?

Is this a common thing? I don't remember ever receiving a discovery board blank

1 ACCEPTED SOLUTION

Accepted Solutions
Sarra.S
ST Employee

Hello all,

Thank you for bringing this issue to our attention.

I confirm the issue and I reported Internally.

Internal ticket number: 147459 (This is an internal tracking number and is not accessible or usable by customers).

Sarra

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

View solution in original post

44 REPLIES 44
Peter BENSCH
ST Employee

In fact, the DISCOVERY are always delivered pre-programmed. Depending on where you got the board, a possible previous owner may have erased its flash.

However, it should not be a problem to reprogram the board and the external flash memory, as the compiled demo can be found on the STM32H747I-DISCO product website under Documentation > Compiled Demos, after unzipping in the subfolder STM32H747I-DISCO_demo/Binary.

Does it answer your question?

Regards

/Peter

In order to give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.
yakabmarci
Senior

my board is brand new from mouser, i flashed the compiled demo still doesn't work

If you only drag'n'drop the HEX onto the drive letter, only the STM32 is programmed, but not the external flash. Did you use the batch file for flashing because the external flash must also be programmed with the corresponding loader? 

Regards

/Peter

In order to give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.
yakabmarci
Senior

i used the batchfile

Well, from a distance and without seeing how you programmed it and what feedback there was, it's hard to give advice.

You could now investigate what is causing the problem, e.g. jumper settings etc or try programming a small demo. But you certainly have a warranty with Mouser, so you should contact the seller and either exchange the DISCOVERY or ask for money back.

Regards

/Peter

In order to give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.
yakabmarci
Senior

I think the issue is not with the board it is with the demos:

following this guide and flashing with the batch file doesn't work

en.STM32H747I-DISCO_demo.zip\STM32H747I-DISCO_demo\readme.txt

flashing each demo individually works but incorrectly, heavy artifacts and flickers on the display

e.g. STM32H747I-DISCO_demo\TouchGFX\Binary\TouchGFX-STM32H747I-DISCO_V1.0.0.hex

flashing tutti frutti demo works correctly with clean display:

fllowing guide en.STM32H747I-DISCO_Tutti-Frutti_demo.zip\STM32H747I-DISCO_Tutti-Frutti_DC_Demo\readme.txt

So in my opinion the demo should be updated both source and binaires, the source is not straightforward to build in CubeIDE, and compiled binary doesn't work (maybe something changed in new revisions of the board?)

So it seems my board came brand new from mouser blank.

Pretty sure you'd need to use STM32 Cube Programmer for .HEX files, and definitely to program the QSPI via an External Loader.

Boards without software from Mouser, more apt to be ones that were returned rather than from the factory.

Check connectivity of screen, rough transit has been a problem on some DISCO boards.

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..
ACapo.1
Senior

Same issue here with a new board being blank, same problems flashing the demo.

Also the majority of the examples in the cube IDE either do not build, do not flash or do not work.

All in all pretty poor!

Sarra.S
ST Employee

Hello all,

Thank you for bringing this issue to our attention.

I confirm the issue and I reported Internally.

Internal ticket number: 147459 (This is an internal tracking number and is not accessible or usable by customers).

Sarra

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.