cancel
Showing results for 
Search instead for 
Did you mean: 

STM32CubeIDE doesn't start first time after being installed

XR.1
Associate III

1. Yesterday I downloaded CubeIDE 1.14.0 for Linux Mint Cinnamon 21.2

2. Today I installed it and I tried to run it from the graphical app launcher

3. It asked me for the workspace's name. I gave it a one. This window was closed

4. Nothing happen, really, nothing!

5. I tried to re-run it and it asked me for the workspace's name. Then it said there was a workspace active with the same name

6. I run it from command line:

$ /opt/st/stm32cubeide_1.14.0/stm32cubeide_wayland %F

7. It asked me for the workspace's name. Then it said there was a workspace active with the same name

8. I opened the app manager and there were 3 open Java instances plus some CubeIDE apps. I killed them all

9. I run it from command line (again):

$ /opt/st/stm32cubeide_1.14.0/stm32cubeide_wayland %F

 

 

10. The IDE finally started. I haven't gone further at this moment. I just want you to know this misbehavior

 

Why this horrible and awkward behavior? It's the lastest release! Same happened with previous releases.

 

UPDATE (some minutes later)

11. I created a new project for a Nucleo board

12. Seems the IDE entered into an infinite loop

13. A window showed up "Please login to download...", but the IDE was unresponsive

14. I killed the Java process and I re run it again

15. The IDE was stucked again and my OS detected this situation. It's in Spanish, but it says "Force exit / Wait"

 

What's wrong with the IDE?

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi,

As I said, I found a simple, yet incredible workaround (an ugly one, though). The problem is in your side, not in the Eclipse editor:

1. DISCONNECT FROM INTERNET

2. Create a workspace

3. Create/Open a project

4. Edit your IOC project

5. Generate code

6. Compile your project

7. RECONNECT TO INTERNET

 

ST servers are painfully slow, that's way it seems the IDE freezes. However, when you're offline everything moves smoothly.

 

The IDE will ask you several times to go online, SAY NO! But DON'T SELECT THE TICK CONTROL, just say no.

 

When your project has been built then you can go online and update some IDE tools (if needed).

 

In general, whenever find yourself in any of the 2..5 steps above, DISCONNECT YOUR PC FROM INTERNET.

View solution in original post

7 REPLIES 7
Semer CHERNI
ST Employee

Hello @XR.1 

First let me thank you for posting.

The STM32CubeIDE tool is fully supported for specific Linux distribution :  Ubuntu® LTS 20.04 and LTS 22.04, and Fedora® 36.
Unfortunately, tests cannot cover all Linux version therefore we focus on the most used ones.

KR,
Semer.  

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

AScha.3
Chief

> Yesterday I downloaded CubeIDE 1.14.0 for Linux Mint ..

Which version you tried ?

I have Linux MX and the "Generic.." version - so try this (if you have tried other).

(The "Debian.." didnt work , although my system is a "Debian" type. )

If you feel a post has answered your question, please click "Accept as Solution".

Hi, CubeIDE works in Linux Mint, but it's unreliable and it has been documented. Some users (including me) have reported that they've lost their projects 'cause a Eclipse native problem.

Linux Mint is based on Ubuntu and this is based on Debian, so every path conducts to Debian.

Besides that, Linux Mint is my 24/7 beloved operating system, so sadly I can't change it just because the IDE works unreliable there.

The good news is that I found a workaround that I'll be talking about later when I have some spare time.

The good news is that I found a workaround that I'll be talking about later when I have some spare time, and it has nothing to do with Linux Mint, but in your side.

Hi,

As I said, I found a simple, yet incredible workaround (an ugly one, though). The problem is in your side, not in the Eclipse editor:

1. DISCONNECT FROM INTERNET

2. Create a workspace

3. Create/Open a project

4. Edit your IOC project

5. Generate code

6. Compile your project

7. RECONNECT TO INTERNET

 

ST servers are painfully slow, that's way it seems the IDE freezes. However, when you're offline everything moves smoothly.

 

The IDE will ask you several times to go online, SAY NO! But DON'T SELECT THE TICK CONTROL, just say no.

 

When your project has been built then you can go online and update some IDE tools (if needed).

 

In general, whenever find yourself in any of the 2..5 steps above, DISCONNECT YOUR PC FROM INTERNET.

Hi,

Try this : (no need to DISCONNECT FROM INTERNET )

menu -> preferences -> disable search and automatic updates ->

AScha3_0-1708854153465.png

On my (Linux) system improved IDE behavior a lot.

If you feel a post has answered your question, please click "Accept as Solution".

Hi,

 

Thank you for the suggestion but I've lost my IOC project =) Hopefully it's not my main project, otherwise I'll be crying by now.

 

But don't worry for my lost test project, I've learned the hardway that CubeIDE isn't reliable.

 

The thing is that, if keep my wifi on and I disable the automatic updates, then when I try to open the IOC file, Eclipse shows up 2 windows, one after another, as usual: Loading the IOC project and Rendering (Java eats 100% CPU). Then nothing happens: the IOC project never renders (Java CPU consumption drops to 0%; seems it enters into an infinite loop or so).

Then I need to kill the Java instance and when I try to reload the project, the IOC gets somehow corrupted so that CubeIDE never enters into the Eclipse IDE. Some users or ST employees have suggested to delete the project's folder =(

 

ST did a big mistake hard binding the IDE to a connection to its servers and choosing a propietary format (instead of YAML) for the IOC project.