cancel
Showing results for 
Search instead for 
Did you mean: 

STM32CubeIDE - 1.15.1 - Dependency to libncurses5

Dunfell
Associate

Hello,

I want to use STM32CubeIDE with Ubuntu 24.04 (new LTS), but on this version we don't have libncurses5 but libncurses6.

 

If we install STM32CubeIDE from .deb we have an error because libncurses5 is not installable

If we install STM32CubeIDE from general linux installer, we have no error as it doesn't check the dependency.

 

The problem is, when I want to flash my device using STM32CubeIDE it force the use or arm-none-eabi-gdb provided by ST here: `/opt/st/stm32cubeide_1.15.1/plugins/com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32.12.3.rel1.linux64_1.0.100.202403111256` so it fails because arm-none-eabi-gdb (from ST) require libncurses5

 

My question is simple:

How to use arm-none-eabi-gdb provided by my computer instead of the version provided by ST .. ?

2 REPLIES 2
Radosław
Senior II

Install you own  arm-none-eabi compiler  and add into tollchain manager in STM32CubeIDE

Semer CHERNI
ST Employee

Hello @Dunfell 

First let me thank you for posting.

At this stage only Linux®: Ubuntu® LTS 20.04 and LTS 22.04, and Fedora® 37 are supported by STM32CubeIDE.

Check the release note the Host PC system requirements  section.

KR,
Semer.

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.