cancel
Showing results for 
Search instead for 
Did you mean: 

1.13.2 problem with List Pinout Compatible MCUs

padawan
Associate III

Hi,

if i select in MX "List Pinout Compatible MCUs"

padawan_1-1700563206378.png

i get this:

padawan_0-1700563181762.png

Sometimes STM32CubeIDE closes without warning.

i reintalled the ide, i delete the workspace, i restart the pc, nothing helps! i change in the properties from external bowser (chrome) to internal, nothing.

Any suggestions?

Padawan

 

1 ACCEPTED SOLUTION

Accepted Solutions
Bob S
Principal

Try running CubeMX outside of the IDE.  You will have to install the stand-alone CubeMX it if you haven't already done so.

Personally, I never use the "run CubeMX inside CubeIDE" feature.  It just doesn't provide any benefit.  I generally leave CubeMX running, then open whichever project I need, make changes, same/generate then close the project (and leave CubeMX open).  Then switch to the IDE and re-compile, etc.  Much quicker and easier.

View solution in original post

6 REPLIES 6
STTwo-32
ST Employee

Hello @padawan 

I've tested personally for a few times, and nothing happened.

Can you test this behavior with another PC?

Best Regards.

STTwo-32

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

If i do the same in 1.12.1 i get  this

padawan_0-1700566218750.png

And this seems ok.

So i think it is one more issue in 1.13.2 :(

Padawan

I don't think so. Doing this operation with the version 1.13.2 I got this:

STTwo32_0-1700570224116.png

 

Can you check your internal parameters? 

Best regards.

STTwo-32

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Hm, can you specify which parameters I need to check?

I can't find anything like the "do not deface screen"-parameter, that i

can check..

Padawan

Bob S
Principal

Try running CubeMX outside of the IDE.  You will have to install the stand-alone CubeMX it if you haven't already done so.

Personally, I never use the "run CubeMX inside CubeIDE" feature.  It just doesn't provide any benefit.  I generally leave CubeMX running, then open whichever project I need, make changes, same/generate then close the project (and leave CubeMX open).  Then switch to the IDE and re-compile, etc.  Much quicker and easier.

 

Thanks Bob for the hint

with Cube Mx standalone 6.8.1 it is ok.

with Cube MX standalone 6.10 it is ok,

with the version 6.9.2 integrated in the STM IDE v 1.13.2 -> d'oh

edit:

with the brand new 1.14.0 it is ok (MX 6.10)

padawan