cancel
Showing results for 
Search instead for 
Did you mean: 

Re: STM32F769I-DISCO - Really noisy TFT LCD display

MikParà
Associate

Hi everyone

i worked fine with MB116-A03 display and now i have the same problem with A09 display. I made the changes available on github:
- created the new component nt35510 with the three files (.h .c .html)
- and made changes to 4 files: stm32f769i_discovery_lcd (.c and .h) stm32f769i_discovery (.c and .h).

However the display still does not work. But are there other changes to be made? It says to enable the correct hardware target, but where can I do that?
In the stm32f769i_discovery.h file I have already reported the lines:
#if !defined(USE_STM32F769I_DISCO) && \
!defined(USE_STM32F769I_DISCO_REVB03)
#define USE_STM32F769I_DISCO

Thanks to anyone who can give me directions.

1 ACCEPTED SOLUTION

Accepted Solutions
KDJEM.1
ST Employee

Hello @MikParà and welcome to community 🙂,

Please download and use the correct drivers file shared in the GitHub in your project.

Also when  STM32F769I DISCOVERY w/ MB1166-A09 LCD daughter board connected on it should be used in stm32f769i_discovery.h file

#define USE_STM32F769I_DISCO_REVB03

instead

#define USE_STM32F769I_DISCO

Please let me know if the issue is solved.

Thank you.

Kaouthar

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

View solution in original post

2 REPLIES 2
KDJEM.1
ST Employee

Hello @MikParà and welcome to community 🙂,

Please download and use the correct drivers file shared in the GitHub in your project.

Also when  STM32F769I DISCOVERY w/ MB1166-A09 LCD daughter board connected on it should be used in stm32f769i_discovery.h file

#define USE_STM32F769I_DISCO_REVB03

instead

#define USE_STM32F769I_DISCO

Please let me know if the issue is solved.

Thank you.

Kaouthar

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Good morning everyone
thanks for the advice, I solved it and it started working again
Thanks again for your support