cancel
Showing results for 
Search instead for 
Did you mean: 

Bug the Cubemx New Version not working USART6_IRQHandler

mbagh.1
Senior

Hello, in the new versions, cubemx and USART6_IRQHandler  does not work, what is the reason?

It does not work for both stm32h743iit6 and stm32h723zgt6

7 REPLIES 7
TDK
Guru

What evidence do you have that it isn't working?

If you feel a post has answered your question, please click "Accept as Solution".

Pretty sure this won't have changed the silicon, debug from first principles.

Start with the Vector Table and the binding the Linker has done. Disassemble, and check. Check for weak linkage issues, or name mangling.

Check that the interrupts are generated / cleared. Not conflicted by DMA moving data, or debugger peripheral view sat over the registers interfering with them, etc.

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..

Hello, no, I am absolutely sure that in version 6 cubemx it was working perfectly, but now this problem has arisen, no matter what I did, it didn't work Test yourself, that part doesn't work anymore

Sorry, not really my dev system of choice. Just saying that if you can pin this down there's a better chance it will be identified and fixed by ST, and you can perhaps work around the issue and continue with your work.

Generally a good reason in embedded to NOT keep chasing tool / version updates unless there's some compelling reasons to re-qualify everything. Also should retain tools and binaries if you're going to have to maintain code for years or decades and need to review failure scenarios.

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..
TDK
Guru

Also, "doesn't work" is incredibly vague and doesn't provide an avenue for analyzing. You'll probably need to provide more detail on your exact issue for anyone to even be able to investigate.

As @Tesla DeLorean said, silicon doesn't change between Cube versions. Compilers are much less likely to have an issue. If your code changed, do a diff and see what changed.

If you feel a post has answered your question, please click "Accept as Solution".

I'm using a Nucleo-H723ZG and have the exact same parameters set for UART3 and UART6. I can confirm that UART6 Rx does not interrupt while UART3 does.

Another H7 report here.  https://community.st.com/t5/embedded-software-mcus/stm32h750b-dk-uart-does-not-work/td-p/584909

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..