Showing results for 
Search instead for 
Did you mean: 

STM8S208C8 SWIM error [30006]: Comm init error: chip does not answer



We are using STM8S208C8 in our product. When i try this to connect through ST-Link V2 SWIM connector, straight away i am getting SWIM error [30006]: Comm init error: chip does not answer. The MCU VDD is connected to +3.3V and i measured +3.29V. We have plenty of boards assembled and i have tried 3 boards, all through the same error. I have reviewed the schematics and PCB layout and couldn't find any issue. The same ST-Link V2 is working with another product which is having the same MCU connected to +5V VDD.

Please help resolve this issue.



Emilio P.G. Ficara
Associate II

Hi, here is a checklist that I follow when I have troubles with microcontroller programming / burning. If you want, give it a try:

1) have you checked if the supply voltage is present on the ST-LINK V2 programmer ? The original programmer needs to be powered from the circuit, while some clones use their own supply (taken from USB port). The correct way (for the original ST-LINK V2) is to power the programmer with the voltage applied to the microcontroller on the board.

2) Have you checked the reset pin of the microcontroller is at high level (inactive) ?

3) Is the clock enabled / running ?

4) Have you set the brownout voltage higher than the power supply (if it was set) ?

5) Have you fully erased the program memory in the micro ? This can cause the swim to operate with much difficulties (read the PDF document about the SWIM).

Note that not all the points will apply to any microcontroller. Use only the ones that makes sense.

Hope this helps, bye.

Emilio P.G. Ficara
Associate II

Oops, I forgot the most important one: test if the SWIM pin is "free" and "clean", so if it does not have some hardware problem like pull-downs, capacitors on the line, etc.



I have faced described error.

The issue appeared after changin powering my STM8S003 board from USB to baterry source.

In my case, short wire between GND pin on SWIM connector and huge ground polygon solved issue.

Please watch a photo.




I am experiencing the same issue. I think i erased the program memory on the MCU. @Emilio P.G. Ficara suggests to read the PDF document about SWIM - Which document ? I have read a few different documents now but cannot resolve the issue.

Do i need to reset the board - is that possible?