Showing results for 
Search instead for 
Did you mean: 

No ST-LINK detected

Associate II

I have got an Nucleo L073RZ   ( and also a discovery 407,F410RB and 4 more nucleo boards) .


It is a new board just unboxed .  I can see it as a drive  in my computer beside disks  so I know it is working.


But st link cannot detect it.   All my  boards except discovery board have same issue. I have tried 2 computers, windows 10 and windows 11 .  

I used to program one of the nucleo board.

More details: In one of the board the st link made me upgrade firmware , still same issue is there. 


ST Employee

Hello @rahulsoni15348,

Let me first welcome you to the Community 🙂

Change the USB cable (use a quality USB serial Comm cable and NOT a charging cable).

Try with latest release of STM32Cubeprogrammer.


When your question is answered, please close this topic by clicking "Accept as Solution".

Thanks for so fast reply, you are awesome.

I installed stm32cube programmer.

It is able to connect with same cable to my discovery board.

But not nucleo board.  



I tried with another board , Attached is detailed explanation of what is happening. 


btw. the L073RZ just worked with cube programmer (got detected, i can see memory) , I have yet to check if it works with stm32 cube ide also , I want to program and debug eventually.


If voltage is 0.16V, the board doesn't have power.

Doesn't make sense that the st-link on the board would have power and work normally but the target mcu does not.

Double check power settings, jumpers.

If you feel a post has answered your question, please click "Accept as Solution".