Showing results for 
Search instead for 
Did you mean: 

STMH743ZI2 CubeMx clock setup, max frequency not allowed

Associate III

I have been following this discussion:

As when I create a project for the Nucleo-H743ZI2 I have to set the clock, and the auto generator makes the speed slow.

I followed the discussions method on how to increase the speed and I get the same results. But I can't save as an error appears. It says DCPRE1 has a max frequency of 480MhZ, but when I have it set to 400MHz an error appears saying it must be <=350Mhz. The same happens for the HCLCK but the error says <=150Mhz instead.

I have attached a screenshot of what I have and my set up.

Is this a bug or am I not able to increase the clock performance from the initial auto generated speeds?



Hello @KSOdin2​,

Please excuse the somewhat late reply and thank you for having reported.

Trying to figure out the problem, I can't reproduce it from my side. The "DCPRE1 clock frequency must be =< 300Mhz" error did not appear:


Actually, only "PLL Mux should have HSE as input" error message was displayed. Normally this error is due to activation of USB_OTG_FS (which is activated by default when starting a project based on Nucleo-H743ZI and initializing all peripherals with their default mode).

In fact backing to STM32H743xI Data Sheet, in 3.40 Universal serial bus on-the-go high-speed (OTG_HS) section, it is mentioned that "The USB OTG controllers require a dedicated 48 MHz clock that is generated by a PLL connected to the HSE oscillator".

For USB application, the internal clock source is not precise enough: To achieve a High-Speed communication, a high frequency clock is required. So the USB clock is sourced from the HSE clock.

Thus, if you're using USB in your project, it is preferred to use HSE clock source for best accuracy or you can change the USB Clock source to RC48:


Otherwise, referring to your attached screenshot, there is also a red cross in the Pinout & Configuration:

0693W00000BZbKbQAL.pngHence, I assume the "DCPRE1 clock frequency must be =< 300Mhz" error is due to a faulty configuration.

Please check In Pinout configuration view > RCC RCC Configuration Panel > Parameter Settings > Power Parameters > Power Regulator Voltage Scale, the Power Regulator Voltage Scale should match the maximum frequencies mentioned in Table 122. General operating conditions of the Data Sheet:

0693W00000BZbLPQA1.png>when I have it set to 400MHz an error appears saying it must be <=350Mhz. The same happens for the HCLCK but the error says <=150Mhz instead.

As far as I can see, you're setting the  Power Regulator Voltage Scale to VOS2.

Hope this helps you solve your issue. You can attach your .ioc for further check.