Showing results for 
Search instead for 
Did you mean: 

CubeMX install on Mac Sierra

Sebastian G.
Associate II
Posted on December 06, 2016 at 09:52

I am trying to install CubeMX 4.18.0 on my Mac (Sierra), opening the installer appears to do nothing, if launched via spotlight i get a warning stating unable to open the programm.

#cubemx #macos #sierra
Nesrine M_O
Lead II
Posted on December 06, 2016 at 10:45




Please refer to the


user manual and follow the steps/requirements for installing and running CUBEMX under MacOS:

  • Make sure that tyou have administrators rights.

  • Make sure that you haveinstalled Java Development Kit 1.7.0_45 or later.

    If the issue persist again please contact us.

-Nesrine M-

Posted on December 06, 2016 at 11:47

I got admin rights and 'javac 1.8.0_102' -> already had cubemx installed a while ago, so it was running on this exact computer. Dont know what changed!?

Posted on December 06, 2016 at 11:54




I'll report this issue to our MX team for checking. Sorry for the inconvenience it may bring.

-Nesrine M-

Posted on December 06, 2016 at 15:44

I installed the eclipse add-on, it runs and does everything i need!

Associate II
Posted on December 23, 2016 at 20:09

Double-clicking the installer didn't work for me either.

Workaround: open a terminal, cd to the directory where the files have been unpacked and start the installer with the command:

java -jar SetupSTM32CubeMX-4.0.exe

This worked for me.

Posted on January 09, 2017 at 07:12

I had a same problem and this worked for me Thanks!

Kirill Makukhin
Posted on May 16, 2017 at 05:50

Installing with sudo works:

sudo open 'path_to_/'

However, it screws automatic update
Heath Raftery
Associate II
Posted on July 13, 2017 at 09:29

This was killing me too - silent failure. Eventually discovered I could cd to and run the executable from the command line:

$ cd ~/Downloads/en/

$ ./SetupSTM32CubeMX-4_22_0_macos

Please install Java JDK 1.7.0_45 or a more recent version

Hallelujah! Just needed to install the latest JDK (not the JRE as directed elsewhere!) and away we go.

Thierry Coton
Posted on October 19, 2017 at 22:38

Actually, the setup for Mac OS has been copied from a Linux installation and can only stall as the setup is trying to write into /usr/share/applications which does not exists on Mac OS but does not pop any error up...

LOL, seriously, guys, do you really have a Mac?



I had to open the package and launch the setup in a terminal to discover this.

It has been a year this issue exists and still not fixed.

/Users/***********/Downloads/en.stm32cubemx/ ; exit;

iMac-**-*****:~ **********$ /Users/***********/Downloads/en.stm32cubemx/ ; exit;

19 oct. 2017 16:19:14 INFOS: Logging initialized at level 'INFO'

19 oct. 2017 16:19:14 INFOS: Commandline arguments:

19 oct. 2017 16:19:15 INFOS: Detected platform: mac_osx,version=10.12.6,arch=x86,symbolicName=null,javaVersion=9.0.1

19 oct. 2017 16:19:18 WARNING: Cannot write to '/usr/share/applications'