Showing results for 
Search instead for 
Did you mean: 

The BSP example for STM32F429I-Disc1 with STM32CubeIde crashes.

Associate II

Good morning! I have a problem with the STM32F429I-DISC1 board. I bought this board a few weeks ago and with the STMCubeIde software (v. 1.12.0) I downloaded the BSP example for this board together with the STM32CubeF4 package (v. STM32Cube_FW_F4_V1.27.0). After compiling the project and loading it into the board (Run as STM32 C/C++ Application), the execution hangs during the calibration of the touch-screen (activate the colored circle inside the rectangle). I tried with various PCs with Windows 10 Pro (I7 and I5 with 16 GB of RAM) and also on a Linux Kubuntu v.22.04 machine but the anomaly always occurs. Another example (LTDC_Display_2Layers) works correctly. I also tried to use another STM32F429I-DISC1 card but the problem remains. Can anyone enlighten me on this? Thank you!


> execution hangs

How exactly? Where is the PC in debugger?


The pc is an I7 Intel (motherboars Asus Prime Z270A - Processor Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz  3.41 GHz with 16 GB Kingston)

The execution of the software stops when the colored circles to press appear. Despite pressing with my finger or with a touch-pen, the circles do not color and freeze. I just have to reset:

ST Employee

Hello Alann ,

This BSP example configuration has been running on STMicroelectronics STM32F429I-Discovery RevC board, and in order to run it on STMicroelectronics STM32F429I-Discovery RevD or RevE boards (NB: check your board revision ) , please ensure to add "USE_STM32F429I_DISCOVERY_REVD" define in the toolchain's pre-processor options and download the update fix form github : Update touch calibration to fix inverted touch panel on STM32F429I-DI… · STMicroelectronics/STM32CubeF4@d7fef24 · GitHub



_legacyfs_online_stmicro_images_0693W00000binnXQAQ.pngGood morning and thank you! How do I see the REV of the card? I don't see any indication on the circuit board.


Hi Alann ,

as mentioned on the picture below , your board is STM32F429I-Discovery RevE.



PC = Program Counter

If you stop execution in the debugger, where in the whole of the code is it sitting / stuck.

ie while(1) loop in HardFault_Handler() or Error_Handler(), or some other place that can be identified..

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..

Good morning! I made the suggested corrections and the circles are colored regularly...thanks. But it hangs up after another error: MEM$ - cannot be initialized. So I need more suggestions. Thanks again.

Hello Alann ,

Could you please provide more details : at which level exactly is the error faced? If at compilation level, which IDE are you using? did you add this modification under this path : Drivers/BSP/STM32F429I-Discovery/stm32f429i_discovery_ts.c ?

if defined (USE_STM32F429I_DISCOVERY_REVD)
    if (y > 3700)
      y = 3700;
    else if (y < 180)
      y = 180;
    /* Y value first correction */
    y -= 360;  
    y = 3700 - y;
    /* Y value first correction */
    y -= 360;

and please add "USE_STM32F429I_DISCOVERY_REVD" define in the toolchain's pre-processor options ,