Showing results for 
Search instead for 
Did you mean: 

CubeIDE forcing you to login to ST is complete [...]

Associate III

I don't care if the title of this post breaks some sort of forum usage rule, I just need to make it absolutely plain that I am sick and tired of every last company on Earth insisting I have an account with them and use it whenever I so much as breathe, drink a glass of water or, Chtuluh forbid ! update a HAL library for a microcontroller.

I believe there are more than enough bugs in CubeIDE, let alone actual necessary features that are missing, to keep your developers occupied forever. You did not need to waste everyone's time forcing people to login to ST. This feature brings nothing, helps no one but yourselves, and was asked by absolutely nobody, ever. So please, may I suggest you rethink this stupid, bordering on evil new addition to CubeIDE, and remove it with the next version ?

FYI, some of us work in companies where our computers are not, must not and cannot be, connected to the internet. It's already tough enough installing some of your HAL libraries (the patches) while being offline, we do not need the additional hassle of a login system that does nothing useful anyway.

A tool has to be convenient. If my screwdriver required an internet connection so as to snitch on how many turns I do in each direction depending on my GPS location, I'd start considering switching to fingernails or rocks.

You are welcome to try and make a case as to why you need me to log in to download updates to stuff you provide free of charge. I do need a good laugh.

Oh and I haven't checked on my last CubeIDE ticket... did you finally fix the bug where CubeIDE is confused when launching firmware on a target with Flash banks swapped ? Because that would sure be of actual use to the legions of programmers doing FOTA.

Associate II

I cannot login in the STM32CubeIDE, it keeps faling, I can login in the browser, but I cannot download the software for reinstall, everytime it keeps promting me for loggin into stm again, even that I already is logged in. I have a plain private internet connection without any additional firewall than the one there is on my computer. I do not use vpn.

i have also tried to disable my firewall, still no luck, Have also tried hotspot on my phone.
I have tried all three network settings under the preferences.

i you want us to login it would be great if it worked


You have to login in the IDE, not in a browser.

In IDE in it's menu.

Did you try that?


Ok, i see now ... login in IDE not working... perfect !

If you feel a post has answered your question, please click "Accept as Solution".
Associate II

I've got the same issue. There is no logging (IDE) possible.

Got a window "User Authentication Dialog", then, after some time "Connection lost".

I'm working in a "private enviroment", every other application, app, straming,.... which uses internet is working fine.

So please . remove this bug!

Thanks Winfried

ST Employee


For our Community members who faced login issue with STM32CubeIDE or STM32CubeMX, please refer to this post where explanation is provided and there the confirmation that problem is resolved.


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.