Showing results for 
Search instead for 
Did you mean: 

Change u-boot kernel command line

Associate II

Hello there,

I have a OSD32MP1-RED board based on stm32mp157c. Following the instructions How to create your own machine, I was able to compile the image. The problem happens when I try to boot from SD card with the generated image after load the boot loader and kernel, I got the error:

Waiting for root device /dev/mmcblk0p6...

After some research, I realized the mmcblk0p6 corresponds to eMMC memory in my board (but now this is empty). So, I have tried to modify the kernel's arguments adding in the config machine file the variable:

APPEND = "root=/dev/mmcblk1p6 rootwait rw console=ttySTM0,115200 init=/sbin/init firmware_class.path=/lib/firmware/"

However I get the same result, the generated image alway points to the mmcblk1p6 block. My question is:

What variable do you need to set or modify to change the parameters passed to kernel from u-boot?

I attached the log file generated for more details.

Thanks in advance for your support.

ST Employee

Hi @MHern.4​ ,

Did you correctly specify BOOTDEVICE_LABELS += "emmc" in your machine.conf ?


In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.
ST Employee


in the provided log:

U-Boot retrieve the DISTO configuration file in bootfs partition (the only partition marked bootable):


Found /extlinux/extlinux.conf

Retrieving file: /extlinux/extlinux.conf


append: root=/dev/mmcblk0p6 rootwait rw console=ttySTM0,115200

the append displayed here is found by U-Boot in this file, but it seems still not updated.

=> the extlinux.conf file is not updated by the YOCTO or the updated version wasn't copied on the bootfs partition

For simple test you can modify the file manually on the sdcard.

For yocto generation, see



I don't know how to configure it for YOCTO (that depend on OpenSTLinux version used).