Showing results for 
Search instead for 
Did you mean: 

TouchGFX Designer : Error "Unable to locate C:/<path_to_folder>"

Associate III


I created a project in STM32CubeIDE, I initialized all peripherals to their default mode using CubeMX, and generated some TouchGFX code usingTouchGFX Generator. Then I opened the file ApplicationTemplate.touchgfx.part with TouchGFX Designer, drew some graphics and tried to generate the code, but I got an error, here are the logs :

"Generate Code


       Wrote config/gcc/


   Generate Assets

       make -f simulator/gcc/Makefile assets -j8

       Reading ./application.config


   Post Generate

       touchgfx update_project --project-file=simulator/msvs/Application.vcxproj



   Post Generate Target

       touchgfx update_project --project-file=../Essai_13.ioc --platform=m4

       Unable to locate C:/Users/bernard/Home/TouchGFX_Projects/Essai_13/TouchGFX



Note that C:/Users/bernard/Home/TouchGFX_Projects/Essai_13/TouchGFX is the path to the folder where ApplicationTemplate.touchgfx.part resides.

What is wrong here ? What can I do to work on this project with TouchGFX Designer ?

Thanks in advance !


Accepted Solutions
Associate III

If I sum up, in ApplicationTemplate.touchgfx.part, you need to insert 2 lines :


"Application": {
    "Name": "Essai_12",


"Application": {
  "Platform": "m4",
  "ProjectFile": "../Essai_12.ioc",
    "Name": "Essai_12",

And of course adapt to your platform and .ioc file name.

View solution in original post

Chief II

I mean searched ../Essai_13.ioc isnt exist or on other place, try correct path manualy

Associate III

The file Essai_13.ioc exists at C:/Users/bernard/Home/TouchGFX_Projects/Essai_13 (thus is C:/Users/bernard/Home/TouchGFX_Projects/Essai_13/TouchGFX/..).

I tried to correct the path manually but I don't find where, is it in a file or in TouchGFX Designer ?

Associate II

same problem.

how can i fix?



check "run as administrator" TouchGfx Designer"


This doesn't solve it for me. I tried moving my project around on different disks, but I still see the same error.

Chief III


The Designer doesn't understand .part files that are old, only .touchgfx files. So if you're using an old project that was never opened with that version of the designer, then there's a problem.

You can get around it by adding Platform and ProjectFile to your .part file. For instance, for

    "Platform": "m7",
    "ProjectFile": "../STM32F746.ioc",


Thanks for your answer ! I'm not sure what you mean by "old", this project was created by the latest version of TouchGFX Generator, and I'm using Designer 4.19.0 to generate its code.

At first there is only a "ApplicationTemplate.touchgfx.part" file, in which I added the lines as you advice (m4 for Platform and ../Essai_13.ioc for ProjectFile), then I opened it with Designer, added a box and a text, genererated the code, but got the same error at the "Post Generate Target" step.

But Designer had created an "Essai_13.touchgfx" file, so I added those lines in it too, opened it and tried again but I got the same result.

I attach the modified files and a tree-like file listing of the project (after code generation) just in case.

Can you spot any obvious mistake ?

Thanks in advance ! Have a nice day


I shouldve mentioned that you need to put those lines in the "Application" node of the .part file.

  "Application": {

Associate III

That solved it, thank you !

Now the Designer seems to generate the code properly.