Showing results for 
Search instead for 
Did you mean: 

Problems using ST-GDB Server on Linux Mint


I have the newest Version of ST/Atollic TrueStudio installed on my Linux Mint Machine.

Operating System: Linux Mint 19
            Kernel: Linux 4.15.0-20-generic
      Architecture: x86-64

When Itry to upload my Code I get the following error:

STMicroelectronics ST-LINK GDB server. Version 5.1.0
Copyright (c) 2018, STMicroelectronics. All rights reserved.
Starting server with the following options:
        Persistent Mode            : Disabled
        Logging Level              : 1
        Listen Port Number         : 61234
        Status Refresh Delay       : 15s
        Verbose Mode               : Disabled
        SWD Debug                  : Enabled
Target no device found
Error in initializing ST-LINK device.
Reason: No device found on target.

I've succesfully upgraded the ST-Link Firmware Version to the newest version.

When I Try to run the server manually from the terminal I get:

:~$ /opt/Atollic_TrueSTUDIO_for_STM32_x86_64_9.2.0/Servers/ST-LINK_gdbserver/ST-LINK_gdbserver
/opt/Atollic_TrueSTUDIO_for_STM32_x86_64_9.2.0/Servers/ST-LINK_gdbserver/ST-LINK_gdbserver: error while loading shared libraries: cannot open shared object file: No such file or directory

The file it can't find is located in the



Now my question:

Why does uploading not work? Is the missing file the only problem or could they be independent? Why doesn't it find the file, even thought it is in the proper location? The proper rules are located in the udev directory. (Upgrading of the Firmware worked, so I guess the USB connection is not the problem.)

If this was already solved I'm sorry ... Just didn't find an answer..:worried_face:

I'm grateful for any answers..😀

Greetings from Germany

Philipp Wasser

Associate II

I have the same problem. I copied this file to the usr / lib folder and then GDB server sees it. But it didn’t give any results. Debugging doesn’t work anyway. The program shows an error

"STLink server is required to launch the debug session".