Showing results for 
Search instead for 
Did you mean: 

Missing ai_platform.h and bsp_ai.h?


Not be able to compile as it asks for ai_platform.h? But the file exists: Middlewares/ST/AI/AI/include/ai_platform.h

Copied into teh Inc folder but then I got this bps_ai.h is not found.

I am using NUCLEO_H743ZI on Mac.

Any suggestions?

Thank you in advance.

ST Employee

In the project properties can you verify that the include paths have been generated properly.

You should have something like




then the regular HAL and CMSIS includes

to make sure all the elements are generated you should check all the check box in the upper part of the configuration (Artificial Intelligence Code, Artificial Intelligence Application) and give in the Platform settings the USART to use to communicate back to the PC (normally it is the STLink VCP USART)


In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.

Thank you for your response. I am using x-CUBE IDE to create the C code. I would assume the libraries are based on the project creation structure. Agree if I am complin g on Linux ro MAc manual.

I did ineed seelcted AI Code and Applications.

I was not able to fine this header file: bps_ai.h in the project.

Thank you much all your support.

Associate II

I also have the same problem. I am using STM32IDE V1.0.1 with CubeMx 5.2.1 and X-CUBE-AI 3.4.0. I get the same build error. I also note that in the "Manage embedded Packages" that there is a Red X next to both 3.3.0 and 3.4.0 ai packages, if I hover over ther eis a message that this version of the pack is not compatible with the version of CubeMX installed, it says > 5.0.1 is needed, however, 5.2.1 in installed. Not a good start for X-CUBE-AI and STM32IDE i'm afraid

Ji Hyun Park

I might be a bit late, but I have encountered the same problem and maybe have a solution to this problem.

You should check whether 'Platform Settings' under 'STMicroelectronics.X-CUBE-AI.X.X.X' has been set before you generate the code.

In my case (using STM32F469NIHX), I have set 'COM Port' to 'USART:Asynchronous' with 'USART1' and when I generate the code, bsp_ai.h file is generated under X-CUBE-AI > Target.

Hope this solves the problem.

Associate II

In my case, the include path was set wrong.

I modified below configuration

Truestudio -> Project property -> C/C++ Build -> Setting -> Tool Setting -> C Compiler -> Directories -> "Middlewares/ST/AI/Inc" to "../Middlewares/ST/AI/Inc"

Then another error "cannot find -l:NetworkRuntime512_CM4_GCC.a" appeared and it was solved by modifying

Truestudio -> Project property -> C/C++ Build -> Setting -> Tool Setting -> C Linker -> Libraries -> "Middlewares/ST/AI/Inc" to "../Middlewares/ST/AI/Inc"