Showing results for 
Search instead for 
Did you mean: 

I can't compile the AI project on the STM32H743 chip

Associate II

How to deal with fatal error: ai_platform.h: No such file or directory? I can't find this file anywhere in the project.

I tried using different versions of CubeIDE and X-CUBE-AI, added include paths in project properties. I checked on F7 and H7. I have Core and ApplicationTemplate selected in Software Packs Component Selector.

The problem started with the inability to use USART along with the X-CUBE-AI package enabled. Then no error appeared, only communication over USART did not work.

I am currently using CubeIDE 1.12 and X-CUBE-AI 8.0, and have updated what I can.

The last time AI worked for me I was still using Eclipse (SW4STM32), but it no longer supports the latest chips I use.

Please point out what could be the problem.


Associate II

Middlewares folder is not generated in the project, I do not know why.

After copying this folder from another project, the problem with ai_platform.h disappeared.

On the other hand, I am still unable to use communication via USART. I am trying with USART 2 and USART 3, Nucleo H743 board and H743 chip of LQFP176 version. The result is always the same - USART does not work. The rest of the program seems to work normally.

Associate III

When I change from SystemPerformance to ApplicationTemplate, the Middlewares folder disappears but the compiler still requires it. Is this some CubeIDE bug?

Associate II

I am also facing the same issue. This STM AI toolkit is really frustrating. No documents, no support from the dev team, and no replies for such a huge problem.