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1.1.1 GPIO Lab



Configure GPIO for LED toggling

• Objective

• Learn how to setup pin and GPIO port in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Goal

• Configure GPIO pin in CubeMX and Generate Code

• Add in to project HAL_Delay function and HAL_GPIO_Toggle function

• Verify the correct functionality on toggling LED

111.1.1



Configure GPIO for LED toggling

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• Configure LED pin as GPIO_Output

121.1.1



Configure GPIO for LED toggling

• For debug purpose is recommended to select debug pins

SWD or JTAG

• Select can be done in TAB>Pinout>SYS

• On discovery is available only SWD option

• If SWD/JTAG is not selected and the Set all free pins as analog 

(MENU>Project>Settings>TAB>Code Generator) is selected, debug is not possible 

131.1.1



Configure GPIO for LED toggling

Clock Configuration overview 10

• External clock enabling

• TAB>Pinout

• Select HSE and LSE clocks

• Bypass or crystal

14

1. Set HSE crystal

2. CubeMX reserve pins
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Configure GPIO for LED toggling

• In order to run on maximum frequency, setup clock system

151.1.1



Configure GPIO for LED toggling

• GPIO Configuration

• TAB>Configuration>System>GPIO

161.1.1



Configure GPIO for LED toggling

• GPIO(Pin) Configuration

• Select Push Pull mode

• No pull-up and pull-down

• Output speed to HIGH

Is important for faster

peripheries like SPI, USART

• Button OK

171.1.1



Configure GPIO for LED toggling

• GPIO(Pin) output speed configuration

• Change the rising and falling edge when pin change state from high to low or low to high

• Higher GPIO speed increase EMI noise from STM32 and increase STM32 consumption

• It is good to adapt GPIO speed with periphery speed. Ex.: Toggling GPIO on 1Hz is LOW 

optimal settings, but SPI on 45MHz the HIGH must be set

18
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Configure GPIO for LED toggling

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

191.1.1



Configure GPIO for LED toggling

• Now we open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 3 */ and /* USER CODE END 3 */ tags

• Into infinite loop while(1){   }

• For toggling we need to use this functions

• HAL_HAL_Delay which create specific delay

• HAL_GPIO_WritePin or HAL_GPIO_TogglePin

201.1.1



Configure GPIO for LED toggling

• Now we open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 3 */ and /* USER CODE END 3 */ tags

• Into infinite loop while(1){   }

• For toggling we need to use this functions

• HAL_HAL_Delay which create specific delay

• HAL_GPIO_WritePin or HAL_GPIO_TogglePin
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/* USER CODE BEGIN 3 */
/* Infinite loop */
while (1)
{
HAL_GPIO_WritePin(GPIOG, GPIO_PIN_14, GPIO_PIN_SET);
HAL_Delay(500);

HAL_GPIO_WritePin(GPIOG, GPIO_PIN_14, GPIO_PIN_RESET);
HAL_Delay(500);

}
/* USER CODE END 3 */

1.1.1



1.1.2 EXTI lab
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Configure EXTI to turn on LED

• Objective

• Learn how to setup input pin with EXTI in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Goal

• Configure GPIO and EXTI pin in CubeMX and Generate Code

• Add into project Callback function and function which turn on led

• Verify the correct functionality by pressing button which turns on LED

231.1.2



Configure EXTI to turn on LED

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• Configure LED pin as GPIO_Output

• Configure Button pin as  GPIO_EXTIX

241.1.2



Configure EXTI to turn on LED

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• Configure LED pin as GPIO_Output

• Configure Button pin as GPIO_EXTIX

251.1.2



Configure EXTI to turn on LED

• In order to run on maximum frequency, setup clock system

• Details in lab 0

261.1.2



Configure EXTI to turn on LED

• GPIO Configuration

• TAB>Configuration>System>GPIO

271.1.2



Configure EXTI to turn on LED

• GPIO(Pin) Configuration

• Select External Interrupt Mode with Rising edge trigger detection

• No pull-up or pull-down

• PG14 can be let in default

settings

• Button OK

281.1.2



Configure EXTI to turn on LED

• NVIC Configuration

• We need to enable interrupts for EXTI

• TAB>Configuration>System>NVIC

291.1.2



Configure EXTI to turn on LED

• NVIC Configuration

• Enable interrupt for 

EXTI Line0

• Button OK

301.1.2



Configure EXTI to turn on LED

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

311.1.2



Configure EXTI to turn on LED

HAL Library work flow 1
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Configure the GPIO to generate interrupt on 

rising or falling edge

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_EXTI0_IRQHandler

Edge detection callback

HAL_GPIO_EXTI_Callback

EXTI0_IRQHandler

Generated by 

CubeMX

1.1.2



Configure EXTI to turn on LED

HAL Library work flow 2

33

Configure the GPIO to generate interrupt on 

rising or falling edge

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_EXTI0_IRQHandler

Edge detection callback

HAL_GPIO_EXTI_Callback

EXTI0_IRQHandler

MX_GPIO_Init

inside main.c

1.1.2



Configure EXTI to turn on LED

HAL Library working flow 3
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Configure the GPIO to generate interrupt on 

rising or falling edge

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_EXTI0_IRQHandler

Edge detection callback

HAL_GPIO_EXTI_Callback

EXTI0_IRQHandler

inside 

stm32f4xx_it.c

1.1.2



Configure EXTI to turn on LED

HAL Library work flow 4
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Configure the GPIO to generate interrupt on 

rising or falling edge

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_EXTI0_IRQHandler

Edge detection callback

HAL_GPIO_EXTI_Callback

EXTI0_IRQHandler

User must define Callback 

it is declared by default as 

empty weak

1.1.2



Configure EXTI to turn on LED

HAL Library work flow 5
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Configure the GPIO to generate interrupt on 

rising or falling edge

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_EXTI0_IRQHandler

Edge detection callback

HAL_GPIO_EXTI_Callback

EXTI0_IRQHandler

Usually in main.c between

/* USER CODE BEGIN */ 

tags

1.1.2



Configure EXTI to turn on LED

HAL Library work flow summary
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Configure the GPIO to generate interrupt on 

rising or falling edge

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_EXTI0_IRQHandler

Edge detection callback

HAL_GPIO_EXTI_Callback

EXTI0_IRQHandler

2. init GPIO

1. init NVIC

3. create 

edge

4. EXTI interrupt 

handler

5. HAL EXTI 

interrupt handler

6. HAL EXTI 

callback

HAL files clearing 

flags, check errors, 

…

1.1.2



Configure EXTI to turn on LED

• Now we open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 4 */ and /* USER CODE END 4 */ tags

• We create function which will handle the EXTI interrupts

• The HAL callback function for EXTI

• void HAL_GPIO_EXTI_Callback(uint16_t GPIO_Pin)

• For LED turn on we need to use this functions

• HAL_GPIO_WritePin

381.1.2



Configure EXTI to turn on LED

• Now we open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 4 */ and /* USER CODE END 4 */ tags

• We create function which will handle the EXTI interrupts

• The HAL callback function for EXTI

• void HAL_GPIO_EXTI_Callback(uint16_t GPIO_Pin)

• For LED turn on we need to use this functions

• HAL_GPIO_WritePin

39

/* USER CODE BEGIN 4 */
void HAL_GPIO_EXTI_Callback(uint16_t GPIO_Pin)
{
if(GPIO_Pin == GPIO_PIN_0) {
HAL_GPIO_WritePin(GPIOG, GPIO_PIN_14, GPIO_PIN_SET);

} else {
__NOP();

}
}
/* USER CODE END 4 */

1.1.2



1.2.1 Low Power mode SLEEP 

lab 
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Use SLEEP mode with EXTI

• Objective

• We use the EXTI setup from lab 1

• Learn how to setup SLEEP in HAL

• Create simple project with SLEEP mode with wake up on pin press

• Goal

• Use project from EXTI lab

• Learn how to setup the SLEEP in HAL,  and which events can wake up 

MCU

• Verify the correct functionality by measuring consumption

411.2.1



SLEEP Mode
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Use SLEEP mode with EXTI

HAL Library work flow summary
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Configure the GPIO to generate interrupt on 

rising or falling edge

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_EXTI0_IRQHandler

Edge detection callback

HAL_GPIO_EXTI_Callback

EXTI0_IRQHandler

2. init GPIO

1. init NVIC

4. create 

edge

6. HAL EXTI 

interrupt handler

7. HAL EXTI 

callback

HAL files clearing 

flags, check errors, 

…

Enter into SLEEP mode(WFI)

3. Use WFI

5. EXTI interrupt 

handler

1.2.1



Use SLEEP mode with EXTI

• Now we open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 3 */ and /* USER CODE END 3 */ tags

• Function to enter SLEEP

• HAL_PWR_EnterSLEEPMode(uint32_t Regulator, uint8_t SLEEPEntry)

• We can measure consumption

44

To be able to reprogram 

the STM32 which is in 

LP mode, use 

connection during 

reset option

1.2.1



Use SLEEP mode with EXTI

• Now we open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 3 */ and /* USER CODE END 3 */ tags

• Function to enter SLEEP

• HAL_PWR_EnterSLEEPMode(uint32_t Regulator, uint8_t SLEEPEntry)

• We can measure consumption
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/* USER CODE BEGIN 3 */
/* Infinite loop */
while (1)
{
HAL_Delay(1000);

HAL_PWR_EnterSLEEPMode(PWR_LOWPOWERREGULATOR_ON,PWR_SLEEPENTRY_WFI);
}
/* USER CODE END 3 */

1.2.1



Use SLEEP mode with EXTI

• Consumption still to high?

• Is STM32 really in SLEEP?

• Is the Systick disabled?

• Is this better?

46

/* USER CODE BEGIN 3 */
/* Infinite loop */
while (1)
{
HAL_Delay(1000);
HAL_SuspendTick();
HAL_PWR_EnterSLEEPMode(PWR_LOWPOWERREGULATOR_ON,PWR_SLEEPENTRY_WFI);
HAL_ResumeTick();

}
/* USER CODE END 3 */

1.2.1



1.2.2 Low Power mode STOP lab 

06/12/2016STM32F42xx Technical Training              



Use STOP mode with EXTI

• Objective

• We use the EXTI setup from lab 1

• Learn how to setup STOP in HAL

• Create simple project with STOP mode with wake up on pin press

• Goal

• Use project from EXTI lab

• Learn how to setup the STOP in HAL, which events can wake up you

• Verify the correct functionality by measuring consumption

481.2.2



Clock
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1.2.2



Use STOP mode with EXTI

HAL Library work flow summary
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Configure the GPIO to generate interrupt on 

rising or falling edge

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_EXTI0_IRQHandler

Edge detection callback

HAL_GPIO_EXTI_Callback

EXTI0_IRQHandler

2. init GPIO

1. init NVIC

4. create 

edge

6. HAL EXTI 

interrupt handler

7. HAL EXTI 

callback

HAL files clearing 

flags, check errors, 

…

Enter into STOP mode(WFI)
3. Use WFI

5. EXTI interrupt 

handler

Clock reconfigure

8. Reconfigure 

clock after 

wakeup
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Use STOP mode with EXTI

• Now we open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 3 */ and /* USER CODE END 3 */ tags

• Function to enter SLEEP

• HAL_PWR_EnterSTOPMode(uint32_t Regulator, uint8_t STOPEntry)

• HAL_PWREx_EnterUnderDriveSTOPMode(uint32_t Regulator, uint8_t STOPEntry)

• We can measure consumption

51

To be able to reprogram 

the STM32 which is in 

LP mode, use 

connection during 

reset option

1.2.2



Use STOP mode with EXTI

• Now we open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 3 */ and /* USER CODE END 3 */ tags

• Function to enter SLEEP

• HAL_PWR_EnterSTOPMode(uint32_t Regulator, uint8_t STOPEntry)

• HAL_PWREx_EnterUnderDriveSTOPMode(uint32_t Regulator, uint8_t STOPEntry)

• We can measure consumption

52

/* USER CODE BEGIN 3 */
/* Infinite loop */
while (1)
{
HAL_Delay(1000);  
HAL_PWR_EnterSTOPMode(PWR_LOWPOWERREGULATOR_ON,PWR_STOPENTRY_WFI);
SystemClock_Config();

}
/* USER CODE END 3 */

1.2.2



Use STOP mode with EXTI

• Or different function (for STM32F42X/43X)

53

/* USER CODE BEGIN 3 */
/* Infinite loop */
while (1)
{

HAL_Delay(1000);  
HAL_PWREx_EnterUnderDriveSTOPMode(PWR_LOWPOWERREGULATOR_UNDERDRIVE_ON,PWR_STOPENTRY_WFI);
SystemClock_Config();

}
/* USER CODE END 3 */

1.2.2



1.2.3 Low Power mode STANDBY 

lab
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Use STANDBY mode

• Objective

• For this lab create CubeMX project

• For testing purpose enable LED on PG14

• Learn how to setup STANDBY in HAL

• Create simple project with STANDBY mode with wake up on pin press

• Goal

• Learn how to setup the STANDBY in HAL, which events can wake up you

• Verify the correct functionality by measuring consumption

551.2.3



Clock
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Use STANDBY mode

HAL Library work flow summary
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Enable Wake-up pin

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

2. Standby

1. init NVIC

4. create 

edge
Enter into STANDBY mode(WFI)

3. Use WFI

Reset
5. Wake up 

STM with reset
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Use STANDBY mode

• Now we open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 3 */ and /* USER CODE END 3 */ tags

• For Wake up we need to setup wake up pin

• HAL_PWR_EnableWakeUpPin(uint32_t WakeUpPinx)

• Function to enter STANDBY

• HAL_PWR_EnterSTANDBYMode();

• We can measure consumption

58

To be able to reprogram 

the STM32 which is in 

LP mode, use 

connection during 

reset option

1.2.3



Use STANDBY mode

• Now we open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 3 */ and /* USER CODE END 3 */ tags

• Function to enter SLEEP

• HAL_PWR_EnterSTOPMode(uint32_t Regulator, uint8_t STOPEntry)

• HAL_PWREx_EnterUnderDriveSTOPMode(uint32_t Regulator, uint8_t STOPEntry)

• We can measure consumption
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/* USER CODE BEGIN 3 */
/* Infinite loop */
while (1)
{
HAL_GPIO_TogglePin(GPIOG, GPIO_PIN_14);
HAL_Delay(2000);
HAL_PWR_EnableWakeUpPin(PWR_WAKEUP_PIN1);
HAL_PWR_EnterSTANDBYMode();

}
/* USER CODE END 3 */

1.2.3



Use STANDBY mode

• We cannot go into STANDBY again?

• Try to clear wake up flag

• __HAL_PWR_CLEAR_FLAG(PWR_FLAG_WU);

60

/* USER CODE BEGIN 2 */

__HAL_PWR_CLEAR_FLAG(PWR_FLAG_WU);
/* USER CODE END 2 */

1.2.3



1.3.1 Data transfer over DMA lab
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Use DMA in M2M transfer

• Objective

• Learn how to setup DMA transfer in CubeMX

• Create simple DMA memory to memory transfer from RAM to RAM

• Goal

• Use CubeMX and Generate Code with DMA 

• Learn how to setup the DMA in HAL

• Verify the correct functionality by comparing transferred buffers

621.3.1



Use DMA in M2M transfer 63
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Use DMA in M2M transfer

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• For DMA we don’t need to configure any pins

641.3.1



Use DMA in M2M transfer

• In order to run on maximum frequency, setup clock system

• Details in lab 0

651.3.1



Use DMA in M2M transfer 66

• DMA configuration

• TAB>Configuration

• System>DMA

• TAB>DMA2

• Button ADD

1. TAB > 

Configuration
2. System DMA

3. TAB>DMA 2

4. Add DMA 

channel

1.3.1



Use DMA in M2M transfer 67

• DMA configuration

• Select MEMTOMEM 

DMA request

• Normal mode

• Increment source and 

destination address

• FIFO setup

• Byte data width

• Burst size

• Button OK

1. MEMTOMEM

2. Normal 

mode

3. Increment 

addresses

4. FIFO setup

5. Data width and 

Burst

6. OK

1.3.1



Use DMA in M2M transfer

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

681.3.1



Use DMA in M2M transfer

• Start process DMA (same for TIM, ADC)

• Non blocking start process 

• The end of the process must be checked by polling

69

Peripheral 

Initializations

Start Process

(HAL_DMA_Start)

Poll for process complete

(HAL_DMA_PollForTransfer)

1. init DMA

2. Start DMA

3. DMA transfer data

4. Check if transfer is complete

1.3.1



Use DMA in M2M transfer

• Return values

• Most of CubeMX functions have return values, which indicate, if operation was successful, 

timeout occurs of function end with error

• Is recommended handle this return values to be sure that program working as expected

70

Ex: Poll for process complete

(HAL_DMA_PollForTransfer)

HAL_ERRORHAL_OK HAL_BUSY

DMA transfer was successfully 

finished and data was 

transferred to destination 

without error

1.3.1



Use DMA in M2M transfer

• Return values

• Most of CubeMX functions have return values, which indicate, if operation was successful, 

timeout occurs of function end with error

• Is recommended handle this return values to be sure that program working as expected

71

Ex: Poll for process complete

(HAL_DMA_PollForTransfer)

HAL_ERRORHAL_OK HAL_BUSY

Error occurs during DMA 

transfer you use 

HAL_DMA_GetError for 

details what happened

1.3.1



Use DMA in M2M transfer

• Return values

• Most of CubeMX functions have return values, which indicate, if operation was successful, 

timeout occurs of function end with error

• Is recommended handle this return values to be sure that program working as expected

72

Ex: Poll for process complete

(HAL_DMA_PollForTransfer)

HAL_ERRORHAL_OK HAL_BUSY

DMA transfer in progress, 

user can only abort the 

transfer

1.3.1



Use DMA in M2M transfer

• Now we open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 2 */ and /* USER CODE END 2 */ tags

• HAL functions for DMA

• HAL_DMA_Start(DMA_HandleTypeDef *hdma, uint32_t SrcAddress, uint32_t DstAddress, 

uint32_t DataLength)

• HAL_DMA_PollForTransfer(DMA_HandleTypeDef *hdma, uint32_t CompleteLevel, uint32_t 

Timeout)

731.3.1



Use DMA in M2M transfer

• We create two buffers 

• One with source data 

• Second as destination buffer

74

/* USER CODE BEGIN 0 */
uint8_t Buffer_Src[]={0,1,2,3,4,5,6,7,8,9};
uint8_t Buffer_Dest[10];
/* USER CODE END 0 */

1.3.1



Use DMA in M2M transfer

• HAL_DMA_Start start the M2M data transfer

• HAL_DMA_PollForTransfer check if the transfer ends successfully

75

/* USER CODE BEGIN 2 */
HAL_DMA_Start(&hdma_memtomem_dma2_stream0, (uint32_t) (Buffer_Src), (uint32_t) (Buffer_Dest), 10);
while(HAL_DMA_PollForTransfer(&hdma_memtomem_dma2_stream0, HAL_DMA_FULL_TRANSFER, 100) != HAL_OK)
{
__NOP();

}
/* USER CODE END 2 */

1.3.1



1.3.2 Data transfer over DMA with 

interrupt lab
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Use DMA M2M with interrupt

• Objective

• Learn how to setup DMA transfer with interrupt in CubeMX

• Create simple DMA memory to memory transfer from RAM to RAM

• Goal

• Use CubeMX and Generate Code with DMA 

• Learn how to setup the DMA in HAL

• Verify the correct functionality by comparing transferred buffers

771.3.2



Use DMA M2M with interrupt

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• For DMA we don’t need to configure any pins

781.3.2



Use DMA M2M with interrupt

• In order to run on maximum frequency, setup clock system

• Details in lab 0

791.3.2



Use DMA M2M with interrupt 80

• DMA configuration

• TAB>Configuration

• System>DMA

• TAB>DMA2

• Button ADD

1. TAB > 

Configuration
2. System DMA

3. TAB>DMA 2

4. Add DMA 

channel

1.3.2



Use DMA M2M with interrupt 81

• DMA configuration

• Select MEMTOMEM 

DMA request

• Normal mode

• Increment source and 

destination address

• FIFO setup

• Byte data width

• Burst size

• Button OK

1. MEMTOMEM

2. Normal 

mode

3. Increment 

addresses

4. FIFO setup

5. Data width and 

Burst

6. OK

1.3.2



Use DMA M2M with interrupt 82

• DMA configuration

• System > NVIC

• Enable DMA2 Stream interrupt

• Button OK

1. TAB > 

Configuration

3. Enable DMA2 

interrupts

2. System > NVIC

4. OK

1.3.2



Use DMA M2M with interrupt

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

831.3.2



Use DMA M2M with interrupt

HAL Library DMA with IT flow

84

Start process with interrupt generation at end 

of process

HAL_DMA_Start_IT

DMA Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

end of process callback

DMA_XferCpltCallback

process Error callback

DMA_XferErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA2_Stream0_IRQHandler

1.3.2



Use DMA M2M with interrupt

HAL Library DMA with IT flow

85

Start process with interrupt generation at end 

of process

HAL_DMA_Start_IT

DMA Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

end of process callback

DMA_XferCpltCallback

process Error callback

DMA_XferErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA2_Stream0_IRQHandler

Generated by CubeMX

1.3.2



Use DMA M2M with interrupt

HAL Library DMA with IT flow

86

Start process with interrupt generation at end 

of process

HAL_DMA_Start_IT

DMA Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

end of process callback

DMA_XferCpltCallback

process Error callback

DMA_XferErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA2_Stream0_IRQHandler

Defined by user

1.3.2



Use DMA M2M with interrupt

HAL Library DMA with IT flow

87

Start process with interrupt generation at end 

of process

HAL_DMA_Start_IT

DMA Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

end of process callback

DMA_XferCpltCallback

process Error callback

DMA_XferErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA2_Stream0_IRQHandler

Generated in main.c

1.3.2



Use DMA M2M with interrupt

HAL Library DMA with IT flow

88

Start process with interrupt generation at end 

of process

HAL_DMA_Start_IT

DMA Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

end of process callback

DMA_XferCpltCallback

process Error callback

DMA_XferErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA2_Stream0_IRQHandler

We recommend to use it 

in main.c

1.3.2



Use DMA M2M with interrupt

HAL Library DMA with IT flow

89

Start process with interrupt generation at end 

of process

HAL_DMA_Start_IT

DMA Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

end of process callback

DMA_XferCpltCallback

process Error callback

DMA_XferErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA2_Stream0_IRQHandler

User defined functions. The 

user must define functions by 

himself and put function names 

into DMA structure

1.3.2



Use DMA M2M with interrupt

HAL Library DMA with IT flow

90

Start process with interrupt generation at end 

of process

HAL_DMA_Start_IT

DMA Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

end of process callback

DMA_XferCpltCallback

process Error callback

DMA_XferErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA2_Stream0_IRQHandler

Generated in 

stm32f4xx_it.c

1.3.2



Use DMA M2M with interrupt

HAL Library DMA with IT flow

91

Start process with interrupt generation at end 

of process

HAL_DMA_Start_IT

DMA Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

end of process callback

DMA_XferCpltCallback

process Error callback

DMA_XferErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA2_Stream0_IRQHandler

Defined in 

stm32f4xx_hal_dma.c

1.3.2



Use DMA M2M with interrupt

HAL Library DMA with IT flow

92

Start process with interrupt generation at end 

of process

HAL_DMA_Start_IT

DMA Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

end of process callback

DMA_XferCpltCallback

process Error callback

DMA_XferErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA2_Stream0_IRQHandler

Start DMA buffer transfer

Not blocking function 

program can continue

1.3.2



Use DMA M2M with interrupt

HAL Library DMA with IT flow

93

Start process with interrupt generation at end 

of process

HAL_DMA_Start_IT

DMA Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

end of process callback

DMA_XferCpltCallback

process Error callback

DMA_XferErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA2_Stream0_IRQHandler

Interrupt indicate DMA 

process is half/complete 

or error was detected

1.3.2



Use DMA M2M with interrupt

HAL Library DMA with IT flow

94

Start process with interrupt generation at end 

of process

HAL_DMA_Start_IT

DMA Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

end of process callback

DMA_XferCpltCallback

process Error callback

DMA_XferErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA2_Stream0_IRQHandler

Process interrupt 

information

1.3.2



Use DMA M2M with interrupt

HAL Library DMA with IT flow

95

Start process with interrupt generation at end 

of process

HAL_DMA_Start_IT

DMA Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

end of process callback

DMA_XferCpltCallback

process Error callback

DMA_XferErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA2_Stream0_IRQHandler

Data correctly transferred

Complete callback 

function

1.3.2



Use DMA M2M with interrupt

HAL Library DMA with IT flow

96

Start process with interrupt generation at end 

of process

HAL_DMA_Start_IT

DMA Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

end of process callback

DMA_XferCpltCallback

process Error callback

DMA_XferErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA2_Stream0_IRQHandler

Error was detected 

Error callback function

1.3.2



Use DMA M2M with interrupt

HAL Library DMA with IT flow

97

Start process with interrupt generation at end 

of process

HAL_DMA_Start_IT

DMA Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

end of process callback

DMA_XferCpltCallback

process Error callback

DMA_XferErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA2_Stream0_IRQHandler

1. DMA init

2. DMA transfer 

start

3. DMA transfer 

complete or error
4. HAL DMA 

management5. DMA transfer 

was correct

5. Error in DMA 

transfer

1.3.2



Use DMA M2M with interrupt

• Now we open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 2 */ and /* USER CODE END 2 */ tags

• DMA callback function

• We need to add the name of callback function into DMA structure

• HAL functions for DMA

• HAL_DMA_Start_IT(DMA_HandleTypeDef *hdma, uint32_t SrcAddress, uint32_t DstAddress, 

uint32_t DataLength)

981.3.2



Use DMA M2M with interrupt

• We create two buffers 

• One with source data 

• Second as destination buffer

99

/* USER CODE BEGIN 0 */
uint8_t Buffer_Src[]={0,1,2,3,4,5,6,7,8,9};
uint8_t Buffer_Dest[10];
/* USER CODE END 0 */

1.3.2



Use DMA M2M with interrupt

• DMA callback creation function prototype

• DMA complete callback with nop where we can put breakpoint

100

/* USER CODE BEGIN 4 */
void XferCpltCallback(DMA_HandleTypeDef *hdma)
{
__NOP();//we reach this only if DMA transfer was correct

}
/* USER CODE END 4 */

/* USER CODE BEGIN 0 */
uint8_t Buffer_Src[]={0,1,2,3,4,5,6,7,8,9};
uint8_t Buffer_Dest[10];

void XferCpltCallback(DMA_HandleTypeDef *hdma);
/* USER CODE END 0 */

1.3.2



Use DMA M2M with interrupt

• DMA Start

• Before we start the DMA with interrupt we need to set the callback into DMA structure

• Then is possible use the HAL_DMA_Start_IT to begin DMA transfer

101

/* USER CODE BEGIN 2 */
hdma_memtomem_dma2_stream0.XferCpltCallback=&XferCpltCallback;
HAL_DMA_Start_IT(&hdma_memtomem_dma2_stream0,(uint32_t)Buffer_Src,(uint32_t)Buffer_Dest,10);
/* USER CODE END 2 */

1.3.2



2.1.1 UART Poll lab

06/12/2016STM32F42xx Technical Training              



Simple UART communication

• Objective

• Learn how to setup UART in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Work in pairs, one will create transmitter and second receiver

• Goal

• Configure UART in CubeMX and Generate Code

• Learn how to send and receive data over UART without interrupts

• Verify the correct functionality

1032.1.1



Simple UART communication

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• Pin selection

• We are looking for free pins where is possible to create wire loopback connection

1042.1.1



Simple UART communication

• Pin selection

• We are looking for free pins 

where is possible to create 

wire loopback connection

105

Image from 

STM32F429-Discovery 

user manual

2.1.1



Simple UART communication

• Pin selection

• We are looking for free pins where is possible to create wire loopback connection

106

Image from 

STM32F429 

datasheet

2.1.1



Simple UART communication

• Hardware preparation

• We connect selected pins together by jumper, this help us to create loopback on UART

107

Hardware 

connection 

RX <-TX

TX>RX

2.1.1



Simple UART communication

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX UART selection

• Select USART1 in asynchronous mode

• Select PA9 and PA10 for USART1 if weren't selected

1082.1.1



Simple UART communication

• In order to run on maximum frequency, setup clock system

• Details in lab 0

1092.1.1



Simple UART communication

• CubeMX UART configuration

• Tab>Configuration>Connectivity>USART1

1102.1.1



Simple UART communication

• CubeMX USART configuration check:

• BaudRate

• World length

• Parity

• Stop bits

• Data direction

• Oversampling

1112.1.1



Simple UART communication

• CubeMX USART GPIO configuration check:

• On high baud rate set the 

GPIO speed to HIGH

• TAB>Configuration>System>

>GPIO

• Set the HIGH output speed

Button OK

1122.1.1



Simple UART communication

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

1132.1.1



Init GPIO and NVIC for UART

HAL_UART_MspInit callback

HAL_UART_Init(&huart1);

Init UART1 structure

Simple UART communication

HAL Library init flow

114

Peripheral Initializations

MX_USART1_UART_Init();

CubeMX UART init start in 

main.c file

2.1.1



Init GPIO and NVIC for UART

HAL_UART_MspInit callback

HAL_UART_Init(&huart1);

Init UART1 structure

Simple UART communication

HAL Library init flow

115

Peripheral Initializations

MX_USART1_UART_Init();

1. We need init

UART1

2.1.1



Init GPIO and NVIC for UART

HAL_UART_MspInit callback

HAL_UART_Init(&huart1);

Init UART1 structure

Simple UART communication

HAL Library init flow

116

Peripheral Initializations

MX_USART1_UART_Init();

1. We need init

UART1

CubeMX create for us 

function which handle 

UART initialization

2.1.1



Init GPIO and NVIC for UART

HAL_UART_MspInit callback

HAL_UART_Init(&huart1);

Init UART1 structure

Simple UART communication

HAL Library init flow

117

Peripheral Initializations

MX_USART1_UART_Init();

1. We need init

UART1

2. Call UART1 init

function

2.1.1



Init GPIO and NVIC for UART

HAL_UART_MspInit callback

HAL_UART_Init(&huart1);

Init UART1 structure

Simple UART communication

HAL Library init flow

118

Peripheral Initializations

MX_USART1_UART_Init();

1. We need init

UART1

2. Call UART1 init

function

CubeMX fill the UART 

structure with parameters 

which we choose in 

Configuration window

2.1.1



Init GPIO and NVIC for UART

HAL_UART_MspInit callback

HAL_UART_Init(&huart1);

Init UART1 structure

Simple UART communication

HAL Library init flow

119

Peripheral Initializations

MX_USART1_UART_Init();

1. We need init

UART1

2. Call UART1 init

function

3. Store UART1 configuration 

into structure

2.1.1



Init GPIO and NVIC for UART

HAL_UART_MspInit callback

HAL_UART_Init(&huart1);

Init UART1 structure

Simple UART communication

HAL Library init flow

120

Peripheral Initializations

MX_USART1_UART_Init();

1. We need init

UART1

2. Call UART1 init

function

3. Store UART1 configuration 

into structure

Function wrote 

parameters from structure 

into UART1 registers

2.1.1



Init GPIO and NVIC for UART

HAL_UART_MspInit callback

HAL_UART_Init(&huart1);

Init UART1 structure

Simple UART communication

HAL Library init flow

121

Peripheral Initializations

MX_USART1_UART_Init();

1. We need init

UART1

2. Call UART1 init

function

3. Store UART1 configuration 

into structure

4. Write to UART1 registers

Optional callback from 

HAL_UART_Init function, 

be default empty weak 

function

2.1.1



Init GPIO and NVIC for UART

HAL_UART_MspInit callback

HAL_UART_Init(&huart1);

Init UART1 structure

Simple UART communication

HAL Library init flow

122

Peripheral Initializations

MX_USART1_UART_Init();

1. We need init

UART1

2. Call UART1 init

function

3. Store UART1 configuration 

into structure

4. Write to UART1 registers

CubeMX configure here 

UART1 GPIOs and 

enable UART1 clock 

system

2.1.1



Init GPIO and NVIC for UART

HAL_UART_MspInit callback

HAL_UART_Init(&huart1);

Init UART1 structure

Simple UART communication

HAL Library init flow

123

Peripheral Initializations

MX_USART1_UART_Init();

1. We need init

UART1

2. Call UART1 init

function

3. Store UART1 configuration 

into structure

4. Write to UART1 registers

CubeMX configure here 

UART1 GPIOs and 

enable UART1 clock 

system and NVIC

5. UART1 init callback

2.1.1



Init GPIO and NVIC for UART

HAL_UART_MspInit callback

HAL_UART_Init(&huart1);

Init UART1 structure

Simple UART communication

HAL Library init flow

124

Peripheral Initializations

MX_USART1_UART_Init();

1. We need init

UART1

2. Call UART1 init

function

3. Store UART1 configuration 

into structure

4. Write to UART1 registers

5. UART1 init callback

6. UART1 GPIOS, NVIC and RCC init

2.1.1



Init GPIO and NVIC for UART

HAL_UART_MspInit callback

HAL_UART_Init(&huart1);

Init UART1 structure

Simple UART communication

HAL Library init flow

125

Peripheral Initializations

MX_USART1_UART_Init();

1. We need init

UART1

2. Call UART1 init

function

3. Store UART1 configuration 

into structure

4. Write to UART1 registers

5. UART1 init callback

6. UART1 GPIOS, NVIC and RCC init

7. Next periph init or user code

2.1.1



Simple UART communication

HAL Library transmit flow

126

Generated by 

CubeMX

HAL_TIMEOUT HAL_ERRORHAL_OK

Function blocks

Polling with timeout

Peripheral Initializations

Polling process

HAL_UART_Transmit

HAL_BUSY

2.1.1



Simple UART communication

HAL Library transmit flow

127

Created by user

HAL_TIMEOUT HAL_ERRORHAL_OK

Function blocks

Polling with timeout

Peripheral Initializations

Polling process

HAL_UART_Transmit

HAL_BUSY

2.1.1



Simple UART communication

HAL Library receive flow

128

Generated by 

CubeMX

HAL_TIMEOUT HAL_ERRORHAL_OK

Function blocks

Polling with timeout

Peripheral Initializations

Polling process

HAL_UART_Receive

HAL_BUSY

2.1.1



Simple UART communication

HAL Library receive flow

129

Created by user

HAL_TIMEOUT HAL_ERRORHAL_OK

Function blocks

Polling with timeout

Peripheral Initializations

Polling process

HAL_UART_Receive

HAL_BUSY

2.1.1



Simple UART communication

• Open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 3 */ and /* USER CODE END 3 */ tags

• Into infinite while function

• For transmit use function

• HAL_UART_Transmit(UART_HandleTypeDef *huart, uint8_t *pData, uint16_t Size, uint32_t Timeout)

• For receive use function

• HAL_UART_Receive(UART_HandleTypeDef *huart, uint8_t *pData, uint16_t Size, uint32_t Timeout);

1302.1.1



Simple UART communication

• Transmit solution

• Create data structure for data

• Call transmit function from while loop

131

/* USER CODE BEGIN 3 */
/* Infinite loop */
while (1)
{
HAL_UART_Transmit(&huart1,data,10,1000);

}
/* USER CODE END 3 */

/* USER CODE BEGIN 0 */
uint8_t data[]={0,1,2,3,4,5,6,7,8,9};
/* USER CODE END 0 */

2.1.1



Simple UART communication

• Receive solution

• Create data structure for data

• Call transmit function from while loop

132

/* USER CODE BEGIN 3 */
/* Infinite loop */
while (1)
{
HAL_UART_Receive(&huart1,data,10,1000);

}
/* USER CODE END 3 */

/* USER CODE BEGIN 0 */
uint8_t data[10];
/* USER CODE END 0 */

2.1.1



2.1.2 UART Interrupt lab 

06/12/2016STM32F42xx Technical Training              



Use UART with interrupt

• Objective

• Learn how to setup UART with interrupts in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Create simple loopback example with interrupts

• Goal

• Configure UART in CubeMX and Generate Code

• Learn how to send and receive data over UART with interrupts

• Verify the correct functionality

1342.1.2



Use UART with interrupt

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• Pin selection

• It will be same as previous lab we use again PA9 and PA10

1352.1.2



Use UART with interrupt

• Hardware preparation

• We connect selected pins together by jumper, this help us to create loopback on UART

136

Hardware 

loopback

2.1.2



Use UART with interrupt

• In order to run on maximum frequency, setup clock system

• Details in lab 0

1372.1.2



Use UART with interrupt

• CubeMX UART configuration

• Tab>Configuration>Connectivity>USART1

1382.1.2



Use UART with interrupt

• CubeMX UART configuration check:

• BaudRate

• World length

• Parity

• Stop bits

• Data direction

• Oversampling

1392.1.2



Use UART with interrupt

• CubeMX USART configuration NVIC settings

• TAB>NVIC Settings

• Enable interrupts

• OK

1402.1.2



Use UART with interrupt

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

1412.1.2



Use UART with interrupt

HAL Library UART with IT receive flow

142

Start process with interrupt generation at end 

of process

HAL_UART_Receive_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_RxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

2.1.2



Use UART with interrupt

HAL Library UART with IT transmit flow

143

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

2.1.2



Use UART with interrupt

HAL Library UART with IT transmit flow

144

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

Generated by CubeMX

2.1.2



Use UART with interrupt

HAL Library UART with IT receive flow

145

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

Defined by user

2.1.2



Use UART with interrupt

HAL Library UART with IT receive flow

146

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

Generated in main.c and 

stm32f4xx_hal_msp.c

2.1.2



Use UART with interrupt

HAL Library UART with IT receive flow

147

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

We recommend to use it 

in main.c

2.1.2



Use UART with interrupt

HAL Library UART with IT receive flow

148

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

Defined as __weak you can 

find name of this functions in 

stm32f4xx_hal_uart.c

2.1.2



Use UART with interrupt

HAL Library UART with IT receive flow

149

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

Generated in 

stm32f4xx_it.c

2.1.2



Use UART with interrupt

HAL Library UART with IT receive flow

150

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

Defined in 

stm32f4xx_hal_uart.c

2.1.2



Use UART with interrupt

HAL Library UART with IT receive flow

151

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

Send buffer over UART

Not blocking function 

program can continue

2.1.2



Use UART with interrupt

HAL Library UART with IT receive flow

152

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

Interrupt indicate the data 

register is empty we can 

send more data or error 

was detected

2.1.2



Use UART with interrupt

HAL Library UART with IT receive flow

153

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

Process interrupt 

information

2.1.2



Use UART with interrupt

HAL Library UART with IT receive flow

154

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

Send more data if is buffer 

not empty

2.1.2



Use UART with interrupt

HAL Library UART with IT receive flow

155

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

If data buffer is empty use 

Complete callback 

function

2.1.2



Use UART with interrupt

HAL Library UART with IT receive flow

156

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

Or if error was detected 

use Error callback 

function

2.1.2



Use UART with interrupt

HAL Library UART with IT receive flow

157

Start process with interrupt generation at end 

of process

HAL_UART_Transmit_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_UART_IRQHandler

end of process callback

HAL_UART_TxCpltCallback

process Error callback

HAL_UART_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY USART1_IRQHandler

1. UART1 init

2. UART1 send 

buffer

3. UART1 Tx

register empty

4. Send more 

data or manage 

error5. Buffer sent

5. Transmit error

2.1.2



Use UART with interrupt

• Open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 2 */ and /* USER CODE END 2 */ tags

• For transmit use function

• HAL_UART_Transmit_IT(UART_HandleTypeDef *huart, uint8_t *pData, uint16_t Size);

• For receive use function

• HAL_UART_Receive_IT(UART_HandleTypeDef *huart, uint8_t *pData, uint16_t Size);

1582.1.2



Use UART with interrupt

• Buffer definition

• Sending and receiving methods

159

/* USER CODE BEGIN 0 */
uint8_t tx_buff[]={0,1,2,3,4,5,6,7,8,9};
uint8_t rx_buff[10];
/* USER CODE END 0 */

/* USER CODE BEGIN 2 */
HAL_UART_Receive_IT(&huart1,rx_buff,10);
HAL_UART_Transmit_IT(&huart1,tx_buff,10);
/* USER CODE END 2 */

2.1.2



Use UART with interrupt

• Complete callback check

• We can put brakepoints on NOPs to watch if we send or receive complete buffer

160

/* USER CODE BEGIN 4 */
void HAL_UART_RxCpltCallback(UART_HandleTypeDef *huart)
{
__NOP();//test if we reach this position

}

void HAL_UART_TxCpltCallback(UART_HandleTypeDef *huart)
{
__NOP();//test if we reach this position

}
/* USER CODE END 4 */

2.1.2



2.1.3 UART DMA lab

06/12/2016STM32F42xx Technical Training              



Use UART with DMA transfer

• Objective

• Learn how to setup UART with DMA in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Create simple loopback example with DMA 

• Goal

• Configure UART in CubeMX and Generate Code

• Learn how to send and receive data over UART with DMA

• Verify the correct functionality

1632.1.3



Use UART with DMA transfer

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• Pin selection

• It will be same as previous lab we use again PA9 and PA10

1642.1.3



Use UART with DMA transfer

• Hardware preparation

• We connect selected pins together by jumper, this help us to create loopback on UART

165

Hardware 

loopback

2.1.3



Use UART with DMA transfer

• In order to run on maximum frequency, setup clock system

• Details in lab 0

1662.1.3



Use UART with DMA transfer

• CubeMX UART configuration

• Tab>Configuration>Connectivity>USART1

1672.1.3



Use UART with DMA transfer

• CubeMX USART configuration check:

• BaudRate

• World length

• Parity

• Stop bits

• Data direction

• Oversampling

1682.1.3



Use UART with DMA transfer

• CubeMX USART configuration DMA settings

• TAB>DMA Settings

• Button ADD

1692.1.3



Use UART with DMA transfer

• CubeMX USART configuration DMA Tx settings

• Set USART1_TX request

• Memory to peripheral direction

• Normal mode

• Byte data width

• Increment memory address

1702.1.3



Use UART with DMA transfer

• CubeMX USART configuration DMA Rx settings

• Button ADD

• Set USART1_RX request

• Peripheral to memory direction

• Normal mode

• Byte data width

• Increment memory address

1712.1.3



Use UART with DMA transfer

• CubeMX USART configuration NVIC settings

• TAB>NVIC Settings

• Enable DMA2 interrupts for 

USART1

• Button OK

1722.1.3



Use UART with DMA transfer

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

1732.1.3



Use UART with DMA transfer

HAL Library UART with DMA RX flow

174

Start process with DMA end of transfer 

interrupt generation at end of process

HAL_UART_Receive_DMA

Peripheral Initializations 

including DMA stream initializations

HAL_DMA_IRQHandler

end of process callback

HAL_UART_RxCpltCallback

DMA_Stream_IRQ

Handler

process Error callback

HAL_UART_ErrorCallback

HAL_OK HAL_ERROR HAL_ERROR

2.1.3



Use UART with DMA transfer

HAL Library UART with DMA RX flow

175

Start process with DMA end of transfer 

interrupt generation at end of process

HAL_UART_Receive_DMA

Peripheral Initializations 

including DMA stream initializations

HAL_DMA_IRQHandler

end of process callback

HAL_UART_RxCpltCallback

DMA_Stream_IRQ

Handler

process Error callback

HAL_UART_ErrorCallback

HAL_OK HAL_ERROR HAL_ERROR

Generated by CubeMX

2.1.3



Use UART with DMA transfer

HAL Library UART with DMA RX flow

176

Start process with DMA end of transfer 

interrupt generation at end of process

HAL_UART_Receive_DMA

Peripheral Initializations 

including DMA stream initializations

HAL_DMA_IRQHandler

end of process callback

HAL_UART_RxCpltCallback

DMA_Stream_IRQ

Handler

process Error callback

HAL_UART_ErrorCallback

HAL_OK HAL_ERROR HAL_ERROR

Defined by user

2.1.3



Use UART with DMA transfer

HAL Library UART with DMA RX flow

177

Start process with DMA end of transfer 

interrupt generation at end of process

HAL_UART_Receive_DMA

Peripheral Initializations 

including DMA stream initializations

HAL_DMA_IRQHandler

end of process callback

HAL_UART_RxCpltCallback

DMA_Stream_IRQ

Handler

process Error callback

HAL_UART_ErrorCallback

HAL_OK HAL_ERROR HAL_ERROR

Generated in main.c and 

stm32f4xx_hal_msp.c

2.1.3



Use UART with DMA transfer

HAL Library UART with DMA RX flow

178

Start process with DMA end of transfer 

interrupt generation at end of process

HAL_UART_Receive_DMA

Peripheral Initializations 

including DMA stream initializations

HAL_DMA_IRQHandler

end of process callback

HAL_UART_RxCpltCallback

DMA_Stream_IRQ

Handler

process Error callback

HAL_UART_ErrorCallback

HAL_OK HAL_ERROR HAL_ERROR

We recommend to use it 

in main.c

2.1.3



Use UART with DMA transfer

HAL Library UART with DMA RX flow

179

Start process with DMA end of transfer 

interrupt generation at end of process

HAL_UART_Receive_DMA

Peripheral Initializations 

including DMA stream initializations

HAL_DMA_IRQHandler

end of process callback

HAL_UART_RxCpltCallback

DMA_Stream_IRQ

Handler

process Error callback

HAL_UART_ErrorCallback

HAL_OK HAL_ERROR HAL_ERROR

Generated in 

stm32f4xx_it.c

2.1.3



Use UART with DMA transfer

HAL Library UART with DMA RX flow

180

Start process with DMA end of transfer 

interrupt generation at end of process

HAL_UART_Receive_DMA

Peripheral Initializations 

including DMA stream initializations

HAL_DMA_IRQHandler

end of process callback

HAL_UART_RxCpltCallback

DMA_Stream_IRQ

Handler

process Error callback

HAL_UART_ErrorCallback

HAL_OK HAL_ERROR HAL_ERROR

Defined in 

stm32f4xx_hal_dma.c and 

then linked to 

stm32f4xx_hal_uart.c

2.1.3



Use UART with DMA transfer

HAL Library UART with DMA RX flow

181

Start process with DMA end of transfer 

interrupt generation at end of process

HAL_UART_Receive_DMA

Peripheral Initializations 

including DMA stream initializations

HAL_DMA_IRQHandler

end of process callback

HAL_UART_RxCpltCallback

DMA_Stream_IRQ

Handler

process Error callback

HAL_UART_ErrorCallback

HAL_OK HAL_ERROR HAL_ERROR

Receive buffer over UART 

with DMA

Not blocking function 

program can continue

2.1.3



Use UART with DMA transfer

HAL Library UART with DMA RX flow

182

Start process with DMA end of transfer 

interrupt generation at end of process

HAL_UART_Receive_DMA

Peripheral Initializations 

including DMA stream initializations

HAL_DMA_IRQHandler

end of process callback

HAL_UART_RxCpltCallback

DMA_Stream_IRQ

Handler

process Error callback

HAL_UART_ErrorCallback

HAL_OK HAL_ERROR HAL_ERROR

Interrupt indicate the DMA 

receive half/complete 

buffer or DMA error was 

detected

2.1.3



Use UART with DMA transfer

HAL Library UART with DMA RX flow

183

Start process with DMA end of transfer 

interrupt generation at end of process

HAL_UART_Receive_DMA

Peripheral Initializations 

including DMA stream initializations

HAL_DMA_IRQHandler

end of process callback

HAL_UART_RxCpltCallback

DMA_Stream_IRQ

Handler

process Error callback

HAL_UART_ErrorCallback

HAL_OK HAL_ERROR HAL_ERROR

Process interrupt 

information from DMA and 

UART

2.1.3



Use UART with DMA transfer

HAL Library UART with DMA RX flow

184

Start process with DMA end of transfer 

interrupt generation at end of process

HAL_UART_Receive_DMA

Peripheral Initializations 

including DMA stream initializations

HAL_DMA_IRQHandler

end of process callback

HAL_UART_RxCpltCallback

DMA_Stream_IRQ

Handler

process Error callback

HAL_UART_ErrorCallback

HAL_OK HAL_ERROR HAL_ERROR

If data buffer is full HAL 

use Complete callback 

function

2.1.3



Use UART with DMA transfer

HAL Library UART with DMA RX flow

185

Start process with DMA end of transfer 

interrupt generation at end of process

HAL_UART_Receive_DMA

Peripheral Initializations 

including DMA stream initializations

HAL_DMA_IRQHandler

end of process callback

HAL_UART_RxCpltCallback

DMA_Stream_IRQ

Handler

process Error callback

HAL_UART_ErrorCallback

HAL_OK HAL_ERROR HAL_ERROR

Or if DMA error was 

detected use Error 

callback function

2.1.3



Use UART with DMA transfer

HAL Library UART with DMA RX flow

186

Start process with DMA end of transfer 

interrupt generation at end of process

HAL_UART_Receive_DMA

Peripheral Initializations 

including DMA stream initializations

HAL_DMA_IRQHandler

end of process callback

HAL_UART_RxCpltCallback

DMA_Stream_IRQ

Handler

process Error callback

HAL_UART_ErrorCallback

HAL_OK HAL_ERROR HAL_ERROR

1. UART1 and 

DMA2 init

2. UART1 

receive buffer

3. DMA buffer 

full
4. Process 

interrupt5. Buffer 

received

5. Receive error

2.1.3



Use UART with DMA transfer

• Open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 2 */ and /* USER CODE END 2 */ tags

• For transmit use function

• HAL_UART_Transmit_DMA(UART_HandleTypeDef *huart, uint8_t *pData, uint16_t Size);

• For receive use function

• HAL_UART_Receive_DMA(UART_HandleTypeDef *huart, uint8_t *pData, uint16_t Size);

1872.1.3



Use UART with DMA transfer

• Buffer definition

• Sending and receiving methods with DMA

188

/* USER CODE BEGIN 0 */
uint8_t tx_buff[]={0,1,2,3,4,5,6,7,8,9};
uint8_t rx_buff[10];
/* USER CODE END 0 */

/* USER CODE BEGIN 2 */
HAL_UART_Receive_DMA(&huart1,rx_buff,10);
HAL_UART_Transmit_DMA(&huart1,tx_buff,10);
/* USER CODE END 2 */

2.1.3



Use UART with DMA transfer

• Complete callback check

• We can put breakpoints on NOPs to watch if we receive complete buffer

189

/* USER CODE BEGIN 4 */
void HAL_UART_RxCpltCallback(UART_HandleTypeDef *huart)
{
__NOP();//check if we receive all data

}
/* USER CODE END 4 */

2.1.3



2.2.1 SPI Poll lab

06/12/2016STM32F42xx Technical Training              



Simple SPI communication

• Objective

• Learn how to setup SPI in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Goal

• Configure SPI in CubeMX and Generate Code

• Learn how to send and receive data over SPI without interrupts

• Verify the correct functionality

1912.2.1



Simple SPI communication

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• Pin selection

• We are looking for free pins where is possible to create wire loopback connection

1922.2.1



Simple SPI communication

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX SPI selection

• Select SPI1 Full-Duplex Master

• Select PA5, PA6, PA7 for SPI1 if weren't selected

1932.2.1



Simple SPI communication

• Hardware preparation

• Connect PA6 and PA7 together with jumper

194

Hardware 

loopback

2.2.1



Simple SPI communication

• In order to run on maximum frequency, setup clock system

• Details in lab 0

1952.2.1



Simple SPI communication

• CubeMX SPI configuration

• Tab>Configuration>Connectivity>SPI1

• Check the settings

• Button OK

• The CLK frequency 

with core on 180MHz

is now 45MHz

• For this clock use 

HIGH GPIO speed 

1962.2.1



Simple SPI communication

• CubeMX SPI – GPIO configuration

• The SPI CLK frequency 

with core on 180MHz

is now 45MHz

• For this clock use 

HIGH GPIO speed 

• Tab>Configuration>System>

>GPIO

• Tab>SPI1

• Seth High output speed

• Button OK

1972.2.1



Simple SPI communication

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

1982.2.1



Simple SPI communication

HAL Library transmit receive flow

199

HAL_TIMEOUT HAL_ERRORHAL_OK

Function blocks

Polling with timeout

Peripheral Initializations

Polling process

HAL_SPI_TransmitReceive

HAL_BUSY

2.2.1



Simple SPI communication

• Open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 3 */ and /* USER CODE END 3 */ tags

• For transmit and receive use function

• HAL_SPI_TransmitReceive(SPI_HandleTypeDef *hspi, uint8_t *pTxData, uint8_t 

*pRxData, uint16_t Size, uint32_t Timeout)

2002.2.1



Simple SPI communication

• Transmit receive solution

• Create data structure for data

• Call transmit receive function

201

/* USER CODE BEGIN PV */
uint8_t tx_buffer[]={0,1,2,3,4,5,6,7,8,9};
uint8_t rx_buffer[10];
/* USER CODE END PV */

/* USER CODE BEGIN 2 */
HAL_SPI_TransmitReceive(&hspi1,tx_buffer,rx_buffer,10,100);
/* USER CODE END 2 */

2.2.1



2.2.2 SPI Interrupt lab

06/12/2016STM32F42xx Technical Training              



Use SPI with interrupt

• Objective

• Learn how to setup SPI with interrupts in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Create simple loopback example with interrupts

• Goal

• Configure SPI in CubeMX and Generate Code

• Learn how to send and receive data over SPI with interrupts

• Verify the correct functionality

2032.2.2



Use SPI with interrupt

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX SPI selection

• Select SPI1 Full-Duplex Master

• Select PA5, PA6, PA7 for SPI1 if weren't selected

2042.2.2



Use SPI with interrupt

• Hardware preparation

• Connect PA6 and PA7 together with jumper

205

Hardware 

loopback

2.2.2



Use SPI with interrupt

• In order to run on maximum frequency, setup clock system

• Details in lab 0

2062.2.2



Use SPI with interrupt

• CubeMX SPI configuration

• Tab>Configuration>Connectivity>SPI1

• Check the settings

• Button OK

2072.2.2



Use SPI with interrupt

• CubeMX SPI configuration

• TAB>NVIC Settings

• Enable SPI interrupt

• Button OK

2082.2.2



Use SPI with interrupt

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

2092.2.2



Use SPI with interrupt

HAL Library SPI with IT transmit receive flow

210

Start process with interrupt generation at end 

of process

HAL_SPI_TransmitReceive_IT

Peripheral Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_SPI_IRQHandler

end of process callback

HAL_SPI_TxRxCpltCallback

process Error callback

HAL_SPI_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY SPI1_IRQHandler

2.2.2



Use SPI with interrupt

• Open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 2 */ and /* USER CODE END 2 */ tags

• For transmit use function

• HAL_SPI_TransmitReceive_IT(SPI_HandleTypeDef *hspi, uint8_t *pTxData, uint8_t 

*pRxData, uint16_t Size)

2112.2.2



Use SPI with interrupt

• Buffer definition

• Sending and receiving methods

212

/* USER CODE BEGIN 0 */
uint8_t tx_buff[]={0,1,2,3,4,5,6,7,8,9};
uint8_t rx_buff[10];
/* USER CODE END 0 */

/* USER CODE BEGIN 2 */
HAL_SPI_TransmitReceive_IT(&hspi1,tx_buff,rx_buff,10);
/* USER CODE END 2 */

2.2.2



Use SPI with interrupt

• Complete callback check

• We can put breakpoints on NOPs to watch if we send or receive complete buffer

213

/* USER CODE BEGIN 4 */
void HAL_SPI_TxRxCpltCallback(SPI_HandleTypeDef *hspi)
{
__NOP();

}
/* USER CODE END 4 */

2.2.2



2.2.3 SPI DMA lab

06/12/2016STM32F42xx Technical Training              



Use SPI with DMA transfer

• Objective

• Learn how to setup SPI with DMA in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Create simple loopback example with DMA 

• Goal

• Configure SPI in CubeMX and Generate Code

• Learn how to send and receive data over SPI with DMA

• Verify the correct functionality

2152.2.3



Use SPI with DMA transfer

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX SPI selection

• Select SPI1 Full-Duplex Master

• Select PA5, PA6, PA7 for SPI1 if weren't selected

2162.2.3



Use SPI with DMA transfer

• Hardware preparation

• Connect PA6 and PA7 together with jumper

217

Hardware 

loopback

2.2.3



Use SPI with DMA transfer

• In order to run on maximum frequency, setup clock system

• Details in lab 0

2182.2.3



Use SPI with DMA transfer

• CubeMX SPI configuration

• Tab>Configuration>Connectivity>SPI1

• Check the settings

• Button OK

2192.2.3



Use SPI with DMA transfer

• CubeMX SPI configuration DMA settings

• TAB>DMA Settings

• Button ADD

• SPI1_RX

• Memory increment

• Button ADD

• SPI1_Tx

• Memory increment

• Button OK

2202.2.3



Use SPI with DMA transfer

• CubeMX SPI configuration NVIC settings

• TAB>NVIC Settings

• Enable DMA2 interrupts for 

SPI1 

• Button OK

2212.2.3



Use SPI with DMA transfer

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

2222.2.3



Use SPI with DMA transfer

HAL Library SPI with DMA TX RX flow

223

Start process with DMA end of transfer 

interrupt generation at end of process

HAL_SPI_TransmitReceive_DMA

Peripheral Initializations 

including DMA stream initializations

HAL_DMA_IRQHandler

end of process callback

HAL_SPI_TxRxCpltCallback

process Error callback

HAL_SPI_ErrorCallback

HAL_OK HAL_ERROR HAL_ERROR

DMA2_Stream0_IRQ

Handler

2.2.3



Use SPI with DMA transfer

• Open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 2 */ and /* USER CODE END 2 */ tags

• For transmit use function

• HAL_SPI_TransmitReceive_DMA(SPI_HandleTypeDef *hspi, uint8_t *pTxData, uint8_t 

*pRxData, uint16_t Size)

2242.2.3



Use SPI with DMA transfer

• Buffer definition

• Sending and receiving methods

225

/* USER CODE BEGIN 0 */
uint8_t tx_buff[]={0,1,2,3,4,5,6,7,8,9};
uint8_t rx_buff[10];
/* USER CODE END 0 */

/* USER CODE BEGIN 2 */
HAL_SPI_TransmitReceive_DMA(&hspi1,tx_buff,rx_buff,10);
/* USER CODE END 2 */

2.2.3



Use SPI with DMA transfer

• Complete callback check

• We can put breakpoints on NOPs to watch if we send or receive complete buffer

226

/* USER CODE BEGIN 4 */
void HAL_SPI_TxRxCpltCallback(SPI_HandleTypeDef *hspi)
{
__NOP();

}
/* USER CODE END 4 */

2.2.3



2.3.1 I2C Poll lab

06/12/2016STM32F42xx Technical Training              



Simple I2C communication

• Objective

• Learn how to setup i2C in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Work in pairs, one will create I2C transmitter and second I2C receiver

• Goal

• Configure I2C in CubeMX and Generate Code

• Learn how to send and receive data over I2C without interrupts

• Verify the correct functionality

2282.3.1



Simple I2C communication

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX SPI selection

• Select I2C3 Periphery

• Select PA8, PC9 for I2C3 if weren't selected

2292.3.1



Simple I2C communication

• Hardware preparation

• Connect together PA8 and PC9 pins from both boards, and GND

2302.3.1

Hardware connection 

PA8 <-> PA8

PC9<->PC9



Simple I2C communication

• CubeMX I2C configuration

• Tab>Configuration>Connectivity>I2C3

• Check the settings

• Define Slave address

to 20

• Button OK

2312.3.1



Simple I2C communication

• CubeMX I2C configuration

• Tab>GPIO Settings

• Check Pull-UP

• Check GPIO speed

2322.3.1

Check if the Pull-UP resistor are 

necessary in case you are using 

external one

Check the GPIO speed

This two parameters can limit 

I2C maximum speed



Simple I2C communication

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

2332.3.1



Simple I2C communication

• Buffer definition

• Master simple send and receive functions

234

/* USER CODE BEGIN PV */
/* Private variables 
uint8_t data_tx[10]={1,2,3,4,5,6,7,8,9,0};
uint8_t data_rx[10];
/* USER CODE END PV */

/* USER CODE BEGIN 2 */
HAL_Delay(100);
HAL_I2C_Master_Transmit(&hi2c3,20,data_tx,10,1000);
HAL_Delay(2);
HAL_I2C_Master_Receive(&hi2c3,20,data_rx,10,1000);
/* USER CODE END 2 */

2.3.1



Simple I2C communication

• Slave simple send and receive functions

• During this example the SLAVE must begin the code execution first to be 

prepared on MASTER Receive/Send requests

235

/* USER CODE BEGIN 2 */
status1=HAL_I2C_Slave_Receive(&hi2c3,data_rx,10,10000);
status2=HAL_I2C_Slave_Transmit(&hi2c3,data_rx,10,10000);
/* USER CODE END 2 */

2.3.1



2.3.2 I2C Interrupt lab 

06/12/2016STM32F42xx Technical Training              



Use I2C with interrupt

• Objective

• Learn how to setup I2C with interrupts in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Create simple loopback example with interrupts

• Goal

• Configure I2C in CubeMX and Generate Code

• Learn how to send and receive data over I2C with interrupts

• Verify the correct functionality

2372.3.2



Use I2C with interrupt

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX SPI selection

• Select I2C3 Periphery

• Select PA8, PC9 for I2C3 if weren't selected

2382.3.2



Use I2C with interrupt

• Hardware preparation

• Connect together PA8 and PC9 pins from both boards, and GND

2392.3.2

Hardware connection 

PA8 <-> PA8

PC9<->PC9



Use I2C with interrupt

• CubeMX I2C configuration

• Tab>Configuration>Connectivity>I2C3

• Check the settings

• Define Slave address

to 20

• Button OK

2402.3.2



Use I2C with interrupt

• CubeMX I2C configuration

• Tab>GPIO Settings

• Check Pull-UP

• Check GPIO speed

2412.3.2

Check if the Pull-UP resistor are 

necessary in case you are using 

external one

Check the GPIO speed

This two parameters can limit 

I2C maximum speed



Use I2C with interrupt

• CubeMX I2C configuration

• Tab>NVIC settings

• Enable interrupts

• Button OK

2422.3.2



Use I2C with interrupt

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

2432.3.2



Use I2C with interrupt

• Buffer definition

• Master simple send and receive functions with interrupts

• Master callbacks

244

/* USER CODE BEGIN PV */
/* Private variables 
uint8_t data_tx[10]={1,2,3,4,5,6,7,8,9,0};
uint8_t data_rx[10];
/* USER CODE END PV */

/* USER CODE BEGIN 2 */
HAL_I2C_Master_Transmit_IT(&hi2c3,20,data_tx,10);
HAL_Delay(2);
HAL_I2C_Master_Receive_IT(&hi2c3,20,data_rx,10);
/* USER CODE END 2 */

2.3.2

/* USER CODE BEGIN 4 */
void HAL_I2C_MasterTxCpltCallback(I2C_HandleTypeDef *hi2c){}
void HAL_I2C_MasterRxCpltCallback(I2C_HandleTypeDef *hi2c){}
/* USER CODE END 4 */



Use I2C with interrupt

• Slave receive

• Slave transmit in callback

245

/* USER CODE BEGIN 2 */
HAL_I2C_Slave_Receive_IT(&hi2c3,data_rx,10);
/* USER CODE END 2 */

2.3.2

/* USER CODE BEGIN 4 */
void HAL_I2C_SlaveTxCpltCallback(I2C_HandleTypeDef *hi2c){
}

void HAL_I2C_SlaveRxCpltCallback(I2C_HandleTypeDef *hi2c){
HAL_I2C_Slave_Transmit_IT(&hi2c3,data_rx,10);

}
/* USER CODE END 4 */



2.3.3 I2C DMA lab

06/12/2016STM32F42xx Technical Training              



Use I2C with DMA transfer

• Objective

• Learn how to setup UART with DMA in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Create simple loopback example with DMA 

• Goal

• Configure UART in CubeMX and Generate Code

• Learn how to send and receive data over UART with DMA

• Verify the correct functionality

2472.3.3



3.1.1 Use RTC Alarm lab
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Use RTC and Alarm with interrupt

• Objective

• Learn how to setup RTC with interrupt in CubeMX

• Create simple RTC project with periodic alarm interrupt

• Goal

• Use CubeMX and Generate Code with RTC

• Learn how to setup the RTC in HAL

• Verify the correct functionality by periodic RTC alarm interrupts

2493.1.1



Use RTC and Alarm with interrupt

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• Set Internal Alarm on Alarm A or Alarm B

• Set GPIO to toggle with LED as alarm indication

2503.1.1



Use RTC and Alarm with interrupt

• In order to run on maximum frequency, setup clock system

• Details in lab 0

2513.1.1



Use RTC and Alarm with interrupt

• RTC Configuration

• TAB>Configuration

• Control > RTC

• Set parameters which you want

252

1. TAB > Configuration

2. RTC

3. Check configuration

3.1.1



Use RTC and Alarm with interrupt

• RTC Configuration NVIC

• TAB>NVIC Setup

• Enable Alarm interrupt

• Button OK

253

1. TAB > NVIC

2. Enable RTC Alarm

3. Button OK

3.1.1



Use RTC and Alarm with interrupt

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

2543.1.1



Use RTC and Alarm with interrupt

• The RTC can be preserved during RESET(ok LP modes)

• CubeMX not enable the RTC by default

• We need to add HAL_PWR_EnableBkUpAccess() and __HAL_RCC_RTC_ENABLE() before 

we call MX_RTC_Init()

• Set the first alarm to 1s

• In MX_RTC_Init

• We create the RTC interrupt handler and we reconfigure the Alarm A time

• HAL_RTC_AlarmAEventCallback(RTC_HandleTypeDef *hrtc)

• HAL_RTC_GetAlarm(RTC_HandleTypeDef *hrtc, RTC_AlarmTypeDef *sAlarm, uint32_t Alarm, 

uint32_t Format)

• HAL_RTC_SetAlarm_IT(RTC_HandleTypeDef *hrtc, RTC_AlarmTypeDef *sAlarm, uint32_t 

Format)

• RTC alarm indication will be done by LED

• HAL_GPIO_TogglePin(GPIO_TypeDef* GPIOx, uint16_t GPIO_Pin)

2553.1.1



Use RTC and Alarm with interrupt

• RTC enable

• In MX_RTC_Init we set first Alarm to 1s

256

/* Initialize all configured peripherals */
HAL_PWR_EnableBkUpAccess();//enable PWR backup domain access (RTC,BKReg)
__HAL_RCC_RTC_ENABLE();//Enable RTC. not created by cube because the RTC can run.
MX_GPIO_Init();
MX_RTC_Init();

/**Enable the Alarm A 
*/

sAlarm.AlarmTime.Hours = 0;
sAlarm.AlarmTime.Minutes = 0;
sAlarm.AlarmTime.Seconds = 1;
sAlarm.AlarmTime.SubSeconds = 0;

3.1.1



Use RTC and Alarm with interrupt

• RTC enable

257

/* USER CODE BEGIN 4 */
void HAL_RTC_AlarmAEventCallback(RTC_HandleTypeDef *hrtc){

RTC_AlarmTypeDef sAlarm;
HAL_RTC_GetAlarm(hrtc,&sAlarm,RTC_ALARM_A,FORMAT_BIN);
if(sAlarm.AlarmTime.Seconds>58){

sAlarm.AlarmTime.Seconds=0;
}else{

sAlarm.AlarmTime.Seconds=sAlarm.AlarmTime.Seconds+1;
}
while(HAL_RTC_SetAlarm_IT(hrtc, &sAlarm, FORMAT_BIN)!=HAL_OK){}
HAL_GPIO_TogglePin(GPIOG,GPIO_PIN_14);

}
/* USER CODE END 4 */

3.1.1



Use RTC and Alarm with interrupt

• Advanced task

• The counting stops after 1minute

• Modify the project to create alarm every 1s for infinite time

• We only need to modify the Alarm mask to ignore Days, Hours and Minutes

258

/**Enable the Alarm A 
*/

sAlarm.AlarmTime.Hours = 0;
sAlarm.AlarmTime.Minutes = 0;
sAlarm.AlarmTime.Seconds = 1;
sAlarm.AlarmTime.SubSeconds = 0;
sAlarm.AlarmTime.TimeFormat = RTC_HOURFORMAT12_AM;
sAlarm.AlarmTime.DayLightSaving = RTC_DAYLIGHTSAVING_NONE;
sAlarm.AlarmTime.StoreOperation = RTC_STOREOPERATION_RESET;
sAlarm.AlarmMask = RTC_ALARMMASK_DATEWEEKDAY|RTC_ALARMMASK_HOURS|RTC_ALARMMASK_MINUTES;
sAlarm.AlarmSubSecondMask = RTC_ALARMSUBSECONDMASK_ALL;
sAlarm.AlarmDateWeekDaySel = RTC_ALARMDATEWEEKDAYSEL_DATE;
sAlarm.AlarmDateWeekDay = 1;
sAlarm.Alarm = RTC_ALARM_A;
HAL_RTC_SetAlarm_IT(&hrtc, &sAlarm, FORMAT_BCD);

3.1.1



3.2.1 TIM with interrupt lab

06/12/2016STM32F42xx Technical Training              



Use TIM with interrupt

• Objective

• Learn how to setup TIM with Interrupt in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Indicate TIM interrupt with LED toggle

• Goal

• Configure TIM in CubeMX and Generate Code

• Learn how start timer and handle interrupt

• Verify the correct functionality

2603.2.1



Use TIM with interrupt

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX TIM selection

• Select TIM clock source Internal clock

• Enable GPIO for LED PG14

2613.2.1



Use TIM with interrupt

• CubeMX TIM configuration

• Tab>Configuration>Control>TIM1

• Check the settings

2623.2.1



Use TIM with interrupt

• CubeMX TIM configuration

• Tab>Parameter Settings

• Prescaler to 18000

• Counter period to 10000

• Together with 180MHz TIMER1 

clock we get period 1Hz

2633.2.1



Use TIM with interrupt

• CubeMX TIM configuration

• Tab>NVIC Settings

• Enable TIM1 Update interrupt

• Button OK

2643.2.1



Use TIM with interrupt

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

2653.2.1



Use TIM with interrupt

HAL Library TIM with IT flow

266

Start process with interrupt generation at end 

of process

HAL_TIM_Base_Start_IT

TIM Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_TIM_IRQHandler

process callback

HAL_TIM_PeriodElapsedCallback

process Error callback

HAL_TIM_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY TIM1_UP_TIM10_IRQHandler

3.2.1



Use TIM with interrupt

• Open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 2 */ and /* USER CODE END 2 */ tags

• For TIM start use function

• HAL_TIM_Base_Start_IT(TIM_HandleTypeDef *htim)

• TIM callback 

• void TIM1_UP_TIM10_IRQHandler(void)

• GPIO LED toggle 

• HAL_GPIO_TogglePin(GPIO_TypeDef* GPIOx, uint16_t GPIO_Pin)

2673.2.1



Use TIM with interrupt

• Solution

• TIM start

• Callback handling

268

/* USER CODE BEGIN 2 */
HAL_TIM_Base_Start_IT(&htim1);
/* USER CODE END 2 */

/* USER CODE BEGIN 4 */
void HAL_TIM_PeriodElapsedCallback(TIM_HandleTypeDef *htim)
{
HAL_GPIO_TogglePin(GPIOG,GPIO_PIN_14);

}
/* USER CODE END 4 */

3.2.1



3.2.2 TIM with PWM output lab
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Use TIM with PWM output

• Objective

• Learn how to setup TIM with PWM out in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Indicate TIM PWM on LED

• Goal

• Configure TIM in CubeMX and Generate Code

• Learn how start timer and set PWM out

• Verify the correct functionality with LED

2703.2.2



Use TIM with PWM output

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX TIM selection

• Select TIM clock source - Internal clock

• Set Channel1 to PWM generation

2713.2.2



Use TIM with PWM output

• CubeMX TIM configuration

• TAB>Configuration

>Control>TIM1

• TAB>Parameter settings

• Prescaler to 18000

• Counter period to 10000

• Together with 180MHz TIMER1 

clock we get period 1Hz

• PWM pulse to 5000 this give

us 1Hz blinking frequency

2723.2.2



Use TIM with PWM output

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

2733.2.2



Use TIM with PWM output

• Start process TIM with PWM(same for DMA, ADC)

• Non blocking start process 

274

Peripheral 

Initializations

Start Process

HAL_TIM_PWM_Start

3.2.2



Use TIM with PWM output

• Open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 2 */ and /* USER CODE END 2 */ tags

• For TIM start use function

• HAL_TIM_PWM_Start(TIM_HandleTypeDef *htim, uint32_t Channel)

• GPIO LED toggle 

• We wire the Channel1 PE9 with LED PG14

2753.2.2



Use TIM with PWM output

• Solution

• TIM PWM start

• TIM1 Channel 1 and LED connection

276

/* USER CODE BEGIN 2 */
HAL_TIM_PWM_Start(&htim1,TIM_CHANNEL_1);
/* USER CODE END 2 */

3.2.2



3.2.3 TIM with DMA lab
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Use TIM with DMA transfer

• Objective

• Learn how to setup TIM with DMA in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Indicate TIM DMA transfer with LED toggle

• Goal

• Configure TIM in CubeMX and Generate Code

• Learn how start timer and setup DMA

• Verify the correct functionality with DMA transfer into GPIO register

2783.2.3



Use TIM with DMA transfer

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX TIM selection

• Select TIM clock source Internal clock

• Enable GPIO for LED PG14

2793.2.3



Use TIM with DMA transfer

• CubeMX TIM configuration

• Tab>Configuration>Control>TIM1

• Check the settings

2803.2.3



Use TIM with DMA transfer

• CubeMX TIM configuration

• Tab>Parameter Settings

• Prescaler to 18000

• Counter period to 10000

• Together with 180MHz TIMER1 

clock we get period 1Hz

2813.2.3



Use TIM with DMA transfer

• CubeMX TIM configuration

• TAB>DMA Settings

• Button ADD

• Select TIM1_UP DMA request

• Memory to peripheral direction

• Set Memory increment

• Circular mode

• Half word data width

• Button OK

2823.2.3



Use TIM with DMA transfer

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

2833.2.3



Use TIM with DMA transfer

HAL Library TIM with DMA flow

284

Start process with DMA 

HAL_DMA_Start

Peripheral Initializations 

including DMA stream initializations

HAL_OK HAL_ERROR HAL_ERROR

Start process with TIM

HAL_TIM_Base_Start

HAL_OK HAL_ERROR HAL_ERROR

3.2.3



Use TIM with DMA transfer

• Open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 2 */ and /* USER CODE END 2 */ tags

• For TIM start use function

• HAL_TIM_Base_Start_DMA(TIM_HandleTypeDef *htim, uint32_t *pData, uint16_t 

Length)

• TIM1 trigger DMA transfer

• __HAL_TIM_ENABLE_DMA

• DMA start function

• HAL_DMA_Start(DMA_HandleTypeDef *hdma, uint32_t SrcAddress, uint32_t 

DstAddress, uint32_t DataLength)

• GPIO LED register address

• (uint32_t)(&GPIOG->ODR)

2853.2.3



Use TIM with DMA transfer

• Variable data definition

• DMA and TIM start

286

/* USER CODE BEGIN 2 */
__HAL_TIM_ENABLE_DMA(&htim1, TIM_DMA_UPDATE);
HAL_DMA_Start(&hdma_tim1_up,(uint32_t)data,(uint32_t)&GPIOG->ODR,2);
HAL_TIM_Base_Start(&htim1);
/* USER CODE END 2 */

/* USER CODE BEGIN PV */
uint16_t data[]={GPIO_PIN_14,0x0000};
/* USER CODE END PV */

3.2.3



3.2.4 TIM as counter lab
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Use TIM as pulse counter

• Objective

• Learn how to setup TIM as counter in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Indicate TIM count 5 button press with LED toggle

• Goal

• Configure TIM as counter in CubeMX and Generate Code

• Learn how start timer and handle interrupt

• Verify the correct functionality with LED toggle after 5 button press

2883.2.4



Use TIM as pulse counter

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX TIM selection

• Select TIM clock source ETR2

• Enable GPIO for LED PG14

2893.2.4



Use TIM as pulse counter

• Hard ware setting

• Connect Button PA0 and ETR pin PE7 with wire together

2903.2.4



Use TIM as pulse counter

• CubeMX TIM configuration

• Tab>Configuration>Control>TIM1

• Check the settings

2913.2.4



Use TIM as pulse counter

• CubeMX TIM configuration

• Tab>Parameter Settings

• Counter set to 5, 5 button press

• Clock set the ETR pin filter and

edge reaction

2923.2.4



Use TIM as pulse counter

• CubeMX TIM configuration

• Tab>NVIC Settings

• Enable TIM1 Update interrupt

• Button OK

2933.2.4



Use TIM as pulse counter

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

2943.2.4



Use TIM as pulse counter

HAL Library TIM with IT flow

295

Start process with interrupt generation at end 

of process

HAL_TIM_Base_Start_IT

TIM Initializations 

including peripheral interrupt NVIC 

initializations 

HAL_TIM_IRQHandler

process callback

HAL_TIM_PeriodElapsedCallback

process Error callback

HAL_TIM_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY TIM1_UP_TIM10_IRQHandler

3.2.4



Use TIM as pulse counter

• Open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 2 */ and /* USER CODE END 2 */ tags

• For TIM start use function

• HAL_TIM_Base_Start_IT(TIM_HandleTypeDef *htim)

• TIM callback 

• void TIM1_UP_TIM10_IRQHandler(void)

• GPIO LED toggle 

• HAL_GPIO_TogglePin(GPIO_TypeDef* GPIOx, uint16_t GPIO_Pin)

2963.2.4



Use TIM as pulse counter

• Solution

• TIM start

• Callback handling

297

/* USER CODE BEGIN 2 */
HAL_TIM_Base_Start_IT(&htim1);
/* USER CODE END 2 */

/* USER CODE BEGIN 4 */
void HAL_TIM_PeriodElapsedCallback(TIM_HandleTypeDef *htim)
{
HAL_GPIO_TogglePin(GPIOG,GPIO_PIN_14);

}
/* USER CODE END 4 */

3.2.4



3.3.1 WWDG lab
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Use WWDG

• Objective

• Learn how to setup WWDG in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Create simple application to test WWDG

• Goal

• Configure WDGin in CubeMX and Generate Code

• Learn how to start WWDG

• WWDG indication via LED

2993.3.1



Use WWDG

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX WWDG selection

• Select WWDG

• Configure PG14 for LED indication

3003.3.1



Use WWDG

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX WWDG selection

• Select WWDG

• Configure PG14 for LED indication

3013.3.1



Use WWDG

• In order to run on maximum frequency, setup clock system

• Details in lab 0

3023.3.1



Use WWDG

• CubeMX ADC configuration

• TAB>Configuration>System>

>WWDG>Parameter Settings 

• Set prescaller to 8

• WWDG window to 80

• And free running counter to 127

• Button OK

3033.3.1



Use WWDG

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

3043.3.1



Use WWDG

• How calculate the window APB1freq=45MHz, prescaller 8

305

In our case 80

Fixed 63

We refresh the 

WWDG to 127
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3.3.1



Use WWDG

• Solution

• WWDG Start

• WWDG refresh

306

/* USER CODE BEGIN 2 */
HAL_WWDG_Start(&hwwdg);
/* USER CODE END 2 */

/* USER CODE BEGIN 3 */
/* Infinite loop */
while (1)
{
//30ms or 50ms is outside the WWDG window, 40ms fits inside the window
HAL_Delay(40);
HAL_GPIO_WritePin(GPIOG, GPIO_PIN_14, GPIO_PIN_SET);
HAL_WWDG_Refresh(&hwwdg, 127);

}
/* USER CODE END 3 */

3.3.1



3.3.2 IWDG lab
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Use IWDG

• Objective

• Learn how to setup IWDG in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Create simple application to test IWDG

• Goal

• Configure IWDG in CubeMX and Generate Code

• Learn how to start IWDG

• IWDG indication via LED

3083.3.2



Use IWDG

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX IWDG selection

• Select IWDG

• Configure PG14 for LED indication

3093.3.2



Use IWDG

• In order to run on maximum frequency, setup clock system

• Details in lab 0

3103.3.2



Use IWDG

• CubeMX ADC configuration

• TAB>Configuration>System>

>IWDG>Parameter Settings 

• Set prescaller to 4

• Max value to 50

• Button OK

3113.3.2



Use IWDG

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

3123.3.2



Use IWDG

• IWDG refresh interval

313
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Use IWDG

• Solution

• IWDG Start

• IWDG refresh

314

/* USER CODE BEGIN 2 */
HAL_IWDG_Start(&hiwdg);
/* USER CODE END 2 */

/* USER CODE BEGIN 3 */
/* Infinite loop */
while (1)
{
HAL_Delay(7);//try delay  6ms and 7ms
HAL_GPIO_WritePin(GPIOG,GPIO_PIN_14,GPIO_PIN_SET);
HAL_IWDG_Refresh(&hiwdg);

}
/* USER CODE END 3 */

3.3.2



Use IWDG

• Hardware IWDG

• Remove IWDG start from project

• Use ST-Link utility and enable IWDG Hardware start

315

/* USER CODE BEGIN 2 */
/* USER CODE END 2 */

3.3.2



Use IWDG

• Hardware IWDG

• Start ST-Link utility

• Menu>Target>Option bytes

or CTRL+B

• Uncheck the WDG_WS

• Button APPLY

• Now the IWDG is automatically started after reset

• !!! DO NOT FORGET disable 

IWDG automatic start after 

you end this example

3163.3.2



4.1.1 DAC wave generator lab

06/12/2016STM32F42xx Technical Training              



Use DAC as wave generator

• Objective

• Learn how to setup DAC as wave generator in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Goal

• Configure DAC as wave generator in CubeMX and Generate Code

• Learn how start it in project

3184.1.1



Use DAC as wave generator

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX DAC selection

• Select DAC OUT2

3194.1.1



Use DAC as wave generator

• CubeMX DAC configuration

• TAB>Configuration>Analog>DAC>Parametr Settings 

• Enable

Output buffer

• Button OK

3204.1.1



Use DAC as wave generator

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

3214.1.1



Use DAC as wave generator

• Start process DAC generation (same for DMA, ADC)

• Non blocking start process 

322

Peripheral 

Initializations

Start Process

HAL_DAC_Start

Set value

HAL_DAC_SetValue

4.1.1



Use DAC as wave generator

• Open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 2 */ and /* USER CODE END 2 */ tags

• and /* USER CODE BEGIN 3 */ and /* USER CODE END 3 */ tags

• For DAC start use function

• HAL_DAC_Start(DAC_HandleTypeDef* hdac, uint32_t Channel)

• DAC set DAC value

• HAL_DAC_SetValue(DAC_HandleTypeDef* hdac, uint32_t Channel, uint32_t Alignment, 

uint32_t Data)

3234.1.1



Use DAC as wave generator

• Solution

• DAC setup and start

• Create the wave

324

/* USER CODE BEGIN 2 */
HAL_DAC_Start(&hdac,DAC_CHANNEL_2);
/* USER CODE END 2 */

/* USER CODE BEGIN 3 */
/* Infinite loop */
while (1)
{
HAL_DAC_SetValue(&hdac, DAC_CHANNEL_2, DAC_ALIGN_12B_R, value_dac);
if(value_dac>4095)
{

value_dac=0;
}
HAL_Delay(1);

}
/* USER CODE END 3 */

4.1.1



4.2.1 ADC Poll lab
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Use ADC in polling mode

• Objective

• Use the DAC part from previous lab

• Learn how to setup ADC in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Goal

• Configure ADC in poll in CubeMX and Generate Code

• Learn how to start ADC and measure the DAC

• Verify the measured wave in STMStudio

(http://www.st.com/web/en/catalog/tools/PF251373 require JAVA)

3264.2.1

http://www.st.com/web/en/catalog/tools/PF251373


Use ADC in polling mode

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX DAC selection

• Select DAC OUT2

• Select ADC IN13

3274.2.1



Use ADC in polling mode

• Hardware connection

• Connect DAC out2 PA5 and ADC1 IN13 PC3 together 

3284.2.1



Use ADC in polling mode

• CubeMX ADC configuration

• TAB>Configuration>Analog>ADC1>Parametr Settings 

• Set ADC1

• Set sampling time 

for CH13

• Button OK

• DAC from previous

example

3294.2.1



Use ADC in polling mode

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

3304.2.1



Use ADC in polling mode

• Start process ADC(same for DMA, DAC, TIM)

• Non blocking start process 

331

Peripheral 

Initializations

Start Process

HAL_DAC_Start

Peripheral 

Initializations

Start Process

HAL_DAC_Start

4.2.1



Use ADC in polling mode

• Open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 2 */ and /* USER CODE END 2 */ tags

• and /* USER CODE BEGIN 3 */ and /* USER CODE END 3 */ tags

• For DAC start use function

• HAL_DAC_Start(DAC_HandleTypeDef* hdac, uint32_t Channel)

• HAL_ADC_PollForConversion(ADC_HandleTypeDef* hadc, uint32_t Timeout)

• HAL_ADC_GetValue(ADC_HandleTypeDef* hadc)

• DAC functions

• HAL_DAC_Start(DAC_HandleTypeDef* hdac, uint32_t Channel)

• HAL_DAC_SetValue(DAC_HandleTypeDef* hdac, uint32_t Channel, uint32_t Alignment, 

uint32_t Data)

3324.2.1



Use ADC in polling mode

• Solution

• Variables

• DAC setup and start

333

/* USER CODE BEGIN 2 */
HAL_DAC_Start(&hdac,DAC_CHANNEL_2);
HAL_DAC_SetValue(&hdac, DAC_CHANNEL_2, DAC_ALIGN_12B_R, value_dac);
/* USER CODE END 2 */

/* USER CODE BEGIN PV */
uint32_t value_adc;
uint32_t value_dac=0;
/* USER CODE END PV */

4.2.1



Use ADC in polling mode

• Solution

• Main loop with DAC set and ADC set

334

/* USER CODE BEGIN 3 */
/* Infinite loop */
while (1)
{

HAL_ADC_Start(&hadc1);
HAL_ADC_PollForConversion(&hadc1,10);
value_adc=HAL_ADC_GetValue(&hadc1);
HAL_DAC_SetValue(&hdac, DAC_CHANNEL_2, DAC_ALIGN_12B_R, value_dac);
value_dac++;
if(value_dac>4095){

value_dac=0;
}
HAL_Delay(1);

}
/* USER CODE END 3 */

4.2.1



Use ADC in polling mode

• Test the functionality

• We need the address of variable value_adc

• This can be found usually in debug mode in watch, my address is 

0x2000005C (depends on compilator and optimizations)

• Start the STMStudio

• Set the ST Link SWD

• Right click into 

Display variable 

settings

• Select NEW

3354.2.1



Use ADC in polling mode

• STM studio settings

• Set value_adc address

my 0x2000005C

• Set 16bit unsigned val

• Right click on this line

• Select Send To

VarViewer1

3364.2.1



Use ADC in polling mode

• STM studio settings

• Viewers settings is on bottom

• Set the correct upper value

to 4096(12bit)

3374.2.1



Use ADC in polling mode

• STM studio settings

• Now press 

green play button 

• And you will see 

content of 

value_adc

3384.2.1



4.2.2 ADC Interrupt lab

06/12/2016STM32F42xx Technical Training              



Use ADC with interrupt

• Objective

• Use the DAC part from previous lab

• Learn how to setup ADC with interrupt in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Goal

• Configure ADC in interrupt in CubeMX and Generate Code

• Learn how to start ADC and measure the DAC

• Verify the measured wave in STMStudio

(http://www.st.com/web/en/catalog/tools/PF251373 require JAVA)

3404.2.2

http://www.st.com/web/en/catalog/tools/PF251373


Use ADC with interrupt

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX DAC selection

• Select DAC OUT2

• Select ADC IN13

3414.2.2



Use ADC with interrupt

• CubeMX ADC configuration

• TAB>Configuration>Analog>ADC1>Parametr Settings 

• Set ADC1

• Set sampling time 

for CH13

• Button OK

• DAC from previous

example

3424.2.2



Use ADC with interrupt

• CubeMX ADC configuration

• TAB>NVIC settings

• Enable ADC1 interrupt

• Button OK

3434.2.2



Use ADC with interrupt

• CubeMX NVIC configuration

• Because we want use the 

Systick for delay in interrupt 

The ADC interrupt priority must

be changed

• TAB>Configuration>System>NVIC

• Change ADC1 

preemption priority 

to 1 

3444.2.2



Use ADC with interrupt

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

3454.2.2



Use ADC with interrupt

HAL Library ADC with IT flow

346

Start process with interrupt generation at end 

of process

HAL_ADC_Start_IT

ADCInitializations

including peripheral interrupt NVIC 

initializations 

HAL_ADC_IRQHandler

process callback

HAL_ADC_ConvCpltCallback

process Error callback

HAL_ADC_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY ADC_IRQHandler

4.2.2



Use ADC with interrupt

• Open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 2 */ and /* USER CODE END 2 */ tags

• and /* USER CODE BEGIN 4 */ and /* USER CODE END 4 */ tags

• For DAC start use function

• HAL_ADC_Start_IT(ADC_HandleTypeDef* hadc, uint32_t Channel)

• HAL_ADC_GetValue(ADC_HandleTypeDef* hadc)

• ADC complete callback function

• HAL_ADC_ConvCpltCallback(ADC_HandleTypeDef* hadc)

• DAC functions

• HAL_DAC_Start(DAC_HandleTypeDef* hdac, uint32_t Channel)

• HAL_DAC_SetValue(DAC_HandleTypeDef* hdac, uint32_t Channel, uint32_t Alignment, 

uint32_t Data)

3474.2.2



Use ADC with interrupt

• Solution

• Variables

• DAC setup and start ADC/DAC

348

/* USER CODE BEGIN 2 */
HAL_DAC_Start(&hdac,DAC_CHANNEL_2);
HAL_DAC_SetValue(&hdac, DAC_CHANNEL_2, DAC_ALIGN_12B_R, value_dac);
HAL_ADC_Start_IT(&hadc1);
/* USER CODE END 2 */

/* USER CODE BEGIN PV */
uint32_t value_adc;
uint32_t value_dac=0;
/* USER CODE END PV */

4.2.2



Use ADC with interrupt

• Solution

• ADC complete callback routine

349

/* USER CODE BEGIN 4 */
void HAL_ADC_ConvCpltCallback(ADC_HandleTypeDef* hadc)
{ 

value_adc=HAL_ADC_GetValue(&hadc1);
HAL_DAC_SetValue(&hdac, DAC_CHANNEL_2, DAC_ALIGN_12B_R, value_dac);
value_dac++;
if(value_dac>4095){

value_dac=0;
}
HAL_Delay(1);
HAL_ADC_Start_IT(&hadc1);

}
/* USER CODE END 4 */

4.2.2



Use ADC with interrupt

• STM studio settings

• Check functionality

again with 

STMstudio

3504.2.2



4.2.3 ADC with DMA lab
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Use ADC with DMA

• Objective

• Use the DAC part from previous lab

• Learn how to setup ADC with DMA in CubeMX

• How to Generate Code in CubeMX and use HAL functions

• Goal

• Configure ADC in DMA in CubeMX and Generate Code

• Learn how to start ADC and measure the DAC

• Verify the measured wave in STMStudio

(http://www.st.com/web/en/catalog/tools/PF251373 require JAVA)

3524.2.3

http://www.st.com/web/en/catalog/tools/PF251373


Use ADC with DMA

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• CubeMX DAC selection

• Select DAC OUT2

• Select ADC IN13

3534.2.3



Use ADC with DMA

• CubeMX ADC configuration

• TAB>Configuration>Analog>ADC1>Parameter Settings 

• Set ADC1

• Set sampling time 

for CH13

• DMA Continuous requests

• Button OK

• DAC from previous

example

3544.2.3



Use ADC with DMA

• CubeMX ADC configuration

• TAB>DMA Settings

• Button ADD

• DMA request ADC1

• Peripheral to memory direction

• Circular mode

• Memory increment

• Half word data width

• Button OK

3554.2.3



Use ADC with DMA

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

3564.2.3



Use ADC with DMA

HAL Library ADC with DMA flow

357

Start process with interrupt generation at end 

of process

HAL_ADC_Start_DMA

ADCInitializations

including peripheral interrupt NVIC 

initializations 

HAL_DMA_IRQHandler

process callback

HAL_ADC_ConvCpltCallback

process Error callback

HAL_ADC_ErrorCallback

HAL_ERRORHAL_OK HAL_BUSY DMA1_StreamX_IRQHandler

4.2.3



Use ADC with DMA

• Open the project in our IDE

• The functions we want to put into main.c

• Between /* USER CODE BEGIN 2 */ and /* USER CODE END 2 */ tags

• and /* USER CODE BEGIN 3 */ and /* USER CODE END 3 */ tags

• For DAC start use function

• HAL_ADC_Start_DMA(ADC_HandleTypeDef* hadc, uint32_t* pData, uint32_t Length)

• DAC functions

• HAL_DAC_Start(DAC_HandleTypeDef* hdac, uint32_t Channel)

• HAL_DAC_SetValue(DAC_HandleTypeDef* hdac, uint32_t Channel, uint32_t Alignment, 

uint32_t Data)

3584.2.3



Use ADC with DMA

• Solution

• Variables

• DAC setup and start ADC/DAC

359

/* USER CODE BEGIN 2 */
HAL_DAC_Start(&hdac,DAC_CHANNEL_2);
HAL_DAC_SetValue(&hdac, DAC_CHANNEL_2, DAC_ALIGN_12B_R, value_dac);
HAL_ADC_Start_DMA(&hadc1,(uint32_t*)&value_adc,1);
/* USER CODE END 2 */

/* USER CODE BEGIN PV */
uint32_t value_adc;
uint32_t value_dac=0;
/* USER CODE END PV */

4.2.3



Use ADC with DMA

• Solution

• ADC main routine

360

/* USER CODE BEGIN 3 */
/* Infinite loop */
while (1)
{

HAL_DAC_SetValue(&hdac, DAC_CHANNEL_2, DAC_ALIGN_12B_R, value_dac);
value_dac++;
if(value_dac>4095){

value_dac=0;
}
HAL_Delay(5);
HAL_ADC_Start(&hadc1);
HAL_Delay(5);

}
/* USER CODE END 3 */

4.2.3



Use ADC with DMA

• STM studio settings

• Check functionality

again with 

STMstudio

3614.2.3



5.1 BSP SDRAM lab
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Use BSP for SDRAM initialization

• Objective

• Learn how import BSP into project

• Which part need to by configured in GUI

• Try to write data into SDRAM and read it

• Goal

• Successfully import BSP into your project

• Learn which part you need to import

• How to setup the project

3635.1



Use BSP for SDRAM initialization

• Create project in CubeMX

• Menu > File > New Project

• Select STM32F4 > STM32F429/439 > LQFP144 > STM32F439ZITx

• We need only blank project with clock initialization
• We only set the RCC and configure the core to maximum speed

3645.1



Use BSP for SDRAM initialization

• Now we set the project details for generation

• Menu > Project > Project Settings

• Set the project name

• Project location

• Type of toolchain

• Now we can Generate Code

• Menu > Project > Generate Code

3655.1



Use BSP for SDRAM initialization

• Now we have bank project

• For SDRAM we need to include more parts

366

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c stm32f4xx_discovery_sdram.c stm32f4xx_discovery_io.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c stm32f4xx_hal_sdram.c

BSP package

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

5.1



Use BSP for SDRAM initialization

BSP SDRAM organization

367

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c stm32f4xx_discovery_sdram.c stm32f4xx_discovery_io.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c stm32f4xx_hal_sdram.c

BSP package

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

5.1



Use BSP for SDRAM initialization

BSP SDRAM organization

368

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c stm32f4xx_discovery_sdram.c stm32f4xx_discovery_io.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c stm32f4xx_hal_sdram.c

BSP package

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

2. include 

stm32f4xx_discovery.h 

1. include 

stm32f4xx_discovery_sdram.h 

5.1



Use BSP for SDRAM initialization

BSP SDRAM organization

369

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c stm32f4xx_discovery_sdram.c stm32f4xx_discovery_io.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c stm32f4xx_hal_sdram.c

BSP package

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c

3. include stm32f4xx_hal.h 

stm32f4xx_hal.c

4. stm32f4xx_hal.h include all 

peripherals which are used in 

stm32f4xx_discovery.c

5.1



Use BSP for SDRAM initialization

BSP SDRAM organization

370

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c stm32f4xx_discovery_sdram.c stm32f4xx_discovery_io.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c stm32f4xx_hal_sdram.c

BSP package

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

5. stm32f4xx_hal.h include all 

peripherals which are used in 

stm32f4xx_discovery_sdram.c

5.1



Use BSP for SDRAM initialization

BSP SDRAM organization

371

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c stm32f4xx_discovery_sdram.c stm32f4xx_discovery_io.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c stm32f4xx_hal_sdram.c

BSP package

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

6. HAL_SDRAM_Init

is function from 

stm32f4xx_discovery_sdram.c  7. HAL_SDRAM_Init

call functions from 

stm32f4xx_II_fmc.c  

8. stm32f4xx_II_fmc.c use 

functions from 

stm32f4xx_hal_sdram.c

5.1



Use BSP for SDRAM initialization 372

stm32f4xx_hal_ppp.h

stm32f4xx_hal_ppp_ex.h

stm32f4xx_hal.h

stm32f4xx_it.c

user_code.c

Source files Include files

stm32f4xx_hal_def.h

stm32f4xx_hal_conf.h

stm32f4xx_hal_ppp.c

stm32f4xx_hal_ppp_ex.c

stm32f4xx_hal.c

HAL Drivers

User Code

user_code.h

stm32f4xx_it.h

BSP Drivers Stm32f4xx_discovery.c

Stm32ffxx_discovery_sdram.c

Stm32f4xx_discovery.h

Stm32ffxx_discovery_sdram.h

5.1



Use BSP for SDRAM initialization

• The copy part

• In our project in Drivers folder create folder BSP

• Now go into CubeMX repository …\STM32Cube_FW_F4_V1.3.0\Drivers\BSP\

• And copy Components and STM32F429I-Discovery into BSP folder

373

Copy folders into BSP

5.1



Use BSP for SDRAM initialization

• Now we need to add this files also in project

• Create BSP folder in project

• Right click on project in Workplace>ADD>Group

• Name it BSP

• Now right click on BSP>ADD>Files

• From Drivers\BSP\STM32F429I-Discovery\

add stm32f429i_discovery.c

and stm32f429i_discovery_sdram.c

3745.1



Use BSP for SDRAM initialization

• The stm32f429i_discovery.c contains functions 

for all components on discovery kit 

(LCD, GYRO,…)

• Then we also need add into project HAL library

which handle their interface (I2C, SPI, … )

• Right click on STM32F4xx_HAL_Drive>ADD

from \Drivers\STM32F4xx_HAL_Driver\Src

• stm32f4xx_hal_i2c.c

• stm32f4xx_hal_spi.c

• stm32f4xx_hal_sdram.c

• stm32f4xx_II_fmc.c

3755.1



Use BSP for SDRAM initialization

• Now add the include paths for this new files

• Right click on project>Options>Category C/C++Compiler>Preprocesor

• Into Defined symbols add USE_STM32F429I_DISCO

• This allow use BSP functions

• Into additional includes add

$PROJ_DIR$\..\..\Drivers\BSP\STM32F429I-Discovery

• Button OK

• Button OK close project options

3765.1



Use BSP for SDRAM initialization

• Now last thing is allow to include 

new HAL files which we added

• Open stm32f4xx_hal_conf.h in ..\Inc\

• Uncomment files which we added

• HAL_SDRAM_MODULE_ENABLED

• HAL_I2C_MODULE_ENABLED

• HAL_SPI_MODULE_ENABLED

3775.1



Use BSP for SDRAM initialization

• Into main.c now we add include of stm32f429i_discovery_sdram.h

• Now we can use the SDRAM init functions from BSP

• Now you can try to write into SDRAM area

In stm32f429i_discovery_sdram.h you can find where is the SDRAM 

memory and how is their size

• SDRAM_DEVICE_ADDR ((uint32_t)0xD0000000)

• SDRAM_DEVICE_SIZE ((uint32_t)0x800000)  /* SDRAM device size in MBytes */

378

/* USER CODE BEGIN Includes */
#include "stm32f429i_discovery_sdram.h"
/* USER CODE END Includes */

/* USER CODE BEGIN 2 */
BSP_SDRAM_Init();
/* USER CODE END 2 */

5.1



Use BSP for SDRAM initialization

• SDRAM test

379

/* USER CODE BEGIN PV */
volatile uint32_t value;
/* USER CODE END PV */

/* USER CODE BEGIN 2 */
BSP_SDRAM_Init();
*((uint32_t*)SDRAM_DEVICE_ADDR)=0x12345678;
value=*((uint32_t*)SDRAM_DEVICE_ADDR);
/* USER CODE END 2 */

5.1



5.2 BSP LCD lab

06/12/2016STM32F42xx Technical Training              



Use BSP for LCD init and writing

• Objective

• Learn how import BSP LCD into project

• Because the LCD use the SDRAM we use project from lab 25

• Which part need to by configured in GUI

• Try to write text on LCD

• Goal

• Successfully import BSP LCD into your project

• Learn which part you need to import

• How to setup the project

3815.2



Use BSP for LCD init and writing

BSP LCD organization

382

BSP package

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c stm32f4xx_discovery_lcd.c stm32f4xx_discovery_sdram.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c
stm32f4xx_hal_ltdc.c

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

stm32f4xx_hal_sdram.c

Utilities

Fonts

5.2



Use BSP for LCD init and writing

BSP LCD organization

383

BSP package

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c stm32f4xx_discovery_lcd.c stm32f4xx_discovery_sdram.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c
stm32f4xx_hal_ltdc.c

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

1. include 

stm32f4xx_discovery_lcd.h 

stm32f4xx_hal_sdram.c

Utilities

Fonts

2. stm32f4xx_discovery_lcd.h

use the discovery BSP and 

SDRAM

5.2



Use BSP for LCD init and writing

BSP LCD organization

384

BSP package

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c stm32f4xx_discovery_lcd.c stm32f4xx_discovery_sdram.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c
stm32f4xx_hal_ltdc.c

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

3. stm32f4xx_discovery_lcd.h

use driver ili9341.c which is 

TFT LCD controller

stm32f4xx_hal_sdram.c

Utilities

Fonts

4. stm32f4xx_discovery_lcd.h

use LCTD controller from HAL

5.2



Use BSP for LCD init and writing

BSP LCD organization

385

BSP package

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c stm32f4xx_discovery_lcd.c stm32f4xx_discovery_sdram.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c
stm32f4xx_hal_ltdc.c

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

stm32f4xx_hal_sdram.c

Utilities

Fonts
2. stm32f4xx_discovery_lcd.h

use fonts from utility folder

5.2



Use BSP for LCD init and writing

• We use the project from BSP SDRAM

because the LCD also use the SDRAM

• We need copy the Fonts from Utilities 

folder in CubeMX repository

3865.2



Use BSP for LCD init and writing

• The copy part

• In our project in Drivers folder create folder Utilities

• Now go into CubeMX repository …\STM32Cube_FW_F4_V1.3.0\Utilities\

• And copy Fonts into Utilities folder

387

Copy folders into 

Utilities

5.2



Use BSP for LCD init and writing

• We add the driver for LCD from HAL

• Right click on STM32F4xx_HAL_Drive>ADD

from \Drivers\STM32F4xx_HAL_Driver\Src

• stm32f4xx_hal_ltdc.c

• Stm32f4xx_hal_dma2d.c

3885.2



Use BSP for LCD init and writing

• We add the driver for BSP LDC

• Right click on BSP>ADD from \Drivers\BSP\STM32F429I-Discovery\

• stm32f429i_discovery_lcd.c

• Right click on BSP>ADD from \Drivers\BSP\Components\ili9341\

• ili9341.c

3895.2



Use BSP for LCD init and writing

• Now last thing is allow to include 

new HAL files which we added

• Open stm32f4xx_hal_conf.h in ..\Inc\

• Uncomment files which we added

• HAL_DMA2D_MODULE_ENABLED 

• HAL_LTDC_MODULE_ENABLED

3905.2



Use BSP for LCD init and writing

• Into main.c now we modify include from 

stm32f429i_discovery_sdram.h to stm32f429i_discovery_lcd.h

• And remove the BSP_SDRAM_Init()

391

/* USER CODE BEGIN Includes */
#include "stm32f429i_discovery_lcd.h"
/* USER CODE END Includes */

/* USER CODE BEGIN 2 */
/* USER CODE END 2 */

5.2



Use BSP for LCD init and writing

• Simple LCD demonstration

392

/* USER CODE BEGIN 2 */
BSP_LCD_Init();//init LCD
//set the layer buffer address into SDRAM
BSP_LCD_LayerDefaultInit(1, SDRAM_DEVICE_ADDR);
BSP_LCD_SelectLayer(1);//select on which layer we write
BSP_LCD_DisplayOn();//turn on LCD
BSP_LCD_Clear(LCD_COLOR_BLUE);//clear the LCD on blue color
BSP_LCD_SetBackColor(LCD_COLOR_BLUE);//set text background color
BSP_LCD_SetTextColor(LCD_COLOR_WHITE);//set text color
//write text
BSP_LCD_DisplayStringAtLine(2,"Cube STM32");
BSP_LCD_DisplayStringAtLine(3,"BSP");
BSP_LCD_DisplayStringAtLine(4,"LCD DEMO");
/* USER CODE END 2 */

5.2



5.3 BSP EEPROM lab
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Use BSP to access EEPROM

• Objective

• Learn how import BSP EEPROM into project

• We use the project from lab 26

• Which part need to by configured in GUI

• Try to write text into EEPROM and read it

• Read text from EEPROM and display it on LCD

• Goal

• Successfully import BSP EEPROM drivers into your project

• Learn which part you need to import

• How to setup the project

3945.3



Use BSP to access EEPROM

BSP EEPROM organization

395

BSP package

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c

stm32f4xx_discovery_lcd.c

stm32f4xx_discovery_sdram.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c
stm32f4xx_hal_ltdc.c

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

stm32f4xx_hal_sdram.c

Utilities

Fonts

stm32f4xx_discovery_io.c stm32f4xx_discovery_eeprom.c

5.3



Use BSP to access EEPROM

BSP EEPROM organization

396

BSP package

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c

stm32f4xx_discovery_lcd.c

stm32f4xx_discovery_sdram.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c
stm32f4xx_hal_ltdc.c

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

stm32f4xx_hal_sdram.c

Utilities

Fonts

stm32f4xx_discovery_io.c stm32f4xx_discovery_eeprom.c

1. Use functions from 

stm32f4xx_discovery_eeprom.c

5.3



Use BSP to access EEPROM

BSP SDRAM organization

397

BSP package

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c

stm32f4xx_discovery_lcd.c

stm32f4xx_discovery_sdram.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c
stm32f4xx_hal_ltdc.c

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

stm32f4xx_hal_sdram.c

Utilities

Fonts

stm32f4xx_discovery_io.c stm32f4xx_discovery_eeprom.c

2. stm32f4xx_discovery_eeprom.c 

call functions from 

stm32f4xx_discovery_io.c

3. stm32f4xx_discovery_io.c call 

functions from 

stm32f4xx_discovery.c

pin init and write/read functions

5.3



Use BSP to access EEPROM

BSP EEPROM organization

398

BSP package

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c

stm32f4xx_discovery_lcd.c

stm32f4xx_discovery_sdram.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c
stm32f4xx_hal_ltdc.c

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

stm32f4xx_hal_sdram.c

Utilities

Fonts

stm32f4xx_discovery_io.c stm32f4xx_discovery_eeprom.c

4. stm32f4xx_discovery.c

Use stm32f4xx_hal_i2c to 

commutate with eeprom memory

5.3



Use BSP to access EEPROM

• We use the project from BSP LCD lab 26

because we want to display the memory

content on LCD

3995.3



Use BSP to access EEPROM

• We add the driver for BSP LDC

• Right click on BSP>ADD from \Drivers\BSP\STM32F429I-Discovery\

• stm32f429i_discovery_eeprom.c

• stm32f429i_discovery_io.c

4005.3



Use BSP to access EEPROM

• Add the define of EEPROM into project options

• Right click on project>Options>Category C/C++Compiler>Preprocesor

• Into Defined symbols add EE_M24LR64

• This allow use EEPROM functions

• Button OK close project options

4015.3



Use BSP to access EEPROM

• Use the ATM7-M24LR-A board with M24LR memory

and connect it into STM32F429i-Discovery kit

4025.3



Use BSP to access EEPROM

• Into main.c now modify include

• Define variables

403

/* USER CODE BEGIN Includes */
#include "stm32f429i_discovery_lcd.h"
#include "stm32f429i_discovery_io.h"
#include "stm32f429i_discovery_eeprom.h"
#include <string.h>
/* USER CODE END Includes */

/* USER CODE BEGIN PV */
uint8_t text_to_write[]="test text";//write to eeprom
uint8_t text_to_read[200];//read from eeprom
uint32_t address=0;//address in eeprom
uint16_t read_num=1;//number of bytes which we want to read from 
eeprom
/* USER CODE END PV */

5.3



Use BSP to access EEPROM

• Into stm32f4xx_hal_it.c add global variable for i2c handle

• and define handler functions for I2C DMA

404

/* USER CODE BEGIN 0 */
extern I2C_HandleTypeDef I2cHandle;
/* USER CODE END 0 */

/* USER CODE BEGIN 1 */
void DMA1_Stream4_IRQHandler()
{

HAL_DMA_IRQHandler(I2cHandle.hdmatx);
}

void DMA1_Stream2_IRQHandler()
{

HAL_DMA_IRQHandler(I2cHandle.hdmarx);
}
/* USER CODE END 1 */

5.3



Use BSP to access EEPROM

• Into main.c add

405

/* USER CODE BEGIN 2 */
/*LCD init*/
BSP_LCD_Init();
BSP_LCD_LayerDefaultInit(1, SDRAM_DEVICE_ADDR); 
BSP_LCD_SelectLayer(1);
BSP_LCD_DisplayOn();
BSP_LCD_Clear(LCD_COLOR_BLUE);
BSP_LCD_SetBackColor(LCD_COLOR_BLUE);
BSP_LCD_SetTextColor(LCD_COLOR_WHITE);

/*EEPROM init*/
BSP_EEPROM_Init();
/*Write text into EEPROM*/
BSP_EEPROM_WriteBuffer(text_to_write,0,(strlen(text_to_write)+1));
/*Read text from EEPROM*/
do{   
BSP_EEPROM_ReadBuffer((uint8_t*)&(text_to_read[address]),address,(uint16_t*)&read_num); 

}while(text_to_read[address++]!=0x0);
/*Display text*/
BSP_LCD_DisplayStringAtLine(2,text_to_read);
/* USER CODE END 2 */

5.3



5.4 BSP GYRO lab
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Use BSP to access GYROSCOPE

• Objective

• Learn how import BSP GYROSCOPE into project

• We use the project from lab 26

• Which part need to by configured in GUI

• Read data from GYROSCOPE and display it on LCD

• Goal

• Successfully import BSP GYROSCOPE drivers into your project

• Learn which part you need to import

• How to setup the project

4075.4



Use BSP to access GYROSCOPE

BSP GYRO organization

408

BSP package

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c

stm32f4xx_discovery_lcd.c

stm32f4xx_discovery_sdram.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c
stm32f4xx_hal_ltdc.c

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

stm32f4xx_hal_sdram.c

Utilities

Fonts

stm32f4xx_discovery_io.c stm32f4xx_discovery_gyroscope.c
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Use BSP to access GYROSCOPE

BSP GYRO organization

409

BSP package

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c

stm32f4xx_discovery_lcd.c

stm32f4xx_discovery_sdram.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c
stm32f4xx_hal_ltdc.c

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

stm32f4xx_hal_sdram.c

Utilities

Fonts

stm32f4xx_discovery_io.c stm32f4xx_discovery_gyroscope.c

1. Use functions from 

stm32f4xx_discovery_eeprom.c

5.4



Use BSP to access GYROSCOPE

BSP GYRO organization

410

BSP package

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c

stm32f4xx_discovery_lcd.c

stm32f4xx_discovery_sdram.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c
stm32f4xx_hal_ltdc.c

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

stm32f4xx_hal_sdram.c

Utilities

Fonts

stm32f4xx_discovery_io.c stm32f4xx_discovery_gyroscope.c

2. stm32f4xx_discovery_gyroscope.c 

call functions from 

stm32f4xx_discovery_io.c

3. stm32f4xx_discovery_io.c call 

functions from 

stm32f4xx_discovery.c

pin init and read functions

5.4



Use BSP to access GYROSCOPE

BSP GYRO organization

411

BSP package

Our project

Discovery drivers

HAL API

Components

stm32f4xx_discovery.c

stm32f4xx_discovery_lcd.c

stm32f4xx_discovery_sdram.c

ili9341.c lis3dsh.c stmpe811.c

stm32f4xx_II_fmc.c
stm32f4xx_hal_ltdc.c

stm32f4xx_hal_spi.c

stm32f4xx_hal_i2c.c
stm32f4xx_hal.c

stm32f4xx_hal_sdram.c

Utilities

Fonts

stm32f4xx_discovery_io.c stm32f4xx_discovery_gyroscope.c

4. stm32f4xx_discovery.c

Use stm32f4xx_hal_spi to 

commutate with gyroscope

5.4



Use BSP to access GYROSCOPE

• We use the project from BSP LCD lab 26

because we want to display gyro values

on LCD

4125.4



Use BSP to access GYROSCOPE

• We add the driver for BSP LDC

• Right click on BSP>ADD from \Drivers\BSP\STM32F429I-Discovery\

• stm32f429i_discovery_gyroscope.c

• stm32f429i_discovery_io.c

• Right click on BSP>ADD from \Drivers\BSP\Components\

• l3gd20.c

4135.4



Use BSP to access GYROSCOPE

• Into main.c now modify include

• Define variables

414

/* USER CODE BEGIN Includes */
#include "stm32f429i_discovery_lcd.h"
#include "stm32f429i_discovery_gyroscope.h"
#include "stm32f429i_discovery_io.h"
#include <stdio.h>
/* USER CODE END Includes */

/* USER CODE BEGIN PV */
float valxyz[3];//gyroscope values
uint8_t buffer[200];//text buffer
/* USER CODE END PV */

5.4



Use BSP to access GYROSCOPE

• Into main.c add

415

/* USER CODE BEGIN 2 */
/*LCD init*/
BSP_LCD_Init();
BSP_LCD_LayerDefaultInit(1, SDRAM_DEVICE_ADDR); 
BSP_LCD_SelectLayer(1);
BSP_LCD_DisplayOn();
BSP_LCD_Clear(LCD_COLOR_BLUE);
BSP_LCD_SetBackColor(LCD_COLOR_BLUE);
BSP_LCD_SetTextColor(LCD_COLOR_WHITE);
/*Gyroscope init*/
BSP_GYRO_Init();
/* USER CODE END 2 */

5.4



Use BSP to access GYROSCOPE

• Into main.c add

416

/* USER CODE BEGIN 3 */
/* Infinite loop */
while (1)
{
/*Get Gyrospope value*/
BSP_GYRO_GetXYZ(valxyz);
/*Display X*/
sprintf(buffer,"x:%f",valxyz[0]);
BSP_LCD_DisplayStringAtLine(2,buffer);
/*Display Y*/
sprintf(buffer,"y:%f",valxyz[1]);
BSP_LCD_DisplayStringAtLine(3,buffer);
/*Display Z*/
sprintf(buffer,"z:%f",valxyz[2]);
BSP_LCD_DisplayStringAtLine(4,buffer);
/*Delay*/
HAL_Delay(1000);

}
/* USER CODE END 3 */

5.4



Appendix A CubeMX install
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CubeMX install

• CubeMX tool

• http://www.st.com/web/catalog/tools/FM147/CL1794/SC961/SS1533/PF259242?s_searchtype=

partnumber

• The CubeMX tool need the java

• Please check if you have actual java on your pc, for sure 32bit and 64bit version

• Optionally you can download the Cube packages for STM32 device if you 

don’t want to download them throe CubeMX

• STM32CubeL0

• STM32CubeL1

• STM32CubeF0

• STM32CubeF2

• STM32CubeF3

• STM32CubeF4

418A

http://www.st.com/web/catalog/tools/FM147/CL1794/SC961/SS1533/PF259242?s_searchtype=partnumber
http://www.st.com/web/en/catalog/tools/PF260508
http://www.st.com/web/en/catalog/tools/PF260821
http://www.st.com/web/en/catalog/tools/PF260612
http://www.st.com/web/en/catalog/tools/PF260266
http://www.st.com/web/en/catalog/tools/PF260613
http://www.st.com/web/en/catalog/tools/PF259243


CubeMX install

• Install the CubeMX

• After installation run CubeMX

• In case you download the package from web we need to find the place where 

they need to be stored

• MENU>Help>Updater Settings…

• You will see where is the repository folder

• Default is C:/User/Acc_name/STM32Cube/Repository/

• You need to download STM32 packages into this folder

• Or CubeMX automatically download them into this folder

419A



CubeMX install

• The comparison of the CubeMX repository settings and structure in this folder

• In case you want to download this files

automatically use in CubeMX

• MENU>Help>Install New Libraries

• Select libraries which you want

• Force download with button Install Now

420A



CubeMX install

• For the code generation the CubeMX use the package from the Repository 

folder

• The CubeMX can generate the code for some GUI

• Keil

• IAR

• Atollic

• For the debugging is necessity to have the ST-Link drivers

• STSW-LINK003 driver for Win XP/Vista/7

• STSW-LINK006 driver for Win 8

• For driver installation you will need the Admin rights on your PC

421A

http://www.st.com/web/en/catalog/tools/PF258167
http://www.st.com/web/en/catalog/tools/PF259459


Appendix B Documents
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CubeMX documentation

• CubeMX user manual UM1718

• http://www.st.com/st-web-

ui/static/active/en/resource/technical/document/user_manual/DM00104712.pdf

• CubeMX release note RN0094

• http://www.st.com/st-web-

ui/static/active/en/resource/technical/document/user_manual/DM00104712.pdf

• CubeMX technical note TN0072

• http://www.st.com/st-web-

ui/static/active/en/resource/technical/document/technical_note/CD00214439.pdf

423B

http://www.st.com/st-web-ui/static/active/en/resource/technical/document/user_manual/DM00104712.pdf
http://www.st.com/st-web-ui/static/active/en/resource/technical/document/user_manual/DM00104712.pdf
http://www.st.com/st-web-ui/static/active/en/resource/technical/document/technical_note/CD00214439.pdf


STM32F4 documentation

• STM32F429ZI web page

• http://www.st.com/web/en/catalog/mmc/FM141/SC1169/SS1577/LN1806/PF255419#

• STM32F429 Datasheet

• http://www.st.com/st-web-ui/static/active/en/resource/technical/document/datasheet/DM00071990.pdf

• STM32F429 Reference Manual

• http://www.st.com/st-web-

ui/static/active/en/resource/technical/document/reference_manual/DM00031020.pdf

• STM32F429 Programming manual

• http://www.st.com/st-web-

ui/static/active/en/resource/technical/document/programming_manual/DM00046982.pdf
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http://www.st.com/web/en/catalog/mmc/FM141/SC1169/SS1577/LN1806/PF255419
http://www.st.com/st-web-ui/static/active/en/resource/technical/document/datasheet/DM00071990.pdf
http://www.st.com/st-web-ui/static/active/en/resource/technical/document/reference_manual/DM00031020.pdf
http://www.st.com/st-web-ui/static/active/en/resource/technical/document/programming_manual/DM00046982.pdf


STM32F429i-Discovery

documentation
• STM32F429i-Discovery page

• http://www.st.com/web/en/catalog/tools/FM116/SC959/SS1532/LN1848/PF259090?s_searchtyp

e=keyword

• STM32F429i-Discovery user manual with discovery schematics

• http://www.st.com/st-web-

ui/static/active/en/resource/technical/document/user_manual/DM00093903.pdf
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http://www.st.com/web/en/catalog/tools/FM116/SC959/SS1532/LN1848/PF259090?s_searchtype=keyword
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