AnsweredAssumed Answered

STM32Cube LwIP demos not working

Question asked by rob.sofiane on May 28, 2015
Hello,
I'm trying to run the TCP echo client demo that comes with the STM32Cube_FW_F4_V1.5.0  using the STM3204G-EVAL and i can't get any packet from the board.
I'm using echotool as the doc (UM1713) suggest and open the tcp port 7 but there is no response when i press the key button. My PC has a static ip address(192.168.0.11) and the board address is 192.168.0.10.
On my board JP5 is set to 1-2 and JP6 set to 2-3. I connected a straight cable from the board to my router and the green light turned on. ( i did also try the crossover cable and got the same result)
I have tried to ping the device with LW_ICMP defined to 1 and LWIP_ARP to 1, but still no response.
I had the debug enable and here are the output:
When I ping the device:

etharp_arp_input: incoming ARP request                          
etharp_arp_input: replying to ARP request for our IP address               
ethernet_input: dest:ff:ff:ff:ff:ff:ff, src:d8:50:e6:04:c9:59, type:806 
etharp_update_arp_entry: 192.168.0.11 - d8:50:e6:04:c9:59                
etharp_find_entry: found matching entry 0                          
etharp_update_arp_entry: updating stable entry 0


seems like he received the request but my PC keeps saying Destination Host Unreachable when pinging, I find it strange that he doesnt got to the icmp_input function. (the ICMP debug is enable)


When I press the Key button:
tcp_enqueue_flags: queueing 11633:11634 (0x2) 
tcp_output_segment: 11633:11633                         
ip_output_if: st0                                         
IP header:                                                    
+-------------------------------+                    
| 4 | 5 |  0x00 |        44                                        | (v, hl, tos, len)    
+-------------------------------+             
|       14      |000|       0                      |                          | (id, flags, offset)
+-------------------------------+                         
|  255  |    6  |    0x3a58                     |                | (ttl, proto, chksum)   
+-------------------------------+                        
|  192  |  168  |    0  |   10                   |               | (src)                  
+-------------------------------+                    
|  192  |  168  |    0  |   11                   |               | (dest)                
+-------------------------------+

netif->output()etharp_send_ip: sending packet 20000264
tcp_output: nothing to send (00000000)            
tcp_output: nothing to send (00000000)


I do Have WireShark and I see no packets from the STM32 board.

I have also tried other STM32Cube_FW_F4_V1.5.0 demos and none of them are working.There must be something that is done wrong with my settings. I'm new to LwIP, Any help will be very appreciated.

regards,

Outcomes