AnsweredAssumed Answered

STM8l-discovery and Cosmic problem.

Question asked by knyrek.waldemar on Sep 6, 2016
Latest reply on Oct 7, 2017 by memet tri cahyono
Hello, everyone!
I have a problem with my eval board. I carried out all step as said user manual:
1) download a STVD and STVP form :
http://www.st.com/content/st_com/en/products/development-tools/software-development-tools/stm8-software-development-tools/stm8-programmers/stvd-stm8.html
2) download Cosmic tools for the STM8 family from:
http://www.cosmic-software.com/download.php#stm8
3) download standard pheripheral Library form st site.
4) Create a workspace  as shown in this video:
https://www.youtube.com/watch?v=SlwlFo_xAe0
Now when i tried to build empty main.c everything is ok. When I tried to use some function from SPL, there's an linker error:

Running Linker
clnk -l"C:\Program Files (x86)\COSMIC\CXSTM8_EVAL\Lib"  -o Debug\template.sm8 -l"..\..\..\..\..\..\program files (x86)\cosmic\cxstm8_eval\lib" -mDebug\template.map Debug\template.lkf
#error clnk Debug\template.lkf:1 symbol _GPIO_Init not defined (Debug\main.o )
 The command: "clnk -l"C:\Program Files (x86)\COSMIC\CXSTM8_EVAL\Lib"  -o Debug\template.sm8 -l"..\..\..\..\..\..\program files (x86)\cosmic\cxstm8_eval\lib" -mDebug\template.map Debug\template.lkf " has failed, the returned value is: 1
exit code=1.

when the code look's:

#include "stm8l15x.h"

void main(void)
{
    //GPIO_DeInit(GPIOE);
     GPIO_Init(GPIOA, GPIO_Pin_7, GPIO_Mode_Out_PP_Low_Fast);
    while (1);
    {
        
    }
    
}

I know that is problem with configuration of   environment, but I can't find any sloution to solve that problem. Can anybody help me?
P.S Sorry for my English, I'm begginer.



Outcomes