AnsweredAssumed Answered

COSMIC LICENSE error

Question asked by paul.jagadish on Jun 13, 2015
Latest reply on Jun 13, 2015 by paul.jagadish
I have got cosmic license file and copied it to "license" sub-directory of the compiler.
But while compling getting error as

 FlexLM System clock has been set back.

I contacted to cosmic they replied as


This message means that either you have changed the clock/date system on your PC or you may have some files that have a date after the current system date. The Flexnet system is very sensitive.
 
What you could do is to remove or change the date of that file(s), or remove the COSMIC_LICENSE_FILE registry key and re-run the compiler.

As the software is free, there is no direct support. Support is done via the discussion forum on https://my.st.com/public/STe2ecommunities/mcu/default.aspx</span></a></p> </span>I removed the COSMIC_LICENSE_FILE registry key and re-run the compiler but same error.

Waiting for help.

regards
jags

Outcomes