AnsweredAssumed Answered

Debug Dwarf errors, cannot debug using STVD

Question asked by mottes.rick.001 on Mar 2, 2015
Hello,
My problem is using the STVD debugger.  The development platform is win7 64.  The tools are STVD 4.3.6, Raisonance Ride7 7.50.14.0185, RKit-STM8 2.54.14.0283.  The debugger starts normally, no errors, it appears to be ready, then I set a breakpoint in the source code, and get the following error message, 

Die: DW_TAG_padding(abbrev=0, offset=0) 
has children:FALSE
Error: Dwarf Error: Cannot find type of die

I have another development system, it is working properly, it is win8.1, the tools are STVD 4.3.2, Raisonance Ride7 7.42.12.0305, Rkit-STM8 2.48.12.0338. If I build the same project on the win8 platform and copy the .elf file to the win7 platform the debugger works properly and no longer gives me the above error.

A binary file comparison of the two .elf files shows that the two are not the same.
Also, the .aof files on the two platforms are different sizes (the working one is 30k smaller (1038k vs 1074k).
I've run ST Toolset.msi - no change.
I've removed all development tools, manually cleaned the registry, reinstalled, and still get the same error.

I need the debugger to work, any help would be appreciated,
Thanks,
Rick

Outcomes