AnsweredAssumed Answered

my STVD cant show RAM use

Question asked by yu.jeff.001 on Dec 12, 2014
Latest reply on Dec 12, 2014 by luca
HI everyone, i am new to STVD and stm8, cosmic C
i follow the thread of this
https://my.st.com/public/STe2ecommunities/mcu/Lists/stm81/Flat.aspx?RootFolder=/public/STe2ecommunities/mcu/Lists/stm81/Output%20Size%20in%20IDE%20%28ROM%20%20RAM%20Usage%29&FolderCTID=0x01200200770978C69A1141439FE559EB459D7580001E3853D9DB932A46A3FE4CD15CAB46FB&currentviews=2189

and it outcomes :

---------- DEBUG\TEST_ALL.MAP
start 00008080 end 0000808c length    12 segment .const
start 000080cf end 00009b16 length  6727 segment .text
start 00004000 end 00004000 length     0 segment .eeprom
start 00000000 end 0000003b length    59 segment .bsct, initialized
start 00008094 end 000080cf length    59 segment .bsct, from
start 0000003b end 0000004d length    18 segment .ubsct
start 0000004d end 0000004d length     0 segment .bit
start 0000004d end 0000004d length     0 segment .share
start 00000100 end 00000100 length     0 segment .data
start 00000100 end 00000100 length     0 segment .bss
start 00000000 end 0000064b length  1611 segment .info.
start 00000000 end 0000a1cc length 41420 segment .debug
start 00008000 end 00008080 length   128 segment .const
start 0000808c end 00008094 length     8 segment .init

from the above do it mean 6727 , 6.7K byte flash?
And for the data, it show 0 ?

And i encounter that once i add more variable, the program run strangely without warning me the excess of RAM use ?

Thanks for help , thanks

Outcomes