AnsweredAssumed Answered

The Firmware Package (STM32cube FW_f4 V1.4.0) required by the Project is no longer managed by STM32Cube

Question asked by Barta.Hank on Mar 20, 2015
Latest reply on Mar 23, 2015 by Barta.Hank
This is the message that STM32CubeMX presented to me on startup this morning. It is STM32CubeMX v4.6.0 and I believe it recently upgraded me to library version 1.4.0. I checked the web page and it looks like v1.4.0 is the most recent (http://www.st.com/web/en/catalog/tools/PF259243) The 'about' page shows "STMCube V1.0" which seems not right. The New Libraries Manager dialog shows both 1.3.0 and 1.4.0 STM32CubeF4 releases installed. The updater shows nothing new available.

I'm confused by this message so I hit cancel and moved on. It left me in with STM32CubeMX open but no project loaded. (I launched it by double clicking my project .ioc file.)

My question, I suppose is "What gives?"

Outcomes