AnsweredAssumed Answered

Swim - Chip does not answer

Question asked by Joble on Sep 6, 2012
Latest reply on Nov 16, 2015 by herrmann.justin
Hi,

I am debugging software for an STM8S105x6, using the programmer from the STM8S-Discovery board and STVD software.

All went fine, until suddenly an error popped up while entering debug mode: '** Connection error (usb://usb): swim error [30006]: comm init error: chip does not answer'. Also STVP cannot connect to the MCU.

I've tried to other boards (that have worked before). I've directly soldered the SWIM wires to the board. Without any result.

When i changed the programmer a first time, the problem remained. But with a third programmer, the problem was solved.

But after a while the problem came back.

This programmer still seems to be ok, because i can program the MCU on the demoboard itself.

I have no clue what can be the problem.

Some more info about the board:

 * GND, reset and dataline for SWIM are connected. VCC is not connected
 * The reset pin has a 10nF cap to gnd and 10K to the VCC (i have tried to remove both)
 * VCC = 5V1

Anyone an idea what is wrong???

Regards,
Johan






Outcomes