AnsweredAssumed Answered

ST-Link v2 Upgrade Error

Question asked by Toni Nikola on Jun 10, 2018
Latest reply on Jun 16, 2018 by José Eduardo Nascimento dos Santos

Hi, 

I'we got a ST-Link v2 USB dongle.

 

The firmware on it is:  V2.J17.S4

Trying to upgrade the firmware to the latest V2.J30.S7

 

I'm using the software provided by ST:

  • ST-LinkUpgrade_007(both win subfolder and java)
  • STM32 ST-LinkUtility
  • STM32CubeProgrammer

 

All of the above software gave me the same error when trying to upgrade to latest version: "Upgrade Error, Please try again."

 

I am using Win 10, 64bit, ST-link Driver(009). The device is visible in the Device Manager.

(I also tried the exact same thing on Win 8, 64bit)

 

I would like to understand the problem, but the error didn't drop a code to look for, and the official documentation didn't mention it either. 

 

Any suggestions?

 

Regards, 

Toni.

 

EDIT

I can eliminate OS related problem as i tried on 3 different machines. Looks like its a hardware issue, so I am closing this thread. 

Outcomes