AnsweredAssumed Answered

STM32F4DISCOVERY : Cannot connect to the MCU device

Question asked by ronan22 on Apr 16, 2012
Latest reply on Apr 25, 2012 by ronan22
Hello,
I just bought an STM32F4 discovery board. I installed the USB drivers (ST-LINK/V2 USB driver for Windows 7, Vista and XP) and the STM32 ST-LINK utility programmer.  As a first step I would like to connect the ST-Link v2 to the device and then load an example binary file.

The programmer do not reconize the device. When trying to connect, the green/red led is blinking, and them goes to green. But the programmer give me the following message:
"

21:57:55 : Connected via SWD.

21:57:55 : Cannot connect to the MCU device!
"
I tried to do a firmware update. When the board has just been connected i'm able to see the firmware version, it is up to date (i'm also able to update it). But if i try to connect the device, then after firmware update is not possible any more until rebooting the board.

I think i have à driver problem. I tried everything i found on the web (like removing daemon tool) and also tried to instal the drivers on an other computer. I do not manage to connect to the device !!!

Can someone may confirm that i can use the"STM32 ST-LINK utility programmer" by itself as a very first step (to check connectivity)?
Does someone know what may I do to connect this device?

I use windows 7, on a core i3 (64bits) based computer.

Regards,
Ronan

Outcomes