AnsweredAssumed Answered

lwIP + STM32CubeMX

Question asked by Mujtaba Hossaini on May 25, 2018
Latest reply on May 27, 2018 by Mujtaba Hossaini

Dear friends,

 

I am trying to config lwIP Netconn APIs to connect my board to the TCP/IP network using STM32F107RCt6 MCU and a DP83848CVV PHY.  The only options that I change in configuration tab in CubeMX is to disable the DHCP server and enter the static IP address and I add another freeRTOS thread with default stack size of 128 words. I used the tcp echo server example provided by ST and copied the code to the new thread I created and I am sure my code is fine and works well and when I download the code, the board even doesn't answer to the ICMP ping request!

 

 

I also tried to config the STM32F746 Discovery board but I get the same result and the board didn't answer to the ping request so I'm pretty sure there is something missing in my lwIP configuration in CubeMX.

 

I already run TCP echo server using STM32F107RCt6 with lwIP native raw apis version 1.3.1  and SPL libraries but I want to migrate to CubeMX and HAL libraries and new versions of lwIP and freeRTOS.

 

I would be very thankful if someone could help me in configurations. I am using the latest version of CubeMX and Keil IDE and lwIP version 2.0.0.

Outcomes