AnsweredAssumed Answered

FOC 4.0 and STM32F4xx

Question asked by jassmann.marco on Sep 18, 2014
Latest reply on Sep 22, 2014 by Gigi
Hi,

few days ago I downloaded the file "STM32_FOC_SDK_4.0.0_Web_140625.exe" from your homepage and wanted to try out the motion control on my custom board equiped with an STM32F407ZG device (either as single drive or dual drive).

The driving IC is a Trinamic IC TMC603.
Unfortunately I'm not able to test the TMC603, because the FOC 4.0 won't really work.
I generated the dedicated header-files with the WorkBench and needed to adopt some pin settings (I use ADC3 instead of ADC1&2). After that I compiled everything without an error or warning (using Keil MDK-ARM).
I did this with the provided example for MDK-ARM, but after MCboot() it seems that the microcontoller reset's itself everytime.
The structures you need to provide the MCboot()-function are set with address 0x0 by firmware itself. If I force to run the application with internal RC-oscillator 16 MHz (instead of external 8 MHz) the address of this structures is somewhere around 0x200000xx in debugging mode over STLink (of course, the firmware won't work then because of the wrong timing settings).

After this, I tried a completely new project and did it according the User Guide (Chapter 10.3) for STM32F4xx-devices.
There are two libraries mentioned, which are precompiled but the MCApplication.a or .lib is not there.
Even this library is not there, the MDK-ARM compiles (but now with warnings and few easy catched errors), but still not working. In the desciption I guess, some to-be-included files are missing, aren't they?

I also tried to compile this library, but it seems I miss some "confidential files" as mentioned in the user manual. Is it possible to get this "confidential files" by subsrcibe a NDA ? So I would do that.

Can you help me , please ?

Outcomes