AnsweredAssumed Answered

SigFox stack for B-l072Z-LRWAN1

Question asked by Anton Anton on May 8, 2018

Hi, 

 

I have some trouble getting the sigfox stack up and running on B-l072Z-LRWAN1 kit together with SDR Dongle from Sigfox, what i have done so far is:

 

1. Executed SignatureGenerator.bin on my device and retrieved the signature

2. Requested the PAC/ID from Murata and got the sigfox_data.h back

3. Replaced the sigfox_data.h with new data from Murata

4. Modified the sigfox stack to operate with public CMAC `SGFX_CMAC_set_key_type( CMAC_KEY_PUBLIC );`

5. Connected the dongle directly to LRWAN1 via SMA-SMA with attenuator

6. In Snek software configured the device ID and Radio configuration to match the LRWAN1 default config (RC1)

7. Tried to disable/enable authentications but no messages are coming in.

 

The console output is as follows:

 

wakeup OK
devId=009_____
devPac=1______________C
senddata....F8 00 00 00 00 00 00 done
senddata....EF 00 00 00 00 00 00 done
senddata....F1 00 00 00 00 00 00 done
senddata....EF 00 00 00 00 00 00 done
senddata....EF 00 00 00 00 00 00 done
senddata....ED 00 00 00 00 00 00 done
senddata....EF 00 00 00 00 00 00 done
senddata....ED 00 00 00 00 00 00 done
senddata....ED 00 00 00 00 00 00 done
senddata....EF 00 00 00 00 00 00 done
senddata....ED 00 00 00 00 00 00 done
senddata....EF 00 00 00 00 00 00 done
senddata....EF 00 00 00 00 00 00 done
senddata....F1 00 00 00 00 00 00 done

 

The blue led lits up when transmission is ongoing (LD3) while green led (LD2) blinks 6 time during that same time. Does anyone know if there are any other setting which are required to be set in order to get the messages being transmitted?

Outcomes