AnsweredAssumed Answered

6LoWPAN tutorial, GW not starting

Question asked by Mathias Thorell on Apr 26, 2018

Hi !
I have tried to follow the steps listed in  Tutorial: 6LoWPAN, Step-by-Step Guide to Creating a Network and Sending Data to the Internet.

I got the same hardware mentioned there and I have managed to verify that I got the correct FW in my X-Nucleo IDW01M1; v160129. Finally, I have also moved the 0 ohm R4 -> R34.
However, I cannot get step 2 "Craete the Gateway" to work.
I have mounted the hardware and loaded the software and when I connect to it from my PC (using Putty) I see it hanging on

 

/********************************************************
* *
* FP-NET-6LPWIFI1 Function Pack v2.1.1 *
* X-NUCLEO-IDW01M1 Wi-Fi Configuration. *
* WiFi Bridge Application *
* *
*******************************************************/
(HAL 1.7.1_0)
Compiled Dec 15 2017 12:32:42 (KEIL)


Board UID: 006a004f3436510b36383230


Initializing the wifi module...

I have reset, re-uploade dthe software with the same result.

Since there is no makefile avialable for the GW softare (STM32CubeFunctionPack_6LPWIFI1_V2.1.1), I am unable to debug it to see where it's going wrong.

 

So my questions are:

  • Has anyone made the example gateway and node as describe din teh link above work ?
  • Where can I get the makefiel for the STM32CubeFunctionPack_6LPWIFI1_V2.1.1 gateway software so I can build it myself in System Workbench ?

 

Cheers & TIA !

/T

Outcomes