AnsweredAssumed Answered

RE: STM32L053C8-Discovery -- project build errors?

Question asked by curtiss.richard on Apr 26, 2018
Latest reply on Apr 27, 2018 by curtiss.richard

Can someone please verify whether or not this project in STM32Cube_FW_L0_V1.10.0 builds without errors? I am trying to use TrueStudio 9.0.0 and only EWARM and MDK-ARM projects are provided. So, getting "include paths" setup has been a challenge (e.g. missing header stm32l0xx_hal_hid.h).

 

Edit:

Sorry about the previous long subject - first time user of this forum - wasn't clear on how to proceed.

 

Basically want to know if this "cube" is defective or not. Have spent many hours trying to get a build.

The missing header noted above is a show stopper, as it does not exist anywhere in the cube or anywhere else in the universe that Google explores.

 

Has anyone else tried to use this project?

Has anyone else experienced this problem?

Has anyone gotten a successful build using any IDE?

Has anyone even looked at this cube?

 

Thanks.

------------------------------------------------------------------------------------------------------------------

Edit_2

Installed EWARM and got a clean build (haven't yet tried to flash the discovery board).

 

Perhaps I can glean enough from the build log to get a TrueStudio project set up properly.

Outcomes