AnsweredAssumed Answered

Trying STM32f407 DFU. no luck

Question asked by beomki cho on Apr 25, 2018
Latest reply on Apr 25, 2018 by beomki cho

Hello! I'm trying to get DFU works on our customized board.

 

I tried to use internal DFU Bootloader, using BOOT0, BOOT1 pins

 

I connected some pins and made BOOT0  HIGH, BOOT1 LOW and plugged in USB Cable, No Luck!

 

Computer gives 'Unknown Device' so i started to find solution.

 

and searched through ST community. ended up here and asking for help.

 

here's where we are.

 

-. USB

   - MCP-DP is Pulled up to 3.3V by 1.5kR ( Made sure it's 1.5kR ) while MCP-DN isn't

   - ID Pin is Grounded

   - VBUS only goes to power up Regulator which supplies power to STM32F

      ( i did found VBUS_Sensing is PA9 and tried this method, no luck )

-. STM32F407ZET6

   - is working normally ( long as i know ) if connected through main power connector 

   - application doesn't work if powered by USB. ( even with BOOT0 at LOW )

    ( Does work with main power supply )

   - tried every combination of BOOT0, BOOT1 Setting

   - Cleared Readout protection ( OPTION BYTES )

   - Does have external 8MHz Crystal instead 25MHz

 

i also ended up trying STM32CUBE's DFU ( example source )

Computer does identifies STM32 in DFU mode, with CODE 10 error ( Cannot start device )

Outcomes