AnsweredAssumed Answered

Different binary sizes when building

Question asked by William Huang on Apr 23, 2018
Latest reply on Apr 24, 2018 by AvaTar

HI there,

This isn't a question related to ST products, but I'm just curious about something that I started noticing. I am developing my project on Atollic TrueSTUDIO, and when I build the project using the CDT Manged builder, it prints out the size information. I also have a makefile that builds the project as well. I run the makefile under Cygwin and have it print the size information, and the size is different from what was reported by Atollic. I also tried the exact same makefile under MSYS, and the size is also different from both the Cygwin build and the Atollic build. In all cases, the difference in size are just a few bytes.

 

The project still functions normally (from what I see so far), but I just find weird (and maybe worrisome) that the build sizes are all different.

 

I was wondering if anyone else has seen this and if they know anything about it? Thanks.

Outcomes