AnsweredAssumed Answered

STM32F103C8T6 USB Device Error

Question asked by AKIN ROBOTICS on Apr 21, 2018

Hello everyone,

I've been trying to build a USB CDC project with STM32F103C8T6 but couldn't get it to go.

I've built USB projects on STM32F4/4015/407 and 32F103RCT with using CubeMX. 3 of them worked perfectly normal I see the devices on COM list. But when I try to do same things with 32F103C8T6, I couldn't get it working. 

First it was going directly hardfault error handler from startup file. after a while I changed the CubeMx F1 series software package to an old one FW1_1.4 

Its now runs the main but still as an unknown device.

 

   tried to change heap and stack sizes -> didn't work.

   tried to change Middlewares HID/CDC/MassStorage, didn't work.

   tried to build an empty project again other 3 worked but C8T6 didn't work.

   I couldn't find a solution and I'm out of ideas rightnow 

My. Keil version is 5.23 

Cube Mx version is 4.25

OS Win10

I'm open to any suggestions.

Best regards,

Akin,

Outcomes