AnsweredAssumed Answered

STM32F407VG Discovery + M24SR

Question asked by Egor Vasilyev on Apr 18, 2018

   Hello everyone, I'm trying to connect M24SR to the microprocessor STM32fF407.
   Previously used the STM32fF107VC processor, and a slightly corrected demo version of the software for the M24SR Discovery, everything worked perfectly. But when the controller changed, I2C stopped working. The tampering is fed from the resonator on the board (8 MHZ) through PLL, it accelerated it to 72 MHZ. The I2C speed dropped to 100 kHz, the connection is correct, the M24SR itself works adequately (it was rechecked again on the old board).
The third day I struggle over this problem, tried to just establish a connection on I2C in another project with the same stone, I used a Cube, the answer from Slave does not come (the request from the master goes, the timing is exactly 72 MHz board working).
   In what there can be a snag (in initialization I changed only I2C -> I2S2, GIPO SDA, SKL, GPO and RF, everything else is library).
   Perhaps there is some standard project that I did not come across or a standard problem that I did not reach?

   Below are 2 archives: project_files with libraries, which I use and the second, with the standard example of 32.

Outcomes